29 lines
531 B
Makefile
Executable File
29 lines
531 B
Makefile
Executable File
#!/usr/bin/make -f
|
|
|
|
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
|
|
export DEB_LDFLAGS_MAINT_APPEND = -Wl,-O1 -Wl,-z,defs -Wl,--as-needed
|
|
|
|
%:
|
|
dh $@ --with gnome,gir
|
|
|
|
override_dh_autoreconf:
|
|
dh_autoreconf --as-needed
|
|
|
|
override_dh_auto_configure:
|
|
dh_auto_configure -- \
|
|
--enable-gtk-doc \
|
|
--enable-static
|
|
|
|
override_dh_install:
|
|
find debian -name '*.la' -print -delete
|
|
dh_install
|
|
|
|
override_dh_missing:
|
|
dh_missing --fail-missing
|
|
|
|
override_dh_makeshlibs:
|
|
dh_makeshlibs -- -c4
|
|
|
|
override_dh_auto_test:
|
|
xvfb-run -a dh_auto_test
|