30 lines
1.3 KiB
Plaintext
30 lines
1.3 KiB
Plaintext
Description: Makefile add correct flags
|
|
The sedscript creation was missing CPPGLAGS
|
|
More seriously the libnetsnmptrapd library linking was missing LDFLAGS
|
|
Author: Craig Small <csmall@debian.org>
|
|
Bug: https://github.com/net-snmp/net-snmp/issues/29
|
|
Reviewed-by: Craig Small <csmall@debian.org>
|
|
Last-Update: 2019-10-16
|
|
--- a/Makefile.in
|
|
+++ b/Makefile.in
|
|
@@ -114,7 +114,7 @@
|
|
# local build rules
|
|
#
|
|
sedscript: sedscript.in include/net-snmp/net-snmp-config.h $(srcdir)/agent/mibgroup/mibdefs.h
|
|
- $(CPP) $(srcdir)/sedscript.in | egrep '^s[/#]' | sed 's/REMOVEME//g;s# */#/#g;s/ *#/#/g;s#/ *#/#g;s/# g/#g/;' > sedscript
|
|
+ $(CPP) $(CPPFLAGS) $(srcdir)/sedscript.in | egrep '^s[/#]' | sed 's/REMOVEME//g;s# */#/#g;s/ *#/#/g;s#/ *#/#g;s/# g/#g/;' > sedscript
|
|
echo 's/VERSIONINFO/$(VERSION)/g' >> sedscript
|
|
echo 's#DATADIR#$(datadir)#g' >> sedscript
|
|
echo 's#LIBDIR#$(libdir)#g' >> sedscript
|
|
--- a/apps/Makefile.in
|
|
+++ b/apps/Makefile.in
|
|
@@ -232,7 +232,7 @@
|
|
$(LINK) ${CFLAGS} -o $@ snmppcap.$(OSUFFIX) ${LDFLAGS} ${LIBS} -lpcap
|
|
|
|
libnetsnmptrapd.$(LIB_EXTENSION)$(LIB_VERSION): $(LLIBTRAPD_OBJS)
|
|
- $(LIB_LD_CMD) $@ ${LLIBTRAPD_OBJS} $(MIBLIB) $(USELIBS) $(PERLLDOPTS_FOR_LIBS) $(LIB_LD_LIBS)
|
|
+ $(LIB_LD_CMD) $@ ${LLIBTRAPD_OBJS} $(MIBLIB) $(USELIBS) $(PERLLDOPTS_FOR_LIBS) $(LDFLAGS)
|
|
$(RANLIB) $@
|
|
|
|
snmpinforminstall:
|