filters: removing rostest dependency
This commit is contained in:
parent
10675b2b63
commit
02049510ac
|
@ -0,0 +1,33 @@
|
||||||
|
From 5aef0d6619394df17bffe743071295ad041b5794 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
|
||||||
|
Date: Tue, 4 Feb 2014 16:02:09 +0100
|
||||||
|
Subject: [PATCH] make rostest in CMakeLists optional (ros/rosdistro#3010)
|
||||||
|
|
||||||
|
---
|
||||||
|
CMakeLists.txt | 3 ++-
|
||||||
|
1 file changed, 2 insertions(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||||
|
index ccb54f9..97eea51 100644
|
||||||
|
--- a/CMakeLists.txt
|
||||||
|
+++ b/CMakeLists.txt
|
||||||
|
@@ -5,7 +5,7 @@ project(filters)
|
||||||
|
# Find dependencies
|
||||||
|
##############################################################################
|
||||||
|
|
||||||
|
-find_package(catkin REQUIRED COMPONENTS pluginlib roslib roscpp rosconsole rostest)
|
||||||
|
+find_package(catkin REQUIRED COMPONENTS pluginlib roslib roscpp rosconsole)
|
||||||
|
find_package(Boost COMPONENTS system filesystem thread REQUIRED)
|
||||||
|
|
||||||
|
include_directories(
|
||||||
|
@@ -41,6 +41,7 @@ add_library(transfer_function src/transfer_function.cpp)
|
||||||
|
target_link_libraries(transfer_function ${catkin_LIBRARIES} ${Boost_LIBRARIES})
|
||||||
|
|
||||||
|
if(CATKIN_ENABLE_TESTING)
|
||||||
|
+ find_package(rostest)
|
||||||
|
# Test median filter
|
||||||
|
add_executable(median_test EXCLUDE_FROM_ALL test/test_median.cpp )
|
||||||
|
target_link_libraries(median_test median ${catkin_LIBRARIES} ${Boost_LIBRARIES} ${GTEST_LIBRARIES})
|
||||||
|
--
|
||||||
|
1.8.3.2
|
||||||
|
|
|
@ -3,12 +3,13 @@ SECTION = "devel"
|
||||||
LICENSE = "BSD"
|
LICENSE = "BSD"
|
||||||
LIC_FILES_CHKSUM = "file://package.xml;beginline=11;endline=11;md5=d566ef916e9dedc494f5f793a6690ba5"
|
LIC_FILES_CHKSUM = "file://package.xml;beginline=11;endline=11;md5=d566ef916e9dedc494f5f793a6690ba5"
|
||||||
|
|
||||||
DEPENDS = "roslib rosconsole roscpp pluginlib rostest"
|
DEPENDS = "roslib rosconsole roscpp pluginlib"
|
||||||
|
|
||||||
SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
|
SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
|
||||||
SRC_URI[md5sum] = "0dd26504be16afa7816e9a5aa11715f1"
|
SRC_URI[md5sum] = "0dd26504be16afa7816e9a5aa11715f1"
|
||||||
SRC_URI[sha256sum] = "fb71f1fbeaf89726877fce66dce1db8957c5cc6dffa1973d6a104a10233f8237"
|
SRC_URI[sha256sum] = "fb71f1fbeaf89726877fce66dce1db8957c5cc6dffa1973d6a104a10233f8237"
|
||||||
|
|
||||||
SRC_URI += "file://0001-check-for-CATKIN_ENABLE_TESTING.patch"
|
SRC_URI += "file://0001-check-for-CATKIN_ENABLE_TESTING.patch; \
|
||||||
|
file://0001-make-rostest-in-CMakeLists-optional-ros-rosdistro-30.patch"
|
||||||
|
|
||||||
inherit catkin
|
inherit catkin
|
||||||
|
|
Loading…
Reference in New Issue