ros-comm: replacing patch by patch provided upstream
This commit is contained in:
parent
97c43ed571
commit
0738b901d6
|
@ -0,0 +1,88 @@
|
|||
From 560ce8a8855a43565d1798af19cc943c61a72e7f Mon Sep 17 00:00:00 2001
|
||||
From: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
|
||||
Date: Tue, 4 Feb 2014 12:57:23 +0100
|
||||
Subject: [PATCH] make rostest in CMakeLists optional (ros/rosdistro#3010)
|
||||
|
||||
---
|
||||
tools/rosnode/CMakeLists.txt | 3 ++-
|
||||
tools/rostopic/CMakeLists.txt | 3 ++-
|
||||
tools/topic_tools/CMakeLists.txt | 3 ++-
|
||||
utilities/roswtf/CMakeLists.txt | 3 ++-
|
||||
4 files changed, 8 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/tools/rosnode/CMakeLists.txt b/tools/rosnode/CMakeLists.txt
|
||||
index a7347b4..f305890 100644
|
||||
--- a/tools/rosnode/CMakeLists.txt
|
||||
+++ b/tools/rosnode/CMakeLists.txt
|
||||
@@ -1,10 +1,11 @@
|
||||
cmake_minimum_required(VERSION 2.8.3)
|
||||
project(rosnode)
|
||||
-find_package(catkin REQUIRED COMPONENTS rostest)
|
||||
+find_package(catkin REQUIRED)
|
||||
catkin_package()
|
||||
|
||||
catkin_python_setup()
|
||||
|
||||
if(CATKIN_ENABLE_TESTING)
|
||||
+ find_package(rostest)
|
||||
add_rostest(test/rosnode.test)
|
||||
endif()
|
||||
diff --git a/tools/rostopic/CMakeLists.txt b/tools/rostopic/CMakeLists.txt
|
||||
index 0551583..db7917b 100644
|
||||
--- a/tools/rostopic/CMakeLists.txt
|
||||
+++ b/tools/rostopic/CMakeLists.txt
|
||||
@@ -1,6 +1,6 @@
|
||||
cmake_minimum_required(VERSION 2.8.3)
|
||||
project(rostopic)
|
||||
-find_package(catkin REQUIRED COMPONENTS rostest)
|
||||
+find_package(catkin REQUIRED)
|
||||
catkin_package()
|
||||
|
||||
catkin_python_setup()
|
||||
@@ -9,5 +9,6 @@ install(PROGRAMS scripts/rostopic
|
||||
DESTINATION ${CATKIN_PACKAGE_BIN_DESTINATION})
|
||||
|
||||
if(CATKIN_ENABLE_TESTING)
|
||||
+ find_package(rostest)
|
||||
add_rostest(test/rostopic.test)
|
||||
endif()
|
||||
diff --git a/tools/topic_tools/CMakeLists.txt b/tools/topic_tools/CMakeLists.txt
|
||||
index e441b9a..2d52451 100644
|
||||
--- a/tools/topic_tools/CMakeLists.txt
|
||||
+++ b/tools/topic_tools/CMakeLists.txt
|
||||
@@ -1,6 +1,6 @@
|
||||
cmake_minimum_required(VERSION 2.8.3)
|
||||
project(topic_tools)
|
||||
-find_package(catkin COMPONENTS cpp_common message_generation rosconsole roscpp rostest rostime rosunit std_msgs xmlrpcpp)
|
||||
+find_package(catkin COMPONENTS cpp_common message_generation rosconsole roscpp rostime std_msgs xmlrpcpp)
|
||||
|
||||
include_directories(include)
|
||||
include_directories(${catkin_INCLUDE_DIRS})
|
||||
@@ -62,6 +62,7 @@ install(PROGRAMS
|
||||
|
||||
#Testing
|
||||
if(CATKIN_ENABLE_TESTING)
|
||||
+ find_package(rostest rosunit)
|
||||
catkin_add_gtest(${PROJECT_NAME}-utest test/utest.cpp)
|
||||
if(TARGET ${PROJECT_NAME}-utest)
|
||||
target_link_libraries(${PROJECT_NAME}-utest topic_tools)
|
||||
diff --git a/utilities/roswtf/CMakeLists.txt b/utilities/roswtf/CMakeLists.txt
|
||||
index dccb342..97a34ff 100644
|
||||
--- a/utilities/roswtf/CMakeLists.txt
|
||||
+++ b/utilities/roswtf/CMakeLists.txt
|
||||
@@ -1,10 +1,11 @@
|
||||
cmake_minimum_required(VERSION 2.8.3)
|
||||
project(roswtf)
|
||||
-find_package(catkin REQUIRED COMPONENTS rostest)
|
||||
+find_package(catkin REQUIRED)
|
||||
catkin_package()
|
||||
catkin_python_setup()
|
||||
|
||||
if(CATKIN_ENABLE_TESTING)
|
||||
+ find_package(rostest)
|
||||
add_rostest(test/roswtf.test)
|
||||
catkin_add_nosetests(test)
|
||||
endif()
|
||||
--
|
||||
1.8.3.2
|
||||
|
|
@ -1,62 +0,0 @@
|
|||
From 0f16232f1bac7d03cce598bd305bcdd4c456f4ed Mon Sep 17 00:00:00 2001
|
||||
From: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
|
||||
Date: Sat, 21 Sep 2013 15:20:11 +0200
|
||||
Subject: [PATCH] rostest is optional
|
||||
|
||||
---
|
||||
tools/rosnode/CMakeLists.txt | 6 +++++-
|
||||
tools/rostopic/CMakeLists.txt | 6 +++++-
|
||||
utilities/roswtf/CMakeLists.txt | 6 +++++-
|
||||
3 files changed, 15 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/tools/rosnode/CMakeLists.txt b/tools/rosnode/CMakeLists.txt
|
||||
index a7347b4..b397106 100644
|
||||
--- a/tools/rosnode/CMakeLists.txt
|
||||
+++ b/tools/rosnode/CMakeLists.txt
|
||||
@@ -1,6 +1,10 @@
|
||||
cmake_minimum_required(VERSION 2.8.3)
|
||||
project(rosnode)
|
||||
-find_package(catkin REQUIRED COMPONENTS rostest)
|
||||
+if(CATKIN_ENABLE_TESTING)
|
||||
+ find_package(catkin REQUIRED COMPONENTS rostest)
|
||||
+else()
|
||||
+ find_package(catkin REQUIRED)
|
||||
+endif()
|
||||
catkin_package()
|
||||
|
||||
catkin_python_setup()
|
||||
diff --git a/tools/rostopic/CMakeLists.txt b/tools/rostopic/CMakeLists.txt
|
||||
index 0551583..24fbed0 100644
|
||||
--- a/tools/rostopic/CMakeLists.txt
|
||||
+++ b/tools/rostopic/CMakeLists.txt
|
||||
@@ -1,6 +1,10 @@
|
||||
cmake_minimum_required(VERSION 2.8.3)
|
||||
project(rostopic)
|
||||
-find_package(catkin REQUIRED COMPONENTS rostest)
|
||||
+if(CATKIN_ENABLE_TESTING)
|
||||
+ find_package(catkin REQUIRED COMPONENTS rostest)
|
||||
+else()
|
||||
+ find_package(catkin REQUIRED)
|
||||
+endif()
|
||||
catkin_package()
|
||||
|
||||
catkin_python_setup()
|
||||
diff --git a/utilities/roswtf/CMakeLists.txt b/utilities/roswtf/CMakeLists.txt
|
||||
index dccb342..cfd0c11 100644
|
||||
--- a/utilities/roswtf/CMakeLists.txt
|
||||
+++ b/utilities/roswtf/CMakeLists.txt
|
||||
@@ -1,6 +1,10 @@
|
||||
cmake_minimum_required(VERSION 2.8.3)
|
||||
project(roswtf)
|
||||
-find_package(catkin REQUIRED COMPONENTS rostest)
|
||||
+if(CATKIN_ENABLE_TESTING)
|
||||
+ find_package(catkin REQUIRED COMPONENTS rostest)
|
||||
+else()
|
||||
+ find_package(catkin REQUIRED)
|
||||
+endif()
|
||||
catkin_package()
|
||||
catkin_python_setup()
|
||||
|
||||
--
|
||||
1.7.10.4
|
||||
|
|
@ -2,7 +2,7 @@ SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilena
|
|||
SRC_URI[md5sum] = "f561ebda19fa6e737d5f06e49e925be4"
|
||||
SRC_URI[sha256sum] = "3572418e3149b54493770695e5241584f5daf9e849ab70007b16d4ce848d7e12"
|
||||
|
||||
SRC_URI += "file://0001-rostest-is-optional.patch;patchdir=../.."
|
||||
SRC_URI += "file://0001-make-rostest-in-CMakeLists-optional-ros-rosdistro-30.patch;patchdir=../.."
|
||||
|
||||
ROS_PKG_SUBDIR ?= ""
|
||||
S = "${WORKDIR}/${ROS_SP}/${ROS_PKG_SUBDIR}/${ROS_BPN}"
|
||||
|
|
Loading…
Reference in New Issue