Merge pull request #528 from bulwahn/indigo-updates
recipe updates for indigo distribution on 2017-06-30
This commit is contained in:
commit
08516c36c6
|
@ -1,34 +0,0 @@
|
||||||
From 8f40c9b006c70326bcfca73daebb54187a65aa5e Mon Sep 17 00:00:00 2001
|
|
||||||
From: Dmitry Rozhkov <dmitry.rozhkov@linux.intel.com>
|
|
||||||
Date: Mon, 26 Jun 2017 17:05:01 +0300
|
|
||||||
Subject: [PATCH] [ecl_containers] Fix gcc v7.1 compilation issue
|
|
||||||
|
|
||||||
When built with gcc v7.1 compilation fails with an error message
|
|
||||||
about using an expression as a function when updating
|
|
||||||
the private attribute FloatContainerFormatter.prm_width.
|
|
||||||
|
|
||||||
The patch uses assignment to update the attribute.
|
|
||||||
|
|
||||||
Upstream-Status: Accepted [https://github.com/stonier/ecl_core/pull/58]
|
|
||||||
|
|
||||||
Signed-off-by: Dmitry Rozhkov <dmitry.rozhkov@linux.intel.com>
|
|
||||||
---
|
|
||||||
ecl_containers/include/ecl/containers/common/formatters.hpp | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/ecl_containers/include/ecl/containers/common/formatters.hpp b/ecl_containers/include/ecl/containers/common/formatters.hpp
|
|
||||||
index e26ec60..5f4c026 100644
|
|
||||||
--- a/ecl_containers/include/ecl/containers/common/formatters.hpp
|
|
||||||
+++ b/ecl_containers/include/ecl/containers/common/formatters.hpp
|
|
||||||
@@ -123,7 +123,7 @@ class ECL_LOCAL FloatContainerFormatter {
|
|
||||||
* @param w : the width to use for the inserted float.
|
|
||||||
* @return FloatContainerFormatter& : this formatter readied for use with a stream.
|
|
||||||
*/
|
|
||||||
- FloatContainerFormatter& operator()(const unsigned int p, const int w) { format.precision(p); prm_width(w); return *this; } // Permanent
|
|
||||||
+ FloatContainerFormatter& operator()(const unsigned int p, const int w) { format.precision(p); prm_width = w; return *this; } // Permanent
|
|
||||||
/**
|
|
||||||
* Convenient stream formatter. This function directly readies the formatter
|
|
||||||
* with the specified container and the stored (permanent) settings.
|
|
||||||
--
|
|
||||||
2.9.3
|
|
||||||
|
|
|
@ -6,5 +6,3 @@ LIC_FILES_CHKSUM = "file://package.xml;beginline=14;endline=14;md5=d566ef916e9de
|
||||||
DEPENDS = "ecl-license ecl-config ecl-errors ecl-exceptions ecl-formatters ecl-converters ecl-mpl ecl-type-traits ecl-utilities"
|
DEPENDS = "ecl-license ecl-config ecl-errors ecl-exceptions ecl-formatters ecl-converters ecl-mpl ecl-type-traits ecl-utilities"
|
||||||
|
|
||||||
require ecl-core.inc
|
require ecl-core.inc
|
||||||
|
|
||||||
SRC_URI += "file://0001-ecl_containers-Fix-gcc-v7.1-compilation-issue.patch;patchdir=.."
|
|
|
@ -1,6 +1,6 @@
|
||||||
SRC_URI = "https://github.com/stonier/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
|
SRC_URI = "https://github.com/stonier/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
|
||||||
SRC_URI[md5sum] = "625fa08e6e23adb58d9de2caaaf2be08"
|
SRC_URI[md5sum] = "78f4275f5c7cec759ca096e22d1570d2"
|
||||||
SRC_URI[sha256sum] = "ea2e3e8e7572d6e18374b8be3736ce4761ea1f18c6af046af3fe4fcaadfc5285"
|
SRC_URI[sha256sum] = "358e9de2a31cf0df70e1b5d6e0d9dc5f00d042f1974c786eabbb7bcb48151477"
|
||||||
|
|
||||||
S = "${WORKDIR}/${ROS_SP}/${ROS_BPN}"
|
S = "${WORKDIR}/${ROS_SP}/${ROS_BPN}"
|
||||||
|
|
||||||
|
|
|
@ -1,6 +1,6 @@
|
||||||
SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
|
SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
|
||||||
SRC_URI[md5sum] = "c5a9abf8db49abfbb05cb3ed88ef1931"
|
SRC_URI[md5sum] = "e8c39c7fe0033e7512138b9c94649c73"
|
||||||
SRC_URI[sha256sum] = "48f11db9a1be8accf6bce4dc20efa825f8fab1697d8620690eb51051ddd2c6b3"
|
SRC_URI[sha256sum] = "2f7f58064c960fc56de15fdedfd883f62122bd44874787f13c8b4d8a77c45380"
|
||||||
|
|
||||||
S = "${WORKDIR}/${ROS_SP}/${ROS_BPN}"
|
S = "${WORKDIR}/${ROS_SP}/${ROS_BPN}"
|
||||||
|
|
||||||
|
|
|
@ -1,36 +0,0 @@
|
||||||
From 9835342260d40cfeb4d062be1d6ddcc85c5037d8 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Lukas Bulwahn <lukas.bulwahn@gmail.com>
|
|
||||||
Date: Tue, 4 Apr 2017 11:43:26 +0200
|
|
||||||
Subject: [PATCH] make rostest in CMakeLists optional (ros/rosdistro#3010)
|
|
||||||
|
|
||||||
Upstream-Status: Submitted [https://github.com/ros/executive_smach/pull/45]
|
|
||||||
|
|
||||||
Signed-off-by: Lukas Bulwahn <lukas.bulwahn@gmail.com>
|
|
||||||
---
|
|
||||||
smach_ros/CMakeLists.txt | 3 ++-
|
|
||||||
1 file changed, 2 insertions(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/smach_ros/CMakeLists.txt b/smach_ros/CMakeLists.txt
|
|
||||||
index e5694b1..f409e2e 100644
|
|
||||||
--- a/smach_ros/CMakeLists.txt
|
|
||||||
+++ b/smach_ros/CMakeLists.txt
|
|
||||||
@@ -2,7 +2,7 @@ cmake_minimum_required(VERSION 2.8.3)
|
|
||||||
|
|
||||||
project(smach_ros)
|
|
||||||
|
|
||||||
-find_package(catkin REQUIRED COMPONENTS rostest)
|
|
||||||
+find_package(catkin REQUIRED)
|
|
||||||
|
|
||||||
catkin_python_setup()
|
|
||||||
|
|
||||||
@@ -11,6 +11,7 @@ catkin_package(
|
|
||||||
)
|
|
||||||
|
|
||||||
if(CATKIN_ENABLE_TESTING)
|
|
||||||
+ find_package(rostest REQUIRED)
|
|
||||||
add_rostest(test/state_machine.test)
|
|
||||||
add_rostest(test/sequence.test)
|
|
||||||
add_rostest(test/concurrence.test)
|
|
||||||
--
|
|
||||||
2.5.5
|
|
||||||
|
|
|
@ -4,5 +4,3 @@ LICENSE = "BSD"
|
||||||
LIC_FILES_CHKSUM = "file://package.xml;beginline=17;endline=17;md5=d566ef916e9dedc494f5f793a6690ba5"
|
LIC_FILES_CHKSUM = "file://package.xml;beginline=17;endline=17;md5=d566ef916e9dedc494f5f793a6690ba5"
|
||||||
|
|
||||||
require executive-smach.inc
|
require executive-smach.inc
|
||||||
|
|
||||||
SRC_URI += "file://0001-make-rostest-in-CMakeLists-optional-ros-rosdistro-30.patch;striplevel=2"
|
|
|
@ -1,52 +0,0 @@
|
||||||
From 40e8f29f5ef9024bf048b48b0e51b906f9f5aa2a Mon Sep 17 00:00:00 2001
|
|
||||||
From: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
|
|
||||||
Date: Tue, 20 Jan 2015 08:41:49 +0100
|
|
||||||
Subject: [PATCH] gscam_nodelet.h: include scoped_ptr.hpp to compile with boost
|
|
||||||
1.57
|
|
||||||
|
|
||||||
When compiling gscam with the currently latest boost version 1.57,
|
|
||||||
it fails with:
|
|
||||||
In file included from [...]/src/gscam_nodelet.cpp:5:0:
|
|
||||||
[...]/include/gscam/gscam_nodelet.h:20:12: error: 'scoped_ptr' in namespace 'boost' does not name a template type
|
|
||||||
boost::scoped_ptr<GSCam> gscam_driver_;
|
|
||||||
^
|
|
||||||
[...]/include/gscam/gscam_nodelet.h:21:12: error: 'scoped_ptr' in namespace 'boost' does not name a template type
|
|
||||||
boost::scoped_ptr<boost::thread> stream_thread_;
|
|
||||||
^
|
|
||||||
|
|
||||||
It seems that the dependencies of boost/thread.hpp have changed
|
|
||||||
and boost/scoped_ptr.hpp is not included anymore with
|
|
||||||
boost/thread.hpp. Hence, the scoped_ptr is not defined in the
|
|
||||||
gscam_nodelet header. After scanning quickly through the release
|
|
||||||
notes of version 1.57, the boost bug tracker and a few changesets,
|
|
||||||
I could not find not a hint what has changed in the thread library
|
|
||||||
that gscam must include scoped_ptr itself.
|
|
||||||
|
|
||||||
This commit simply addresses the compiler error by explicitly
|
|
||||||
adding boost's scoped_ptr header in the gscam_nodelet header.
|
|
||||||
As this commit also compiles with boost version 1.56, the commit
|
|
||||||
is not expected to cause any problems with other build
|
|
||||||
configurations.
|
|
||||||
|
|
||||||
Signed-off-by: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
|
|
||||||
|
|
||||||
Upstream-Status: Accepted
|
|
||||||
---
|
|
||||||
include/gscam/gscam_nodelet.h | 1 +
|
|
||||||
1 file changed, 1 insertion(+)
|
|
||||||
|
|
||||||
diff --git a/include/gscam/gscam_nodelet.h b/include/gscam/gscam_nodelet.h
|
|
||||||
index 60fc25f..c450dab 100644
|
|
||||||
--- a/include/gscam/gscam_nodelet.h
|
|
||||||
+++ b/include/gscam/gscam_nodelet.h
|
|
||||||
@@ -6,6 +6,7 @@
|
|
||||||
#include <gscam/gscam.h>
|
|
||||||
|
|
||||||
#include <boost/thread.hpp>
|
|
||||||
+#include <boost/scoped_ptr.hpp>
|
|
||||||
|
|
||||||
namespace gscam {
|
|
||||||
class GSCamNodelet : public nodelet::Nodelet
|
|
||||||
--
|
|
||||||
1.9.3
|
|
||||||
|
|
|
@ -7,9 +7,7 @@ DEPENDS = "gstreamer gst-plugins-base gst-plugins-good nodelet opencv roscpp ima
|
||||||
camera-calibration-parsers camera-info-manager"
|
camera-calibration-parsers camera-info-manager"
|
||||||
|
|
||||||
SRC_URI = "https://github.com/ros-drivers/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
|
SRC_URI = "https://github.com/ros-drivers/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
|
||||||
SRC_URI[md5sum] = "c20617a0db24124168fe968365ecb990"
|
SRC_URI[md5sum] = "b0512882e06f5cdd4c6015f16dceb346"
|
||||||
SRC_URI[sha256sum] = "56fbb0c31d32cf4ff1a1b702732c3e8373e6d541c431329bcd931bd705991a35"
|
SRC_URI[sha256sum] = "84d02ed9a0bed769bebddfb67d27085ae779aaf9ab1311aaad94e9d17aa0fbc6"
|
||||||
|
|
||||||
SRC_URI += "file://0001-gscam_nodelet.h-include-scoped_ptr.hpp-to-compile-wi.patch"
|
|
||||||
|
|
||||||
inherit catkin
|
inherit catkin
|
|
@ -1,6 +1,6 @@
|
||||||
SRC_URI = "https://github.com/ros-planning/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
|
SRC_URI = "https://github.com/ros-planning/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
|
||||||
SRC_URI[md5sum] = "6ebfe9fc33837fcea079bcd7f3741eb5"
|
SRC_URI[md5sum] = "6b8c169cb96ae4eb4fe3a67acb77915b"
|
||||||
SRC_URI[sha256sum] = "9ec381e6589a663b03f8468d095599b90b14e102be221f9b19dc8b833dbc05bb"
|
SRC_URI[sha256sum] = "880dd7bf65f82eac3dd87104bd30389fcf8af18790fc15e6597964aec50db5a1"
|
||||||
|
|
||||||
S = "${WORKDIR}/${ROS_SP}/${ROS_BPN}"
|
S = "${WORKDIR}/${ROS_SP}/${ROS_BPN}"
|
||||||
|
|
||||||
|
|
Loading…
Reference in New Issue