rosauth: remove rostest dependency

This commit is contained in:
Lukas Bulwahn 2017-04-06 11:03:52 +02:00
parent c6b42997d6
commit 0c75eb1ad9
2 changed files with 39 additions and 1 deletions

View File

@ -0,0 +1,36 @@
From b63fb159dcf85f450c5770f55f57b281ab9cce68 Mon Sep 17 00:00:00 2001
From: Lukas Bulwahn <lukas.bulwahn@gmail.com>
Date: Tue, 4 Apr 2017 06:04:39 +0200
Subject: [PATCH] make rostest in CMakeLists optional (ros/rosdistro#3010)
Upstream-Status: Submitted [https://github.com/GT-RAIL/rosauth/pull/11]
Signed-off-by: Lukas Bulwahn <lukas.bulwahn@gmail.com>
---
CMakeLists.txt | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9d45c59..434e6ce 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -4,7 +4,7 @@ project(rosauth)
## Find catkin macros and libraries
## if COMPONENTS list like find_package(catkin REQUIRED COMPONENTS xyz)
## is used, also find other catkin packages
-find_package(catkin REQUIRED COMPONENTS roscpp message_generation rostest)
+find_package(catkin REQUIRED COMPONENTS roscpp message_generation)
#######################################
## Declare ROS messages and services ##
@@ -62,6 +62,7 @@ install(TARGETS ros_mac_authentication
#############
if(CATKIN_ENABLE_TESTING)
+ find_package(rostest)
## Add gtest based cpp test target and link libraries
add_executable(ros_mac_authentication_test test/ros_mac_authentication_test.cpp)
add_dependencies(ros_mac_authentication_test ${PROJECT_NAME}_gencpp)
--
2.5.5

View File

@ -3,12 +3,14 @@ SECTION = "devel"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://package.xml;beginline=10;endline=10;md5=d566ef916e9dedc494f5f793a6690ba5"
DEPENDS = "roscpp rostest"
DEPENDS = "roscpp"
SRC_URI = "https://github.com/WPI-RAIL/rosauth/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
SRC_URI[md5sum] = "0e165e867239157266aa2e4c192244bf"
SRC_URI[sha256sum] = "c85c4163c94d20bce9864180785210bfe3dfd110114f18212bd711d1be87c48e"
SRC_URI += "file://0001-make-rostest-in-CMakeLists-optional-ros-rosdistro-30.patch"
S = "${WORKDIR}/${ROS_SP}"
inherit catkin