tf: replacing patch by patch provided upstream

This commit is contained in:
Lukas Bulwahn 2014-02-04 16:37:26 +01:00
parent 2584cec31e
commit 10675b2b63
3 changed files with 35 additions and 31 deletions

View File

@ -0,0 +1,34 @@
From 18e81e33c052e26ae60259708095a2a933f75fd1 Mon Sep 17 00:00:00 2001
From: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
Date: Tue, 4 Feb 2014 16:02:48 +0100
Subject: [PATCH] make rostest in CMakeLists optional (ros/rosdistro#3010)
---
tf/CMakeLists.txt | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)
diff --git a/tf/CMakeLists.txt b/tf/CMakeLists.txt
index fa4a42f..c6988e1 100644
--- a/tf/CMakeLists.txt
+++ b/tf/CMakeLists.txt
@@ -4,7 +4,7 @@ project(tf)
find_package(catkin REQUIRED)
find_package(Boost REQUIRED thread signals)
-find_package(catkin REQUIRED angles geometry_msgs message_filters message_generation rosconsole roscpp rostest rostime sensor_msgs std_msgs tf2_ros)
+find_package(catkin REQUIRED angles geometry_msgs message_filters message_generation rosconsole roscpp rostime sensor_msgs std_msgs tf2_ros)
catkin_python_setup()
@@ -48,6 +48,8 @@ target_link_libraries(static_transform_publisher ${PROJECT_NAME})
# Tests
if(CATKIN_ENABLE_TESTING)
+find_package(rostest)
+
catkin_add_gtest(tf_unittest test/tf_unittest.cpp)
target_link_libraries(tf_unittest ${PROJECT_NAME})
--
1.8.3.2

View File

@ -1,30 +0,0 @@
From 9f1e801c6de00287658f1bae21048f37bb9bb198 Mon Sep 17 00:00:00 2001
From: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
Date: Sat, 21 Sep 2013 16:13:16 +0200
Subject: [PATCH] rostest is optional
---
tf/CMakeLists.txt | 7 ++++++-
1 file changed, 6 insertions(+), 1 deletion(-)
diff --git a/tf/CMakeLists.txt b/tf/CMakeLists.txt
index e8d3044..2d36df3 100644
--- a/tf/CMakeLists.txt
+++ b/tf/CMakeLists.txt
@@ -4,7 +4,12 @@ project(tf)
find_package(catkin REQUIRED)
find_package(Boost REQUIRED thread signals)
-find_package(catkin REQUIRED angles geometry_msgs message_filters message_generation rosconsole roscpp rostest rostime sensor_msgs std_msgs tf2_ros)
+
+if(CATKIN_ENABLE_TESTING)
+ find_package(catkin REQUIRED angles geometry_msgs message_filters message_generation rosconsole roscpp rostest rostime sensor_msgs std_msgs tf2_ros)
+else()
+ find_package(catkin REQUIRED angles geometry_msgs message_filters message_generation rosconsole roscpp rostime sensor_msgs std_msgs tf2_ros)
+endif()
catkin_python_setup()
--
1.7.10.4

View File

@ -7,6 +7,6 @@ DEPENDS = "angles geometry-msgs message-filters sensor-msgs tf2-ros"
require geometry.inc
SRC_URI += "file://0001-rostest-is-optional.patch;striplevel=2"
SRC_URI += "file://0001-make-rostest-in-CMakeLists-optional-ros-rosdistro-30.patch;striplevel=2"
RDEPENDS_${PN} = "python-numpy"