Merge pull request #272 from bulwahn/master-next
more updates and some minor improvements
This commit is contained in:
commit
177585a787
|
@ -2,7 +2,7 @@
|
|||
# Copyright (c) 2013 Stefan Herbrechtsmeier, Bielefeld University
|
||||
#
|
||||
|
||||
inherit cmake distutils-base ros
|
||||
inherit cmake distutils-base ros faulty-solibs
|
||||
|
||||
DEPENDS_prepend = "${@['catkin-native ', ''][d.getVar('BPN', True) == 'catkin']}"
|
||||
|
||||
|
|
|
@ -0,0 +1,5 @@
|
|||
# Ideally, the software packages upstream should be fixed to provide dynamic
|
||||
# libraries with version number and symlinks without version number to them.
|
||||
# This class sets up bitbake to handle improper set up software packages.
|
||||
FILES_SOLIBSDEV = ""
|
||||
FILES_${PN} += "${libdir}/lib*${SOLIBSDEV}"
|
|
@ -7,9 +7,6 @@ ROS_BPN = "${@d.getVar('BPN', True).replace('-', '_')}"
|
|||
ROS_SPN ?= "${ROS_BPN}"
|
||||
ROS_SP = "${ROS_SPN}-${PV}"
|
||||
|
||||
FILES_SOLIBSDEV = ""
|
||||
FILES_${PN} += "${libdir}/lib*${SOLIBSDEV}"
|
||||
|
||||
FILES_${PN} += "\
|
||||
${prefix}/etc \
|
||||
${datadir}/ros/config/${ROS_BPN}.config \
|
||||
|
|
|
@ -15,6 +15,8 @@ environment and the ROS layer for OpenEmbedded [2].
|
|||
[1] https://github.com/ros/pluginlib/commit/2e0860ca42138f837b2e34921a207d40a095d996
|
||||
[2] https://github.com/bmwcarit/meta-ros
|
||||
|
||||
Upstream-Status: Accepted
|
||||
|
||||
Signed-off-by: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
|
||||
---
|
||||
CMakeLists.txt | 10 ++++------
|
||||
|
|
|
@ -18,4 +18,4 @@ SRC_URI[sha256sum] = "d4bdd0b6bce0c6fa9ff18b8926d4953161451bc49dd11497211eb1a62c
|
|||
|
||||
S = "${WORKDIR}/${ROS_SP}"
|
||||
|
||||
inherit cmake ros
|
||||
inherit cmake ros faulty-solibs
|
||||
|
|
|
@ -1,34 +0,0 @@
|
|||
From 29f5630047052c24f1b506bdb743ebd53358686d Mon Sep 17 00:00:00 2001
|
||||
From: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
|
||||
Date: Tue, 4 Feb 2014 16:04:23 +0100
|
||||
Subject: [PATCH] make rostest in CMakeLists optional (ros/rosdistro#3010)
|
||||
|
||||
Upstream-Status: Accepted
|
||||
---
|
||||
camera_info_manager/CMakeLists.txt | 3 ++-
|
||||
1 file changed, 2 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/camera_info_manager/CMakeLists.txt b/camera_info_manager/CMakeLists.txt
|
||||
index f220861..8b83216 100644
|
||||
--- a/camera_info_manager/CMakeLists.txt
|
||||
+++ b/camera_info_manager/CMakeLists.txt
|
||||
@@ -10,7 +10,7 @@ catkin_package(INCLUDE_DIRS include
|
||||
DEPENDS Boost roscpp sensor_msgs
|
||||
)
|
||||
|
||||
-find_package(catkin COMPONENTS camera_calibration_parsers image_transport roscpp roslib rostest)
|
||||
+find_package(catkin COMPONENTS camera_calibration_parsers image_transport roscpp roslib)
|
||||
|
||||
include_directories(SYSTEM ${camera_calibration_parsers_INCLUDE_DIRS}
|
||||
${image_transport_INCLUDE_DIRS}
|
||||
@@ -34,6 +34,7 @@ install(DIRECTORY include/${PROJECT_NAME}/
|
||||
)
|
||||
|
||||
if(CATKIN_ENABLE_TESTING)
|
||||
+ find_package(rostest)
|
||||
# Unit test uses gtest, but needs rostest to create a ROS environment.
|
||||
# Hence, it must be created as a normal executable, not using
|
||||
# catkin_add_gtest() which runs an additional test without rostest.
|
||||
--
|
||||
1.8.3.2
|
||||
|
|
@ -6,5 +6,3 @@ LIC_FILES_CHKSUM = "file://package.xml;beginline=15;endline=15;md5=d566ef916e9de
|
|||
DEPENDS = "boost camera-calibration-parsers image-transport roscpp roslib sensor-msgs"
|
||||
|
||||
require image-common.inc
|
||||
|
||||
SRC_URI += "file://0001-make-rostest-in-CMakeLists-optional-ros-rosdistro-30.patch;striplevel=2"
|
|
@ -1,6 +1,6 @@
|
|||
SRC_URI = "https://github.com/ros-perception/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
|
||||
SRC_URI[md5sum] = "4339a2bc7a7fca8dad6b6c0d7796204d"
|
||||
SRC_URI[sha256sum] = "bcce381f5525fe4185b08c23cbf4f1ddf2bc86263cdb53a7938c6dbf596d8ecc"
|
||||
SRC_URI[md5sum] = "1e747f99e7bae7a49cb387ac02133534"
|
||||
SRC_URI[sha256sum] = "03417c24017e912a683f2e6034624673e011de0843a61905b1f8dc7c2745d21e"
|
||||
|
||||
S = "${WORKDIR}/${ROS_SP}/${ROS_BPN}"
|
||||
|
||||
|
|
|
@ -4,6 +4,6 @@ SECTION = "devel"
|
|||
LICENSE = "BSD"
|
||||
LIC_FILES_CHKSUM = "file://package.xml;beginline=26;endline=26;md5=d566ef916e9dedc494f5f793a6690ba5"
|
||||
|
||||
DEPENDS = "cv-bridge dynamic-reconfigure image-transport opencv roscpp tf"
|
||||
DEPENDS = "cv-bridge dynamic-reconfigure image-transport opencv roscpp tf tf-conversions"
|
||||
|
||||
require image-pipeline.inc
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
DESCRIPTION = "amcl is a probabilistic localization system for a robot moving in 2D."
|
||||
SECTION = "devel"
|
||||
LICENSE = "LGPL-2.1+"
|
||||
LIC_FILES_CHKSUM = "file://package.xml;beginline=20;endline=20;md5=58d727014cda5ed405b7fb52666a1f97"
|
||||
LIC_FILES_CHKSUM = "file://package.xml;beginline=21;endline=21;md5=58d727014cda5ed405b7fb52666a1f97"
|
||||
|
||||
DEPENDS = "dynamic-reconfigure message-filters nav-msgs roscpp std-srvs tf"
|
||||
|
|
@ -1,7 +1,7 @@
|
|||
DESCRIPTION = "This package provides implementations of the Trajectory Rollout and Dynamic Window approaches to local robot navigation on a plane."
|
||||
SECTION = "devel"
|
||||
LICENSE = "BSD"
|
||||
LIC_FILES_CHKSUM = "file://package.xml;beginline=13;endline=13;md5=01c2bc31767ccb3a68e12f02612b2a97"
|
||||
LIC_FILES_CHKSUM = "file://package.xml;beginline=14;endline=14;md5=01c2bc31767ccb3a68e12f02612b2a97"
|
||||
|
||||
DEPENDS = "angles costmap-2d dynamic-reconfigure geometry-msgs libeigen message-generation \
|
||||
nav-core nav-msgs pcl-conversions pcl-ros pluginlib rosconsole roscpp rospy std-msgs tf \
|
|
@ -1,7 +1,7 @@
|
|||
DESCRIPTION = "This planner attempts to find a legal place to put a carrot for the robot to follow."
|
||||
SECTION = "devel"
|
||||
LICENSE = "BSD"
|
||||
LIC_FILES_CHKSUM = "file://package.xml;beginline=13;endline=13;md5=01c2bc31767ccb3a68e12f02612b2a97"
|
||||
LIC_FILES_CHKSUM = "file://package.xml;beginline=14;endline=14;md5=01c2bc31767ccb3a68e12f02612b2a97"
|
||||
|
||||
DEPENDS = "base-local-planner costmap-2d libeigen nav-core pluginlib roscpp tf"
|
||||
|
|
@ -3,7 +3,7 @@ DESCRIPTION = "This package provides a recovery behavior for the navigation stac
|
|||
the static map outside of a given area."
|
||||
SECTION = "devel"
|
||||
LICENSE = "BSD"
|
||||
LIC_FILES_CHKSUM = "file://package.xml;beginline=12;endline=12;md5=01c2bc31767ccb3a68e12f02612b2a97"
|
||||
LIC_FILES_CHKSUM = "file://package.xml;beginline=13;endline=13;md5=01c2bc31767ccb3a68e12f02612b2a97"
|
||||
|
||||
DEPENDS = "costmap-2d libeigen nav-core pluginlib roscpp tf"
|
||||
|
|
@ -4,9 +4,9 @@ DESCRIPTION = "This package provides an implementation of a 2D costmap that take
|
|||
2D costmap based on the occupancy grid and a user specified inflation radius."
|
||||
SECTION = "devel"
|
||||
LICENSE = "BSD"
|
||||
LIC_FILES_CHKSUM = "file://package.xml;beginline=18;endline=18;md5=01c2bc31767ccb3a68e12f02612b2a97"
|
||||
LIC_FILES_CHKSUM = "file://package.xml;beginline=19;endline=19;md5=01c2bc31767ccb3a68e12f02612b2a97"
|
||||
|
||||
DEPENDS = "dynamic-reconfigure geometry-msgs laser-geometry map-msgs message-filters \
|
||||
DEPENDS = "libeigen cmake-modules dynamic-reconfigure geometry-msgs laser-geometry map-msgs message-filters \
|
||||
message-generation nav-msgs pcl-conversions pcl-ros pluginlib roscpp \
|
||||
sensor-msgs std-msgs tf visualization-msgs voxel-grid"
|
||||
|
|
@ -2,7 +2,7 @@ DESCRIPTION = "This package provides an implementation of the Dynamic Window App
|
|||
local robot navigation on a plane."
|
||||
SECTION = "devel"
|
||||
LICENSE = "BSD"
|
||||
LIC_FILES_CHKSUM = "file://package.xml;beginline=19;endline=19;md5=01c2bc31767ccb3a68e12f02612b2a97"
|
||||
LIC_FILES_CHKSUM = "file://package.xml;beginline=20;endline=20;md5=01c2bc31767ccb3a68e12f02612b2a97"
|
||||
|
||||
DEPENDS = "base-local-planner costmap-2d dynamic-reconfigure libeigen nav-core \
|
||||
nav-msgs pluginlib pcl-conversions roscpp tf"
|
|
@ -1,7 +1,7 @@
|
|||
DESCRIPTION = "A ROS node that simply forwards odometry information."
|
||||
SECTION = "devel"
|
||||
LICENSE = "BSD"
|
||||
LIC_FILES_CHKSUM = "file://package.xml;beginline=8;endline=8;md5=01c2bc31767ccb3a68e12f02612b2a97"
|
||||
LIC_FILES_CHKSUM = "file://package.xml;beginline=9;endline=9;md5=01c2bc31767ccb3a68e12f02612b2a97"
|
||||
|
||||
DEPENDS = "angles roscpp rosconsole nav-msgs geometry-msgs tf message-filters rospy"
|
||||
|
|
@ -1,55 +0,0 @@
|
|||
From 9fdd83868742a5f00406632d7c7084a4fc272c35 Mon Sep 17 00:00:00 2001
|
||||
From: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
|
||||
Date: Tue, 4 Feb 2014 16:05:31 +0100
|
||||
Subject: [PATCH] make rostest in CMakeLists optional (ros/rosdistro#3010)
|
||||
|
||||
Upstream-Status: Submitted
|
||||
---
|
||||
map_server/CMakeLists.txt | 2 +-
|
||||
robot_pose_ekf/CMakeLists.txt | 3 ++-
|
||||
2 files changed, 3 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/map_server/CMakeLists.txt b/map_server/CMakeLists.txt
|
||||
index 40be4cc..c2bff5f 100644
|
||||
--- a/map_server/CMakeLists.txt
|
||||
+++ b/map_server/CMakeLists.txt
|
||||
@@ -6,7 +6,6 @@ find_package(catkin REQUIRED
|
||||
roscpp
|
||||
tf
|
||||
nav_msgs
|
||||
- rostest
|
||||
)
|
||||
|
||||
find_package(Boost REQUIRED COMPONENTS system)
|
||||
@@ -55,6 +54,7 @@ endfunction()
|
||||
|
||||
## Tests
|
||||
if(CATKIN_ENABLE_TESTING)
|
||||
+ find_package(rostest)
|
||||
copy_test_data( FILES
|
||||
test/testmap.bmp
|
||||
test/testmap.png )
|
||||
diff --git a/robot_pose_ekf/CMakeLists.txt b/robot_pose_ekf/CMakeLists.txt
|
||||
index c6d6ff0..bd51164 100644
|
||||
--- a/robot_pose_ekf/CMakeLists.txt
|
||||
+++ b/robot_pose_ekf/CMakeLists.txt
|
||||
@@ -23,7 +23,6 @@ link_directories(${BFL_LIBRARY_DIRS})
|
||||
find_package(catkin REQUIRED
|
||||
COMPONENTS
|
||||
roscpp
|
||||
- rostest
|
||||
tf
|
||||
nav_msgs
|
||||
std_msgs
|
||||
@@ -79,6 +78,8 @@ include(CMakeDetermineSystem)
|
||||
if(CMAKE_SYSTEM_NAME MATCHES "Linux")
|
||||
if(CATKIN_ENABLE_TESTING)
|
||||
|
||||
+find_package(rostest)
|
||||
+
|
||||
catkin_download_test_data(download_data_ekf_test2_indexed.bag http://download.ros.org/data/robot_pose_ekf/ekf_test2_indexed.bag FILENAME test/ekf_test2.bag MD5 71addef0ed900e05b301e0b4fdca99e2)
|
||||
add_executable(test_robot_pose_ekf test/test_robot_pose_ekf.cpp)
|
||||
target_link_libraries(test_robot_pose_ekf
|
||||
--
|
||||
1.8.3.2
|
||||
|
|
@ -1,7 +1,7 @@
|
|||
DESCRIPTION = "A path planner library and node."
|
||||
SECTION = "devel"
|
||||
LICENSE = "BSD"
|
||||
LIC_FILES_CHKSUM = "file://package.xml;beginline=8;endline=8;md5=d566ef916e9dedc494f5f793a6690ba5"
|
||||
LIC_FILES_CHKSUM = "file://package.xml;beginline=9;endline=9;md5=d566ef916e9dedc494f5f793a6690ba5"
|
||||
|
||||
DEPENDS = "costmap-2d dynamic-reconfigure geometry-msgs nav-core nav-msgs navfn pluginlib roscpp tf"
|
||||
|
|
@ -1,7 +1,7 @@
|
|||
DESCRIPTION = " map_server provides the map_server ROS Node, which offers map data as a ROS Service."
|
||||
SECTION = "devel"
|
||||
LICENSE = "BSD"
|
||||
LIC_FILES_CHKSUM = "file://package.xml;beginline=13;endline=13;md5=01c2bc31767ccb3a68e12f02612b2a97"
|
||||
LIC_FILES_CHKSUM = "file://package.xml;beginline=14;endline=14;md5=01c2bc31767ccb3a68e12f02612b2a97"
|
||||
|
||||
DEPENDS = "libsdl-image nav-msgs roscpp tf yaml-cpp"
|
||||
|
|
@ -1,7 +1,7 @@
|
|||
DESCRIPTION = "Holds the action description and relevant messages for the move_base package"
|
||||
SECTION = "devel"
|
||||
LICENSE = "BSD"
|
||||
LIC_FILES_CHKSUM = "file://package.xml;beginline=12;endline=12;md5=01c2bc31767ccb3a68e12f02612b2a97"
|
||||
LIC_FILES_CHKSUM = "file://package.xml;beginline=13;endline=13;md5=01c2bc31767ccb3a68e12f02612b2a97"
|
||||
|
||||
DEPENDS = "actionlib-msgs geometry-msgs message-generation roscpp"
|
||||
|
|
@ -1,7 +1,7 @@
|
|||
DESCRIPTION = "The move_base package provides an implementation of an action that, given a goal in the world, will attempt to reach it with a mobile base."
|
||||
SECTION = "devel"
|
||||
LICENSE = "BSD"
|
||||
LIC_FILES_CHKSUM = "file://package.xml;beginline=12;endline=12;md5=01c2bc31767ccb3a68e12f02612b2a97"
|
||||
LIC_FILES_CHKSUM = "file://package.xml;beginline=13;endline=13;md5=01c2bc31767ccb3a68e12f02612b2a97"
|
||||
|
||||
DEPENDS = "actionlib costmap-2d dynamic-reconfigure geometry-msgs message-generation move-base-msgs \
|
||||
nav-core nav-msgs pluginlib roscpp rospy std-msgs std-srvs tf visualization-msgs"
|
|
@ -1,7 +1,7 @@
|
|||
DESCRIPTION = "move_slow_and_clear"
|
||||
SECTION = "devel"
|
||||
LICENSE = "BSD"
|
||||
LIC_FILES_CHKSUM = "file://package.xml;beginline=12;endline=12;md5=01c2bc31767ccb3a68e12f02612b2a97"
|
||||
LIC_FILES_CHKSUM = "file://package.xml;beginline=13;endline=13;md5=01c2bc31767ccb3a68e12f02612b2a97"
|
||||
|
||||
DEPENDS = "costmap-2d geometry-msgs nav-core pluginlib roscpp"
|
||||
|
|
@ -1,7 +1,7 @@
|
|||
DESCRIPTION = "This package provides common interfaces for navigation specific robot actions."
|
||||
SECTION = "devel"
|
||||
LICENSE = "BSD"
|
||||
LIC_FILES_CHKSUM = "file://package.xml;beginline=12;endline=12;md5=01c2bc31767ccb3a68e12f02612b2a97"
|
||||
LIC_FILES_CHKSUM = "file://package.xml;beginline=13;endline=13;md5=01c2bc31767ccb3a68e12f02612b2a97"
|
||||
|
||||
DEPENDS = "costmap-2d geometry-msgs std-msgs tf"
|
||||
|
|
@ -1,7 +1,7 @@
|
|||
DESCRIPTION = "navfn provides a fast interpolated navigation function that can be used to create plans for a mobile base."
|
||||
SECTION = "devel"
|
||||
LICENSE = "BSD"
|
||||
LIC_FILES_CHKSUM = "file://package.xml;beginline=13;endline=13;md5=01c2bc31767ccb3a68e12f02612b2a97"
|
||||
LIC_FILES_CHKSUM = "file://package.xml;beginline=19;endline=19;md5=01c2bc31767ccb3a68e12f02612b2a97"
|
||||
|
||||
DEPENDS = "costmap-2d geometry-msgs nav-core nav-msgs pcl-conversions pcl-ros \
|
||||
pluginlib rosconsole roscpp tf visualization-msgs"
|
|
@ -1,8 +1,6 @@
|
|||
SRC_URI = "https://github.com/ros-planning/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
|
||||
SRC_URI[md5sum] = "f6dd416880d0e92985be5268699d9cb8"
|
||||
SRC_URI[sha256sum] = "52d88c64047539f3d7552cee48def65f082e39d37221659b2533aecef429bb42"
|
||||
|
||||
SRC_URI += "file://0001-make-rostest-in-CMakeLists-optional-ros-rosdistro-30.patch;patchdir=.."
|
||||
SRC_URI[md5sum] = "e6d44439bd062a75ec15d8fd845a657c"
|
||||
SRC_URI[sha256sum] = "9c1ca5fca90e59876782b92e4c67339ce2df84eedc5af4358c5a4b42c6aaed30"
|
||||
|
||||
S = "${WORKDIR}/${ROS_SP}/${ROS_BPN}"
|
||||
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
DESCRIPTION = "The Robot Pose EKF package is used to estimate the 3D pose of a robot, based on (partial) pose measurements coming from different sources. It uses an extended Kalman filter with a 6D model (3D position and 3D orientation) to combine measurements from wheel odometry, IMU sensor and visual odometry. The basic idea is to offer loosely coupled integration with different sensors, where sensor signals are received as ROS messages."
|
||||
SECTION = "devel"
|
||||
LICENSE = "BSD"
|
||||
LIC_FILES_CHKSUM = "file://package.xml;beginline=12;endline=12;md5=01c2bc31767ccb3a68e12f02612b2a97"
|
||||
LIC_FILES_CHKSUM = "file://package.xml;beginline=13;endline=13;md5=01c2bc31767ccb3a68e12f02612b2a97"
|
||||
|
||||
DEPENDS = "roscpp bfl std-msgs geometry-msgs sensor-msgs nav-msgs tf"
|
||||
|
|
@ -2,7 +2,7 @@ DESCRIPTION = "This package provides a recovery behavior for the navigation stac
|
|||
to clear space by performing a 360 degree rotation of the robot."
|
||||
SECTION = "devel"
|
||||
LICENSE = "BSD"
|
||||
LIC_FILES_CHKSUM = "file://package.xml;beginline=12;endline=12;md5=01c2bc31767ccb3a68e12f02612b2a97"
|
||||
LIC_FILES_CHKSUM = "file://package.xml;beginline=13;endline=13;md5=01c2bc31767ccb3a68e12f02612b2a97"
|
||||
|
||||
DEPENDS = "base-local-planner costmap-2d libeigen nav-core pluginlib roscpp tf"
|
||||
|
|
@ -1,7 +1,7 @@
|
|||
DESCRIPTION = "voxel_grid provides an implementation of an efficient 3D voxel grid."
|
||||
SECTION = "devel"
|
||||
LICENSE = "BSD"
|
||||
LIC_FILES_CHKSUM = "file://package.xml;beginline=12;endline=12;md5=01c2bc31767ccb3a68e12f02612b2a97"
|
||||
LIC_FILES_CHKSUM = "file://package.xml;beginline=13;endline=13;md5=01c2bc31767ccb3a68e12f02612b2a97"
|
||||
|
||||
DEPENDS = "roscpp"
|
||||
|
|
@ -1,6 +1,6 @@
|
|||
SRC_URI = "https://github.com/OctoMap/${ROS_SPN}/archive/v${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
|
||||
SRC_URI[md5sum] = "d0742959d4b186ec2c21d61f8642708e"
|
||||
SRC_URI[sha256sum] = "4e95c00f02e71458e5cf02f782e717cb00505d37413c240ee716de98f7bc30a0"
|
||||
SRC_URI[md5sum] = "6781c4a12958cca69570c334cf836f21"
|
||||
SRC_URI[sha256sum] = "cad32744152970d0ab141d12c122d0482510644f29c61b8464bbfc65ebff1cf0"
|
||||
|
||||
S = "${WORKDIR}/${ROS_SP}/${ROS_BPN}"
|
||||
|
||||
|
|
|
@ -3,7 +3,7 @@ SECTION = "devel"
|
|||
LICENSE = "BSD"
|
||||
LIC_FILES_CHKSUM = "file://package.xml;beginline=8;endline=8;md5=d566ef916e9dedc494f5f793a6690ba5"
|
||||
|
||||
DEPENDS = "pcl-msgs pcl"
|
||||
DEPENDS = "pcl-msgs pcl roscpp"
|
||||
|
||||
SRC_URI = "https://github.com/ros-perception/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
|
||||
SRC_URI[md5sum] = "a4317447dbd3da2bcd33d40db700b723"
|
||||
|
|
|
@ -3,7 +3,7 @@ From: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
|
|||
Date: Thu, 10 Apr 2014 07:31:32 +0200
|
||||
Subject: [PATCH] check for CATKIN_ENABLE_TESTING
|
||||
|
||||
Upstream-Status: Submitted
|
||||
Upstream-Status: Accepted
|
||||
---
|
||||
joint_trajectory_controller/CMakeLists.txt | 44 ++++++++++++++++--------------
|
||||
joint_trajectory_controller/package.xml | 2 +-
|
||||
|
|
|
@ -10,4 +10,4 @@ SRC_URI[sha256sum] = "6b1f27b002c6d897b43ed57988133f40aac093a2a6e84d9bf08ed36a13
|
|||
|
||||
S = "${WORKDIR}/${ROS_SP}"
|
||||
|
||||
inherit cmake ros
|
||||
inherit cmake ros faulty-solibs
|
||||
|
|
|
@ -15,6 +15,8 @@ The obtained files were slightly adjusted:
|
|||
- The version in the package.xml is fixed.
|
||||
- Paths in CMakeLists.txt and setup.py were changed for use
|
||||
with the bitbake recipe.
|
||||
|
||||
Upstream-Status: Inappropriate [source repository shall work without catkin]
|
||||
---
|
||||
urdf_parser_py/CMakeLists.txt | 16 ++++++++++------
|
||||
urdf_parser_py/package.xml | 28 ++++++++++++++++++++++++++++
|
||||
|
|
|
@ -11,4 +11,4 @@ require urdfdom.inc
|
|||
|
||||
S = "${WORKDIR}/${ROS_SP}"
|
||||
|
||||
inherit ros cmake
|
||||
inherit cmake ros faulty-solibs
|
||||
|
|
Loading…
Reference in New Issue