ros-comm: updating to 1.11.13

This commit:
- removes std-srvs and rosgraph-msgs recipes, as their sources
now are located in the ros_comm_msgs repository.
- adds a recipe for the new roslz4 package, which rosbag-storage
depends on.
- removes the patch that has been merged upstream.
This commit is contained in:
Lukas Bulwahn 2014-12-08 08:44:08 +01:00
parent c033e0c5e9
commit 18c30e0720
24 changed files with 13 additions and 118 deletions

View File

@ -1,93 +0,0 @@
From 560ce8a8855a43565d1798af19cc943c61a72e7f Mon Sep 17 00:00:00 2001
From: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
Date: Tue, 4 Feb 2014 12:57:23 +0100
Subject: [PATCH] make rostest in CMakeLists optional (ros/rosdistro#3010)
This patch includes the subsequent fix in the indigo-devel branch of the
ros_comm repository (commit "fix find_package() call with two package names").
Upstream-Status: Backport [Accepted in indigo-devel branch]
---
tools/rosnode/CMakeLists.txt | 3 ++-
tools/rostopic/CMakeLists.txt | 3 ++-
tools/topic_tools/CMakeLists.txt | 3 ++-
utilities/roswtf/CMakeLists.txt | 3 ++-
4 files changed, 8 insertions(+), 4 deletions(-)
diff --git a/tools/rosnode/CMakeLists.txt b/tools/rosnode/CMakeLists.txt
index a7347b4..f305890 100644
--- a/tools/rosnode/CMakeLists.txt
+++ b/tools/rosnode/CMakeLists.txt
@@ -1,10 +1,11 @@
cmake_minimum_required(VERSION 2.8.3)
project(rosnode)
-find_package(catkin REQUIRED COMPONENTS rostest)
+find_package(catkin REQUIRED)
catkin_package()
catkin_python_setup()
if(CATKIN_ENABLE_TESTING)
+ find_package(rostest)
add_rostest(test/rosnode.test)
endif()
diff --git a/tools/rostopic/CMakeLists.txt b/tools/rostopic/CMakeLists.txt
index 0551583..db7917b 100644
--- a/tools/rostopic/CMakeLists.txt
+++ b/tools/rostopic/CMakeLists.txt
@@ -1,6 +1,6 @@
cmake_minimum_required(VERSION 2.8.3)
project(rostopic)
-find_package(catkin REQUIRED COMPONENTS rostest)
+find_package(catkin REQUIRED)
catkin_package()
catkin_python_setup()
@@ -9,5 +9,6 @@ install(PROGRAMS scripts/rostopic
DESTINATION ${CATKIN_PACKAGE_BIN_DESTINATION})
if(CATKIN_ENABLE_TESTING)
+ find_package(rostest)
add_rostest(test/rostopic.test)
endif()
diff --git a/tools/topic_tools/CMakeLists.txt b/tools/topic_tools/CMakeLists.txt
index e441b9a..2d52451 100644
--- a/tools/topic_tools/CMakeLists.txt
+++ b/tools/topic_tools/CMakeLists.txt
@@ -1,6 +1,6 @@
cmake_minimum_required(VERSION 2.8.3)
project(topic_tools)
-find_package(catkin COMPONENTS cpp_common message_generation rosconsole roscpp rostest rostime rosunit std_msgs xmlrpcpp)
+find_package(catkin COMPONENTS cpp_common message_generation rosconsole roscpp rostime std_msgs xmlrpcpp)
include_directories(include)
include_directories(${catkin_INCLUDE_DIRS})
@@ -62,6 +62,8 @@ install(PROGRAMS
#Testing
if(CATKIN_ENABLE_TESTING)
+ find_package(rostest)
+ find_package(rosunit)
catkin_add_gtest(${PROJECT_NAME}-utest test/utest.cpp)
if(TARGET ${PROJECT_NAME}-utest)
target_link_libraries(${PROJECT_NAME}-utest topic_tools)
diff --git a/utilities/roswtf/CMakeLists.txt b/utilities/roswtf/CMakeLists.txt
index dccb342..97a34ff 100644
--- a/utilities/roswtf/CMakeLists.txt
+++ b/utilities/roswtf/CMakeLists.txt
@@ -1,10 +1,11 @@
cmake_minimum_required(VERSION 2.8.3)
project(roswtf)
-find_package(catkin REQUIRED COMPONENTS rostest)
+find_package(catkin REQUIRED)
catkin_package()
catkin_python_setup()
if(CATKIN_ENABLE_TESTING)
+ find_package(rostest)
add_rostest(test/roswtf.test)
catkin_add_nosetests(test)
endif()
--
1.8.3.2

View File

@ -1,8 +1,6 @@
SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
SRC_URI[md5sum] = "131703a82abc66a9f71bc32967250900"
SRC_URI[sha256sum] = "c252469345133f372f1cf20d122c92f531ed7e2224db32ad36afa20e7906aedf"
SRC_URI += "file://0001-make-rostest-in-CMakeLists-optional-ros-rosdistro-30.patch;patchdir=../.."
SRC_URI[md5sum] = "a03bda14346ecc015810e0b2ad923ce2"
SRC_URI[sha256sum] = "435eed0fc8f7df46fe12097131e1518730f13fbbe3820d590017bddcbf3d8871"
ROS_PKG_SUBDIR ?= ""
S = "${WORKDIR}/${ROS_SP}/${ROS_PKG_SUBDIR}/${ROS_BPN}"

View File

@ -4,7 +4,7 @@ SECTION = "devel"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://package.xml;beginline=9;endline=9;md5=d566ef916e9dedc494f5f793a6690ba5"
DEPENDS = "boost bzip2 console-bridge cpp-common roscpp-serialization roscpp-traits rostime"
DEPENDS = "boost bzip2 console-bridge cpp-common roscpp-serialization roscpp-traits roslz4 rostime"
require ros-comm.inc

View File

@ -1,10 +0,0 @@
DESCRIPTION = "C++ ROS message and service generators."
SECTION = "devel"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://package.xml;beginline=8;endline=8;md5=d566ef916e9dedc494f5f793a6690ba5"
DEPENDS = "message-generation message-runtime std-msgs roscpp-serialization"
require ros-comm.inc
ROS_PKG_SUBDIR = "messages"

View File

@ -0,0 +1,10 @@
DESCRIPTION = "A Python and C++ implementation of the LZ4 streaming format."
SECTION = "devel"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://package.xml;beginline=12;endline=12;md5=d566ef916e9dedc494f5f793a6690ba5"
DEPENDS = "lz4"
require ros-comm.inc
ROS_PKG_SUBDIR = "utilities"

View File

@ -1,10 +0,0 @@
DESCRIPTION = "Common service definitions. Currently just the 'Empty' service."
SECTION = "devel"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://package.xml;beginline=6;endline=6;md5=d566ef916e9dedc494f5f793a6690ba5"
DEPENDS = "message-generation message-runtime"
require ros-comm.inc
ROS_PKG_SUBDIR = "messages"