DRAFT Drop unused-recipes-ros1/

This commit is contained in:
Herb Kuta 2019-07-03 12:14:41 -07:00
parent e128803664
commit 1b77ee960a
56 changed files with 0 additions and 685 deletions

View File

@ -1,16 +0,0 @@
DESCRIPTION = "Python interface for camera calibration information."
SECTION = "devel"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://package.xml;beginline=13;endline=13;md5=d566ef916e9dedc494f5f793a6690ba5"
DEPENDS = "rospy sensor-msgs"
SRC_URI = "https://github.com/ros-perception/${ROS_SPN}/archive/${ROS_SP}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
SRC_URI[md5sum] = "eb12065f8e6b9d06a489f89f19dcc41e"
SRC_URI[sha256sum] = "d1ae6229c9a55e8d6fa89b5d051b86605fca0b02ff2e344c76c44d7642eb88c6"
S = "${WORKDIR}/${ROS_SPN}-${ROS_SP}"
inherit catkin
RDEPENDS_${PN} = "sensor-msgs"

View File

@ -1,8 +0,0 @@
DESCRIPTION = "The chatter_msgs package"
SECTION = "devel"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://package.xml;beginline=7;endline=7;md5=d566ef916e9dedc494f5f793a6690ba5"
DEPENDS = "message-generation message-runtime std-msgs roscpp-serialization"
require chatter.inc

View File

@ -1,8 +0,0 @@
DESCRIPTION = "The chatter_receiver package"
SECTION = "devel"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://package.xml;beginline=7;endline=7;md5=d566ef916e9dedc494f5f793a6690ba5"
DEPENDS = "chatter-msgs roscpp"
require chatter.inc

View File

@ -1,8 +0,0 @@
DESCRIPTION = "The chatter_sender package"
SECTION = "devel"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://package.xml;beginline=7;endline=7;md5=d566ef916e9dedc494f5f793a6690ba5"
DEPENDS = "chatter-msgs roscpp"
require chatter.inc

View File

@ -1,9 +0,0 @@
SRC_URI = "https://github.com/bmwcarit/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
SRC_URI[md5sum] = "3048507b90d31babed579677c73aa219"
SRC_URI[sha256sum] = "ff7f5a705049bd6e312afcbbf919cc5a382160ff6eca8571a7dec4f4e0bc8f15"
S = "${WORKDIR}/${ROS_SP}/${ROS_BPN}"
inherit catkin
ROS_SPN = "ros_chatter"

View File

@ -1,36 +0,0 @@
From 92cea9b1a2267dadb0b7e2409ed8a23531fad0cf Mon Sep 17 00:00:00 2001
From: Lukas Bulwahn <lukas.bulwahn@gmail.com>
Date: Mon, 3 Apr 2017 18:01:56 +0200
Subject: [PATCH] make rostest in CMakeLists optional (ros/rosdistro#3010)
Upstream-Status: Accepted [https://github.com/OTL/cv_camera/commit/92cea9b1a2267dadb0b7e2409ed8a23531fad0cf]
Signed-off-by: Lukas Bulwahn <lukas.bulwahn@gmail.com>
---
CMakeLists.txt | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fc6a658..681c64b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -2,7 +2,7 @@ cmake_minimum_required(VERSION 2.8.3)
project(cv_camera)
find_package(catkin REQUIRED COMPONENTS
- image_transport roscpp cv_bridge sensor_msgs nodelet camera_info_manager rostest roslint)
+ image_transport roscpp cv_bridge sensor_msgs nodelet camera_info_manager roslint)
find_package(OpenCV REQUIRED)
@@ -86,6 +86,7 @@ roslint_cpp(
)
if (CATKIN_ENABLE_TESTING)
+ find_package(rostest REQUIRED)
add_rostest_gtest(test_cv_camera test/cv_camera.test
test/test_cv_camera.cpp)
target_link_libraries(test_cv_camera ${PROJECT_NAME} ${catkin_LIBRARIES})
--
2.5.5

View File

@ -1,16 +0,0 @@
DESCRIPTION = "cv_camera uses OpenCV capture object to capture camera image. This supports camera_image and nodelet."
SECTION = "devel"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://package.xml;beginline=9;endline=9;md5=d566ef916e9dedc494f5f793a6690ba5"
DEPENDS = "opencv image-transport roscpp cv-bridge sensor-msgs nodelet camera-info-manager roslint"
SRC_URI = "https://github.com/OTL/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
SRC_URI[md5sum] = "d52b7c7386615d649cb7c0a83b910845"
SRC_URI[sha256sum] = "f38948e279e79a7410abb341e1313a64cd8edff2e0a3086d2045a86741af14bf"
SRC_URI += "file://0001-make-rostest-in-CMakeLists-optional-ros-rosdistro-30.patch"
S = "${WORKDIR}/${ROS_SP}"
inherit catkin

View File

@ -1,10 +0,0 @@
DESCRIPTION = "A libfreenect based ROS driver for the Microsoft Kinect. This is a port of the \
OpenNI driver to use libfreenect."
SECTION = "devel"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://package.xml;beginline=12;endline=12;md5=d566ef916e9dedc494f5f793a6690ba5"
DEPENDS = "camera-info-manager diagnostic-updater dynamic-reconfigure \
image-transport libfreenect nodelet roscpp sensor-msgs pluginlib"
require freenect-stack.inc

View File

@ -1,10 +0,0 @@
DESCRIPTION = "Launch files for freenect_camera to produce rectified, \
registered or disparity images. Also produce point clouds and \
registered point clouds. Based on the openni_launch package."
SECTION = "devel"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://package.xml;beginline=14;endline=14;md5=d566ef916e9dedc494f5f793a6690ba5"
require freenect-stack.inc
RRECOMMENDS_${PN} = "freenect-camera image-proc nodelet rgbd-launch tf"

View File

@ -1,9 +0,0 @@
SRC_URI = "https://github.com/ros-drivers/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
SRC_URI[md5sum] = "3a6a07a9a11b28074f2b2c6dba8e102e"
SRC_URI[sha256sum] = "7c3e8e564674cf4a21796d98ceb26e34d0750e53a3593d1fade44338eb45ae31"
S = "${WORKDIR}/${ROS_SP}/${ROS_BPN}"
inherit catkin
ROS_SPN = "freenect_stack"

View File

@ -1,17 +0,0 @@
DESCRIPTION = "Frontier exploration implementation in ROS, \
accepts exploration goals via actionlib, sends movement commands to move_base"
SECTION = "devel"
LICENSE = "GPLv3"
LIC_FILES_CHKSUM = "file://package.xml;beginline=13;endline=13;md5=1e7b3bcc2e271699c77c769685058cbe"
DEPENDS = "geometry-msgs roscpp pcl costmap-2d actionlib move-base-msgs visualization-msgs tf"
SRC_URI = "https://github.com/paulbovbel/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
SRC_URI[md5sum] = "a27eb097cb0fd2b0a381ffae1461e06a"
SRC_URI[sha256sum] = "991a1350ab3daab7665251215105f25fb107ae5b0a0337fbdcd9adea4d7b72d3"
S = "${WORKDIR}/${ROS_SP}"
inherit catkin
RRECOMMENDS_${PN} = "costmap-2d actionlib move-base tf"

View File

@ -1,10 +0,0 @@
DESCRIPTION = "hector_mapping is a SLAM approach that can be used \
without odometry as well as on platforms that exhibit roll/pitch motion \
(of the sensor, the platform or both)."
SECTION = "devel"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://package.xml;beginline=19;endline=19;md5=d566ef916e9dedc494f5f793a6690ba5"
DEPENDS = "cmake-modules message-runtime boost nav-msgs visualization-msgs tf message-filters laser-geometry tf-conversions"
require hector-slam.inc

View File

@ -1,9 +0,0 @@
SRC_URI = "https://github.com/tu-darmstadt-ros-pkg/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
SRC_URI[md5sum] = "5cede4ebdcae09d9bc7ad82b129500e0"
SRC_URI[sha256sum] = "80272696da825afbc21c5baa4477850f9df31174ae6bf65fe50519ff8eaf94bc"
S = "${WORKDIR}/${ROS_SP}/${ROS_BPN}"
inherit catkin
ROS_SPN = "hector_slam"

View File

@ -1,14 +0,0 @@
DESCRIPTION = "The household_objects_database_msgs package"
SECTION = "devel"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://package.xml;beginline=10;endline=10;md5=d566ef916e9dedc494f5f793a6690ba5"
DEPENDS = "message-generation std-msgs geometry-msgs shape-msgs object-recognition-msgs"
SRC_URI = "https://github.com/ros-interactive-manipulation/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
SRC_URI[md5sum] = "96cc5baed4d92626044470772745bf58"
SRC_URI[sha256sum] = "1ab82ef50d580635a7248c83585e641687aa32465c766ebcda5f044778f9ff5b"
S = "${WORKDIR}/${ROS_SP}"
inherit catkin

View File

@ -1,10 +0,0 @@
DESCRIPTION = "Automatic docking for Kobuki"
SECTION = "devel"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://package.xml;beginline=10;endline=10;md5=d566ef916e9dedc494f5f793a6690ba5"
DEPENDS = "roscpp rospy nodelet pluginlib message-filters actionlib \
kdl-conversions std-msgs nav-msgs geometry-msgs actionlib-msgs kobuki-msgs \
kobuki-dock-drive ecl-threads ecl-geometry ecl-linear-algebra"
require kobuki.inc

View File

@ -1,8 +0,0 @@
DESCRIPTION = "Bumper/cliff to pointcloud nodelet"
SECTION = "devel"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://package.xml;beginline=11;endline=11;md5=d566ef916e9dedc494f5f793a6690ba5"
DEPENDS = "roscpp nodelet pluginlib kobuki-msgs sensor-msgs"
require kobuki.inc

View File

@ -1,8 +0,0 @@
DESCRIPTION = "Kobuki's capabilities"
SECTION = "devel"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://package.xml;beginline=10;endline=10;md5=d566ef916e9dedc494f5f793a6690ba5"
require kobuki.inc
RDEPENDS_${PN} = "kobuki-node nodelet rocon-app-manager rocon-apps std-capabilities"

View File

@ -1,8 +0,0 @@
DESCRIPTION = "Code for the Kobuki controller tutorial."
SECTION = "devel"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://package.xml;beginline=9;endline=9;md5=d566ef916e9dedc494f5f793a6690ba5"
DEPENDS = "roscpp nodelet pluginlib std-msgs kobuki-msgs yocs-controllers"
require kobuki.inc

View File

@ -1,8 +0,0 @@
DESCRIPTION = "Description of the Kobuki model"
SECTION = "devel"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://package.xml;beginline=17;endline=17;md5=d566ef916e9dedc494f5f793a6690ba5"
DEPENDS = "urdf xacro"
require kobuki.inc

View File

@ -1,8 +0,0 @@
DESCRIPTION = "Keyboard teleoperation for Kobuki"
SECTION = "devel"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://package.xml;beginline=9;endline=9;md5=d566ef916e9dedc494f5f793a6690ba5"
DEPENDS = "roscpp geometry-msgs std-srvs std-msgs ecl-exceptions ecl-threads ecl-time kobuki-msgs"
require kobuki.inc

View File

@ -1,9 +0,0 @@
DESCRIPTION = "ROS nodelet for Kobuki: ROS wrapper for the Kobuki driver"
SECTION = "devel"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://package.xml;beginline=11;endline=11;md5=d566ef916e9dedc494f5f793a6690ba5"
DEPENDS = "roscpp geometry-msgs sensor-msgs nav-msgs std-msgs tf angles diagnostic-updater diagnostic-msgs nodelet pluginlib \
kobuki-msgs kobuki-driver kobuki-keyop kobuki-safety-controller ecl-exceptions ecl-sigslots ecl-streams ecl-threads"
require kobuki.inc

View File

@ -1,8 +0,0 @@
DESCRIPTION = "Random walker app for Kobuki"
SECTION = "devel"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://package.xml;beginline=9;endline=9;md5=d566ef916e9dedc494f5f793a6690ba5"
DEPENDS = "ecl-threads geometry-msgs kobuki-msgs nodelet pluginlib roscpp std-msgs yocs-controllers"
require kobuki.inc

View File

@ -1,8 +0,0 @@
DESCRIPTION = "Robot apps for Kobuki"
SECTION = "devel"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://package.xml;beginline=10;endline=10;md5=d566ef916e9dedc494f5f793a6690ba5"
require kobuki.inc
RDEPENDS_${PN} = "kobuki-auto-docking kobuki-random-walker nodelet"

View File

@ -1,8 +0,0 @@
DESCRIPTION = "A controller ensuring the safe operation of Kobuki."
SECTION = "devel"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://package.xml;beginline=15;endline=15;md5=d566ef916e9dedc494f5f793a6690ba5"
DEPENDS = "roscpp nodelet pluginlib std-msgs geometry-msgs kobuki-msgs yocs-controllers ecl-threads"
require kobuki.inc

View File

@ -1,8 +0,0 @@
DESCRIPTION = "Kobuki test suite"
SECTION = "devel"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://package.xml;beginline=9;endline=9;md5=d566ef916e9dedc494f5f793a6690ba5"
DEPENDS = "python-orocos-kdl kobuki-node std-msgs sensor-msgs geometry-msgs kobuki-msgs message-generation"
require kobuki.inc

View File

@ -1,9 +0,0 @@
SRC_URI = "https://github.com/yujinrobot/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
SRC_URI[md5sum] = "47c5451f1f0db1dd980c2e804b78a285"
SRC_URI[sha256sum] = "d0b51e309d57852fc63a63b4070031857515eff1e9f7693df174f134ef4f049e"
S = "${WORKDIR}/${ROS_SP}/${ROS_BPN}"
inherit catkin
ROS_SPN = "kobuki"

View File

@ -1,14 +0,0 @@
DESCRIPTION = "The manipulation_msgs package"
SECTION = "devel"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://package.xml;beginline=10;endline=10;md5=d566ef916e9dedc494f5f793a6690ba5"
DEPENDS = "actionlib-msgs geometry-msgs sensor-msgs shape-msgs household-objects-database-msgs"
SRC_URI = "https://github.com/ros-interactive-manipulation/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
SRC_URI[md5sum] = "48bb43443982dc6c78afaf2b65a74e67"
SRC_URI[sha256sum] = "b34fae176367ff727876959e5f40eafeb9a7c158424bc288ae7eb9045e6b3a41"
S = "${WORKDIR}/${ROS_SP}"
inherit catkin

View File

@ -1,41 +0,0 @@
From a48b8169305527f480bfae0f413bd48f818b6bf9 Mon Sep 17 00:00:00 2001
From: Lukas Bulwahn <lukas.bulwahn@gmail.com>
Date: Mon, 21 Aug 2017 11:25:33 +0200
Subject: [PATCH] make it compile with glibc-2.26 with an explicit cast to bool
With glibc-2.26, openslam_gmapping failed to compile with:
```
| [...]/gridfastslam/gfsreader.cpp: In member function 'virtual void GMapping::GFSReader::RawOdometryRecord::read(std::istream&)':
| [...]/gridfastslam/gfsreader.cpp:79:3: error: no match for 'operator==' (operand types are 'std::istream {aka std::basic_istream<char>}' and 'int')
| assert(is);
| ^
```
Hence, this commit explicitly casts to bool, so that the assert annotation compiles
properly again.
Signed-off-by: Lukas Bulwahn <lukas.bulwahn@gmail.com>
Upstream-Status: Submitted [https://github.com/ros-perception/openslam_gmapping/pull/19]
Signed-off-by: Lukas Bulwahn <lukas.bulwahn@gmail.com>
---
gridfastslam/gfsreader.cpp | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/gridfastslam/gfsreader.cpp b/gridfastslam/gfsreader.cpp
index 8b16427..c83f721 100644
--- a/gridfastslam/gfsreader.cpp
+++ b/gridfastslam/gfsreader.cpp
@@ -76,7 +76,7 @@ void RawOdometryRecord::read(istream& is){
is >> pose.y;
is >> pose.theta;
time = 0;
- assert(is);
+ assert(static_cast<bool>(is));
is >> time;
}
--
1.9.1

View File

@ -1,14 +0,0 @@
DESCRIPTION = "ROS-ified version of gmapping SLAM."
SECTION = "devel"
LICENSE = "CC-BY-NC-SA-2.0"
LIC_FILES_CHKSUM = "file://package.xml;beginline=6;endline=6;md5=11e24f757f025b2cbebd5b14b4a7ca19"
SRC_URI = "https://github.com/ros-perception/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
SRC_URI[md5sum] = "da2548abb3d351b199896dc62363ae65"
SRC_URI[sha256sum] = "b54235b197cfd0bb5ce4689310d1b52af838d4614ac37e5f03be18d53eb39683"
SRC_URI += "file://0001-make-it-compile-with-glibc-2.26-with-an-explicit-cas.patch"
S = "${WORKDIR}/${ROS_SP}"
inherit catkin

View File

@ -1,20 +0,0 @@
DESCRIPTION = "Provides a ROS driver for the Sparkfun Razor IMU 9DOF. \
It also provides Arduino firmware that runs on the Razor board, and which must be \
installed on the Razor board for the system to work. \
A node which displays the attitude (roll, pitch and yaw) of the Razor board \
(or any IMU) is provided for testing."
SECTION = "devel"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://package.xml;beginline=15;endline=15;md5=d566ef916e9dedc494f5f793a6690ba5"
DEPENDS = "dynamic-reconfigure"
SRC_URI = "https://github.com/KristofRobot/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
SRC_URI[md5sum] = "1d036536b614e4e9841c970150692e46"
SRC_URI[sha256sum] = "9953df3323167510243386525558dd4fc40d628326852db5ebb303fbcc42a7cb"
S = "${WORKDIR}/${ROS_SP}"
inherit catkin
RDEPENDS_${PN} = "rospy tf sensor-msgs ${PYTHON_PN}-pyserial"

View File

@ -1,13 +0,0 @@
DESCRIPTION = "The public interface and retaskable interface for a robot."
SECTION = "devel"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://package.xml;beginline=9;endline=9;md5=d566ef916e9dedc494f5f793a6690ba5"
DEPENDS = "roslint"
require rocon-app-platform.inc
RDEPENDS_${PN} = "capabilities gateway-msgs rocon-app-manager-msgs rocon-app-utilities \
rocon-apps rocon-console rocon-gateway-utils rocon-gateway rocon-hub rocon-interactions \
rocon-master-info rocon-python-comms rocon-python-utils rocon-std-msgs rocon-uri \
roslib rosmaster rospy std-msgs"

View File

@ -1,9 +0,0 @@
SRC_URI = "https://github.com/robotics-in-concert/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
SRC_URI[md5sum] = "defca2d4c405502249bd4888bee837f6"
SRC_URI[sha256sum] = "72eae53692744d04d580a549449d5346edf28a67f25265db3ba371f467b0a03a"
S = "${WORKDIR}/${ROS_SP}/${ROS_BPN}"
inherit catkin
ROS_SPN = "rocon_app_platform"

View File

@ -1,10 +0,0 @@
DESCRIPTION = "The rocon_app_utilities package"
SECTION = "devel"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://package.xml;beginline=10;endline=10;md5=d566ef916e9dedc494f5f793a6690ba5"
DEPENDS = "${PYTHON_PN}-catkin-pkg roslint"
require rocon-app-platform.inc
RDEPENDS_${PN} = "rocon-console rocon-python-utils rocon-uri ${PYTHON_PN}-rospkg roslaunch"

View File

@ -1,8 +0,0 @@
DESCRIPTION = "Core rocon apps for use with the appmanager and rocon concert."
SECTION = "devel"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://package.xml;beginline=9;endline=9;md5=d566ef916e9dedc494f5f793a6690ba5"
require rocon-app-platform.inc
RDEPENDS_${PN} = "bash gateway-msgs rocon-app-manager-msgs roslib rospy rospy-tutorials topic-tools"

View File

@ -1,8 +0,0 @@
DESCRIPTION = "Testing programs for gateways."
SECTION = "devel"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://package.xml;beginline=10;endline=10;md5=d566ef916e9dedc494f5f793a6690ba5"
DEPENDS = "rocon-test"
require rocon-multimaster.inc

View File

@ -1,8 +0,0 @@
DESCRIPTION = "Utilities for gateway users (avoids large dependency requirements)."
SECTION = "devel"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://package.xml;beginline=8;endline=8;md5=d566ef916e9dedc494f5f793a6690ba5"
require rocon-multimaster.inc
RDEPENDS_${PN} = "rosgraph gateway-msgs rocon-console rocon-python-comms rosservice"

View File

@ -1,13 +0,0 @@
DESCRIPTION = "A hub acts as a shared key-value store for multiple ros systems (primarily used by gateways)."
SECTION = "devel"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://package.xml;beginline=11;endline=11;md5=d566ef916e9dedc494f5f793a6690ba5"
DEPENDS = "roslint"
require rocon-multimaster.inc
RDEPENDS_${PN} = "gateway-msgs python-cryptography rospy rocon-hub-client \
rocon-console rocon-python-comms rocon-python-redis rocon-gateway-utils \
rocon-python-utils rocon-python-wifi roslib rostopic rosservice rosgraph \
std-srvs zeroconf-msgs zeroconf-avahi"

View File

@ -1,8 +0,0 @@
DESCRIPTION = "Client api for discovery and connection to rocon hubs."
SECTION = "devel"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://package.xml;beginline=10;endline=10;md5=d566ef916e9dedc494f5f793a6690ba5"
require rocon-multimaster.inc
RDEPENDS_${PN} = "gateway-msgs rospy rocon-python-redis rocon-gateway-utils"

View File

@ -1,11 +0,0 @@
DESCRIPTION = "A hub acts as a shared key-value store for multiple ros systems (primarily used by gateways)."
SECTION = "devel"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://package.xml;beginline=11;endline=11;md5=d566ef916e9dedc494f5f793a6690ba5"
DEPENDS = "roslint"
require rocon-multimaster.inc
RDEPENDS_${PN} = "avahi-daemon avahi-utils redis std-srvs rosgraph rocon-console \
rocon-gateway rocon-python-comms rocon-python-redis rocon-semantic-version"

View File

@ -1,9 +0,0 @@
SRC_URI = "https://github.com/robotics-in-concert/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
SRC_URI[md5sum] = "1b48d8efe8c69eeecc90a0e53329e8ac"
SRC_URI[sha256sum] = "eb5806aaab740a202c3e0f9f1899c9b5ce57cd8353f88028e95aa0bc2d966659"
S = "${WORKDIR}/${ROS_SP}/${ROS_BPN}"
inherit catkin
ROS_SPN = "rocon_multimaster"

View File

@ -1,11 +0,0 @@
DESCRIPTION = "Rocon test framework (i.e. multi-launch rostest framework)."
SECTION = "devel"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://package.xml;beginline=8;endline=8;md5=d566ef916e9dedc494f5f793a6690ba5"
DEPENDS = "rostest"
require rocon-multimaster.inc
RDEPENDS_${PN} = "rospy rostest rosunit rocon-console rocon-python-utils \
roslaunch rocon-launch"

View File

@ -1,8 +0,0 @@
SRC_URI = "git://github.com/hbrobotics/${ROS_SPN}.git;protocol=https;branch=hydro-devel"
SRCREV = "4f45c3467d724cd7a25db3445f4c98dc759e8fd0"
S = "${WORKDIR}/git/${ROS_BPN}"
inherit catkin
ROS_SPN = "ros_arduino_bridge"

View File

@ -1,6 +0,0 @@
DESCRIPTION = "ROS Arduino Firmware"
SECTION = "devel"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://package.xml;beginline=9;endline=9;md5=d566ef916e9dedc494f5f793a6690ba5"
require ros-arduino-bridge.inc

View File

@ -1,8 +0,0 @@
DESCRIPTION = "ROS Arduino messages"
SECTION = "devel"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://package.xml;beginline=9;endline=9;md5=d566ef916e9dedc494f5f793a6690ba5"
DEPENDS = "message-generation std-msgs"
require ros-arduino-bridge.inc

View File

@ -1,8 +0,0 @@
DESCRIPTION = "ROS Arduino Python"
SECTION = "devel"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://package.xml;beginline=9;endline=9;md5=d566ef916e9dedc494f5f793a6690ba5"
require ros-arduino-bridge.inc
RDEPENDS_${PN} = "rospy std-msgs sensor-msgs geometry-msgs nav-msgs tf ros-arduino-msgs python-pyserial"

View File

@ -1,29 +0,0 @@
DESCRIPTION = "This package is a simple wrapper around the pocketsphinx speech recognizer, \
using gstreamer and a Python-based interface."
SECTION = "devel"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://package.xml;beginline=10;endline=10;md5=d566ef916e9dedc494f5f793a6690ba5"
SRC_URI = "https://github.com/mikeferguson/pocketsphinx/archive/${PV}.tar.gz;downloadfilename=${PN}.tar.gz"
SRC_URI[md5sum] = "814912c0fa4e28dee0e7abc2576f1ad2"
SRC_URI[sha256sum] = "79aed79079d1ca4ac470ea55a82c1de13473df29187b7e8ecec86969c253284a"
S = "${WORKDIR}/pocketsphinx-${PV}"
inherit catkin
do_configure_prepend () {
#rename pocketsphinx to ros_pocketsphinx, to avoid collision with original pocketsphinx
sed -i 's:project(pocketsphinx):project(${ROS_SPN}):g' ${S}/CMakeLists.txt
sed -i 's:<name>pocketsphinx</name>:<name>${ROS_SPN}</name>:g' ${S}/package.xml
sed -i "s:load_manifest('pocketsphinx'):load_manifest('${ROS_SPN}'):g" ${S}/nodes/*py
sed -i 's:pkg="pocketsphinx:pkg="${ROS_SPN}:g' ${S}/demo/*launch
sed -i 's:find pocketsphinx:find ${ROS_SPN}:g' ${S}/demo/*launch
}
RDEPENDS_${PN} = "std-srvs rospy gstreamer0.10-pocketsphinx"
#provides gconfaudiosrc, used to find name of microphone
RRECOMMENDS_${PN} += "gst-plugins-good-gconfelements"
ROS_SPN = "ros_pocketsphinx"

View File

@ -1,8 +0,0 @@
DESCRIPTION = "Tests for validating the real-time capabilities of the ROS publish subscribe communication mechanism"
SECTION = "devel"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://${WORKDIR}/${ROS_SP}/LICENSE.bsd;md5=53d029b66e4cf837754fabf81702aad6"
DEPENDS = "roscpp message-generation message-runtime std-msgs rt-tests-support"
require ros-realtime-tests.inc

View File

@ -1,8 +0,0 @@
DESCRIPTION = "Tests for validating the real-time capabilities of the cyclic ROS timer function"
SECTION = "devel"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://${WORKDIR}/${ROS_SP}/LICENSE.bsd;md5=53d029b66e4cf837754fabf81702aad6"
DEPENDS = "roscpp rt-tests-support"
require ros-realtime-tests.inc

View File

@ -1,8 +0,0 @@
DESCRIPTION = "Tests for validating the real-time capabilities of the ROS oneshot timer function"
SECTION = "devel"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://${WORKDIR}/${ROS_SP}/LICENSE.bsd;md5=53d029b66e4cf837754fabf81702aad6"
DEPENDS = "roscpp rt-tests-support"
require ros-realtime-tests.inc

View File

@ -1,9 +0,0 @@
SRC_URI = "https://github.com/bmwcarit/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
SRC_URI[md5sum] = "e9724fb9ea7b4b79cc3bff37dc3e746f"
SRC_URI[sha256sum] = "073ce024a30bc4c340a0be8e6dee731cd8fc2a7dd124e2d7062e523877988063"
S = "${WORKDIR}/${ROS_SP}/${ROS_BPN}"
inherit catkin
ROS_SPN = "ros_realtime_tests"

View File

@ -1,8 +0,0 @@
DESCRIPTION = "Tests for validating the real-time capabilities of the cyclic ROS timer function"
SECTION = "devel"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://${WORKDIR}/${ROS_SP}/LICENSE.bsd;md5=53d029b66e4cf837754fabf81702aad6"
DEPENDS = "roscpp"
require ros-realtime-tests.inc

View File

@ -1,16 +0,0 @@
DESCRIPTION = "This package contains a ROS wrapper for OpenSlam's Gmapping."
SECTION = "devel"
LICENSE = "CC-BY-NC-SA-2.0"
LIC_FILES_CHKSUM = "file://package.xml;beginline=11;endline=11;md5=11e24f757f025b2cbebd5b14b4a7ca19"
DEPENDS = "nodelet nav-msgs openslam-gmapping roscpp tf rosbag-storage"
SRC_URI = "https://github.com/ros-perception/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
SRC_URI[md5sum] = "b70ca310173d7234d7892f2ab7b21245"
SRC_URI[sha256sum] = "a4eae02f88d599bf34ed8d3865d37e276af22a644d4c45c3fe35d90a48378abc"
S = "${WORKDIR}/${ROS_SP}/${ROS_BPN}"
inherit catkin
ROS_SPN = "slam_gmapping"

View File

@ -1,63 +0,0 @@
From aa0fce16bc80ce7a890dc63b380462f3819cf5e0 Mon Sep 17 00:00:00 2001
From: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
Date: Sat, 14 Jan 2017 06:42:53 +0100
Subject: [PATCH] address gcc6 build error
With gcc6, compiling fails with `stdlib.h: No such file or directory`,
as including '-isystem /usr/include' breaks with gcc6, cf.,
https://gcc.gnu.org/bugzilla/show_bug.cgi?id=70129.
This commit addresses this issue for this package in the same way
it was addressed in various other ROS packages. A list of related
commits and pull requests is at:
https://github.com/ros/rosdistro/issues/12783
The SYSTEM attribute for the include directories was added in commit
188f8fe9 on 2012-11-10 when the packages were changed to use catkin as
build system. The exact reason for using the SYSTEM attribute cannot be
inferred from that commit.
Signed-off-by: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
Upstream-Status: Accepted [https://github.com/stonier/zeroconf_avahi_suite/pull/6/commits/aa0fce16bc80ce7a890dc63b380462f3819cf5e0]
This patch has been generated with:
`git format-patch -1 aa0fce16bc80ce7a890dc63b380462f3819cf5e0`
in the zeroconf_avahi_suite repository.
Signed-off-by: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
---
zeroconf_avahi/CMakeLists.txt | 2 +-
zeroconf_avahi_demos/CMakeLists.txt | 2 +-
2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/zeroconf_avahi/CMakeLists.txt b/zeroconf_avahi/CMakeLists.txt
index 7a05c7c..ec1a48a 100644
--- a/zeroconf_avahi/CMakeLists.txt
+++ b/zeroconf_avahi/CMakeLists.txt
@@ -21,7 +21,7 @@ catkin_package(
CATKIN_DEPENDS rosconsole roscpp zeroconf_msgs
DEPENDS Boost
)
-include_directories(SYSTEM include ${catkin_INCLUDE_DIRS} ${Boost_INCLUDES} ${AVAHI_INCLUDE_DIR})
+include_directories(include ${catkin_INCLUDE_DIRS} ${Boost_INCLUDES} ${AVAHI_INCLUDE_DIR})
##############################################################################
# Project
diff --git a/zeroconf_avahi_demos/CMakeLists.txt b/zeroconf_avahi_demos/CMakeLists.txt
index c558870..17495a4 100644
--- a/zeroconf_avahi_demos/CMakeLists.txt
+++ b/zeroconf_avahi_demos/CMakeLists.txt
@@ -15,7 +15,7 @@ find_package(catkin REQUIRED COMPONENTS zeroconf_avahi zeroconf_msgs)
set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} ${zeroconf_avahi_DIR})
find_package(Avahi REQUIRED)
catkin_package()
-include_directories(SYSTEM include ${catkin_INCLUDE_DIRS} ${AVAHI_INCLUDE_DIR})
+include_directories(include ${catkin_INCLUDE_DIRS} ${AVAHI_INCLUDE_DIR})
##############################################################################
# Project
--
2.5.5

View File

@ -1,10 +0,0 @@
DESCRIPTION = "Several demos and launch-tests for the avahi based zero-configuration."
SECTION = "devel"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://package.xml;beginline=9;endline=9;md5=d566ef916e9dedc494f5f793a6690ba5"
DEPENDS = "zeroconf-msgs zeroconf-avahi"
require zeroconf-avahi-suite.inc
RDEPENDS_${PN} = "avahi-daemon bash"

View File

@ -1,11 +0,0 @@
SRC_URI = "https://github.com/stonier/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
SRC_URI[md5sum] = "b0212776e9c4ae69800a0a4a06e0ad25"
SRC_URI[sha256sum] = "37c1a7febd79ce67cf03f6bbf69dd839ca1efe576b46f22ff6a4ca66e7f8a791"
SRC_URI += "file://0001-address-gcc6-build-error.patch;patchdir=.."
S = "${WORKDIR}/${ROS_SP}/${ROS_BPN}"
inherit catkin
ROS_SPN = "zeroconf_avahi_suite"

View File

@ -1,8 +0,0 @@
DESCRIPTION = "Provides zeroconf services on avahi for ros systems."
SECTION = "devel"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://package.xml;beginline=8;endline=8;md5=d566ef916e9dedc494f5f793a6690ba5"
DEPENDS = "rosconsole roscpp zeroconf-msgs avahi"
require zeroconf-avahi-suite.inc