robot-pose-ekf: initial commit

This commit is contained in:
Kristof Robot 2014-02-09 19:04:26 +01:00
parent 995532c656
commit 1d8895f830
2 changed files with 26 additions and 0 deletions

View File

@ -0,0 +1,16 @@
--- a/robot_pose_ekf/CMakeLists.txt 2014-02-26 22:23:47.631541505 +0100
+++ b/robot_pose_ekf/CMakeLists.txt 2014-02-26 22:23:58.219541227 +0100
@@ -77,6 +77,7 @@
## Tests are failing on OSX for an unknown reason
include(CMakeDetermineSystem)
if(CMAKE_SYSTEM_NAME MATCHES "Linux")
+if(CATKIN_ENABLE_TESTING)
catkin_download_test_data(download_data_ekf_test2_indexed.bag http://download.ros.org/data/robot_pose_ekf/ekf_test2_indexed.bag FILENAME test/ekf_test2.bag MD5 71addef0ed900e05b301e0b4fdca99e2)
add_executable(test_robot_pose_ekf test/test_robot_pose_ekf.cpp)
@@ -98,4 +99,5 @@
)
add_rostest(${CMAKE_CURRENT_SOURCE_DIR}/test/test_robot_pose_ekf_zero_covariance.launch)
+endif(CATKIN_ENABLE_TESTING)
endif(CMAKE_SYSTEM_NAME MATCHES "Linux")

View File

@ -0,0 +1,10 @@
DESCRIPTION = "The Robot Pose EKF package is used to estimate the 3D pose of a robot, based on (partial) pose measurements coming from different sources. It uses an extended Kalman filter with a 6D model (3D position and 3D orientation) to combine measurements from wheel odometry, IMU sensor and visual odometry. The basic idea is to offer loosely coupled integration with different sensors, where sensor signals are received as ROS messages."
SECTION = "devel"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://package.xml;beginline=12;endline=12;md5=01c2bc31767ccb3a68e12f02612b2a97"
DEPENDS = "roscpp bfl std-msgs geometry-msgs sensor-msgs nav-msgs tf"
require navigation.inc
SRC_URI += "file://0001-check-for-CATKIN_ENABLE_TESTING.patch;striplevel=2"