rospy-tutorials: replacing patch by patch provided upstream
This commit is contained in:
parent
0482cca1f5
commit
2584cec31e
|
@ -0,0 +1,33 @@
|
||||||
|
From 8e1fdde288fe2f1edb20e504846dabac026ca2ff Mon Sep 17 00:00:00 2001
|
||||||
|
From: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
|
||||||
|
Date: Tue, 4 Feb 2014 16:07:10 +0100
|
||||||
|
Subject: [PATCH] make rostest in CMakeLists optional (ros/rosdistro#3010)
|
||||||
|
|
||||||
|
---
|
||||||
|
rospy_tutorials/CMakeLists.txt | 3 ++-
|
||||||
|
1 file changed, 2 insertions(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/rospy_tutorials/CMakeLists.txt b/rospy_tutorials/CMakeLists.txt
|
||||||
|
index b588dfc..5287af3 100644
|
||||||
|
--- a/rospy_tutorials/CMakeLists.txt
|
||||||
|
+++ b/rospy_tutorials/CMakeLists.txt
|
||||||
|
@@ -1,7 +1,7 @@
|
||||||
|
cmake_minimum_required(VERSION 2.8.3)
|
||||||
|
project(rospy_tutorials)
|
||||||
|
|
||||||
|
-find_package(catkin REQUIRED COMPONENTS message_generation rostest std_msgs)
|
||||||
|
+find_package(catkin REQUIRED COMPONENTS message_generation std_msgs)
|
||||||
|
|
||||||
|
add_message_files(DIRECTORY msg FILES Floats.msg HeaderString.msg)
|
||||||
|
add_service_files(DIRECTORY srv FILES AddTwoInts.srv BadTwoInts.srv)
|
||||||
|
@@ -27,6 +27,7 @@ foreach(T
|
||||||
|
endforeach()
|
||||||
|
|
||||||
|
if(CATKIN_ENABLE_TESTING)
|
||||||
|
+ find_package(rostest)
|
||||||
|
foreach(T
|
||||||
|
test/test-add-two-ints.launch
|
||||||
|
test/test-peer-subscribe-notify.launch
|
||||||
|
--
|
||||||
|
1.8.3.2
|
||||||
|
|
|
@ -1,29 +0,0 @@
|
||||||
From 3eaf40260ea400cb779ca229cbf3ab27f5a2b6eb Mon Sep 17 00:00:00 2001
|
|
||||||
From: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
|
|
||||||
Date: Sat, 21 Sep 2013 16:33:11 +0200
|
|
||||||
Subject: [PATCH] rostest is optional
|
|
||||||
|
|
||||||
---
|
|
||||||
rospy_tutorials/CMakeLists.txt | 6 +++++-
|
|
||||||
1 file changed, 5 insertions(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/rospy_tutorials/CMakeLists.txt b/rospy_tutorials/CMakeLists.txt
|
|
||||||
index b588dfc..a48ec0d 100644
|
|
||||||
--- a/rospy_tutorials/CMakeLists.txt
|
|
||||||
+++ b/rospy_tutorials/CMakeLists.txt
|
|
||||||
@@ -1,7 +1,11 @@
|
|
||||||
cmake_minimum_required(VERSION 2.8.3)
|
|
||||||
project(rospy_tutorials)
|
|
||||||
|
|
||||||
-find_package(catkin REQUIRED COMPONENTS message_generation rostest std_msgs)
|
|
||||||
+if(CATKIN_ENABLE_TESTING)
|
|
||||||
+ find_package(catkin REQUIRED COMPONENTS message_generation rostest std_msgs)
|
|
||||||
+else()
|
|
||||||
+ find_package(catkin REQUIRED COMPONENTS message_generation std_msgs)
|
|
||||||
+endif()
|
|
||||||
|
|
||||||
add_message_files(DIRECTORY msg FILES Floats.msg HeaderString.msg)
|
|
||||||
add_service_files(DIRECTORY srv FILES AddTwoInts.srv BadTwoInts.srv)
|
|
||||||
--
|
|
||||||
1.7.10.4
|
|
||||||
|
|
|
@ -7,4 +7,4 @@ DEPENDS = "message-generation std-msgs cpp-common roscpp-serialization"
|
||||||
|
|
||||||
require ros-tutorials.inc
|
require ros-tutorials.inc
|
||||||
|
|
||||||
SRC_URI += "file://0001-rostest-is-optional.patch;striplevel=2"
|
SRC_URI += "file://0001-make-rostest-in-CMakeLists-optional-ros-rosdistro-30.patch;striplevel=2"
|
||||||
|
|
Loading…
Reference in New Issue