ros-controllers: adding patches to drop rostest dependency

This commit is contained in:
Lukas Bulwahn 2014-07-31 22:00:08 +02:00
parent 078786a259
commit 2a0777a4ce
4 changed files with 87 additions and 3 deletions

View File

@ -0,0 +1,38 @@
From 79856f596b827981fb5dad854c56347b912836fd Mon Sep 17 00:00:00 2001
From: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
Date: Thu, 31 Jul 2014 21:06:41 +0200
Subject: [PATCH] gripper_action_controller: drop unneeded rostest dependency
Upstream-Status: Accepted
---
gripper_action_controller/CMakeLists.txt | 1 -
gripper_action_controller/package.xml | 1 -
2 files changed, 2 deletions(-)
diff --git a/gripper_action_controller/CMakeLists.txt b/gripper_action_controller/CMakeLists.txt
index 555ec69..2b925a9 100644
--- a/gripper_action_controller/CMakeLists.txt
+++ b/gripper_action_controller/CMakeLists.txt
@@ -17,7 +17,6 @@ find_package(catkin
realtime_tools
control_msgs
trajectory_msgs
- rostest
controller_manager
xacro
)
diff --git a/gripper_action_controller/package.xml b/gripper_action_controller/package.xml
index 513321b..2607005 100644
--- a/gripper_action_controller/package.xml
+++ b/gripper_action_controller/package.xml
@@ -49,7 +49,6 @@
<build_depend>controller_manager</build_depend>
<build_depend>hardware_interface</build_depend>
<build_depend>realtime_tools</build_depend>
- <build_depend>rostest</build_depend>
<build_depend>trajectory_msgs</build_depend>
<build_depend>urdf</build_depend>
<build_depend>xacro</build_depend>
--
1.7.9.5

View File

@ -4,6 +4,8 @@ LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://package.xml;beginline=16;endline=16;md5=d566ef916e9dedc494f5f793a6690ba5"
DEPENDS = "actionlib angles cmake-modules roscpp urdf control-toolbox controller-interface \
hardware-interface realtime-tools control-msgs trajectory-msgs rostest controller-manager xacro"
hardware-interface realtime-tools control-msgs trajectory-msgs controller-manager xacro"
require ros-controllers.inc
SRC_URI += "file://0001-gripper_action_controller-drop-unneeded-rostest-depe.patch;striplevel=2"

View File

@ -0,0 +1,43 @@
From f87e0c5c30bf99e0a45cfef7a8dc17a60ac41cba Mon Sep 17 00:00:00 2001
From: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
Date: Thu, 31 Jul 2014 21:18:31 +0200
Subject: [PATCH] joint_trajectory_controller: make rostest in CMakeLists
optional (ros/rosdistro#3010)
Upstream-Status: Accepted
---
joint_trajectory_controller/CMakeLists.txt | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/joint_trajectory_controller/CMakeLists.txt b/joint_trajectory_controller/CMakeLists.txt
index 06e9d93..9687ec3 100644
--- a/joint_trajectory_controller/CMakeLists.txt
+++ b/joint_trajectory_controller/CMakeLists.txt
@@ -61,7 +61,6 @@ else()
realtime_tools
control_msgs
trajectory_msgs
- rostest
controller_manager
xacro
)
@@ -79,7 +78,6 @@ else()
realtime_tools
control_msgs
trajectory_msgs
- rostest
controller_manager
xacro
INCLUDE_DIRS include
@@ -103,6 +101,8 @@ else()
target_link_libraries(${PROJECT_NAME} ${catkin_LIBRARIES})
if(CATKIN_ENABLE_TESTING)
+ find_package(rostest)
+
catkin_add_gtest(quintic_spline_segment_test test/quintic_spline_segment_test.cpp)
target_link_libraries(quintic_spline_segment_test ${catkin_LIBRARIES})
--
1.7.9.5

View File

@ -3,8 +3,9 @@ SECTION = "devel"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://package.xml;beginline=8;endline=8;md5=d566ef916e9dedc494f5f793a6690ba5"
DEPENDS = "actionlib angles cmake-modules control-toolbox controller-interface controller-manager control-msgs rostest urdf xacro"
DEPENDS = "actionlib angles cmake-modules control-toolbox controller-interface controller-manager control-msgs urdf xacro"
require ros-controllers.inc
SRC_URI += "file://0001-check-for-CATKIN_ENABLE_TESTING.patch;striplevel=2"
SRC_URI += "file://0001-check-for-CATKIN_ENABLE_TESTING.patch;striplevel=2 \
file://0001-joint_trajectory_controller-make-rostest-in-CMakeLis.patch;striplevel=2"