ros-control: updating to 0.7.3
The patch in the meta-ros repository has been submitted and included in version 0.7.3 and hence is deleted in this commit.
This commit is contained in:
parent
6ef9654f7c
commit
2d297b21c8
|
@ -1,56 +0,0 @@
|
||||||
From 00fbc3fa30d78c10e13ecd04d85ecf98a39a4bb2 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
|
|
||||||
Date: Sun, 27 Jul 2014 09:07:29 +0200
|
|
||||||
Subject: [PATCH] make rostest in CMakeLists optional (ros/rosdistro#3010)
|
|
||||||
|
|
||||||
Upstream-Status: Accepted
|
|
||||||
---
|
|
||||||
controller_manager_tests/CMakeLists.txt | 3 ++-
|
|
||||||
joint_limits_interface/CMakeLists.txt | 3 ++-
|
|
||||||
2 files changed, 4 insertions(+), 2 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/controller_manager_tests/CMakeLists.txt b/controller_manager_tests/CMakeLists.txt
|
|
||||||
index 64731bd..badc147 100644
|
|
||||||
--- a/controller_manager_tests/CMakeLists.txt
|
|
||||||
+++ b/controller_manager_tests/CMakeLists.txt
|
|
||||||
@@ -29,7 +29,7 @@ if(USE_ROSBUILD)
|
|
||||||
else()
|
|
||||||
|
|
||||||
# Load catkin and all dependencies required for this package
|
|
||||||
- find_package(catkin REQUIRED COMPONENTS rostest controller_manager controller_interface control_toolbox)
|
|
||||||
+ find_package(catkin REQUIRED COMPONENTS controller_manager controller_interface control_toolbox)
|
|
||||||
|
|
||||||
include_directories(include ${Boost_INCLUDE_DIR} ${catkin_INCLUDE_DIRS})
|
|
||||||
|
|
||||||
@@ -54,6 +54,7 @@ else()
|
|
||||||
target_link_libraries(dummy_app ${PROJECT_NAME} ${catkin_LIBRARIES})
|
|
||||||
|
|
||||||
if(CATKIN_ENABLE_TESTING)
|
|
||||||
+ find_package(rostest)
|
|
||||||
add_executable(cm_test test/cm_test.cpp)
|
|
||||||
add_dependencies(tests cm_test)
|
|
||||||
target_link_libraries(cm_test ${GTEST_LIBRARIES} ${catkin_LIBRARIES})
|
|
||||||
diff --git a/joint_limits_interface/CMakeLists.txt b/joint_limits_interface/CMakeLists.txt
|
|
||||||
index fedaadd..f8305f1 100644
|
|
||||||
--- a/joint_limits_interface/CMakeLists.txt
|
|
||||||
+++ b/joint_limits_interface/CMakeLists.txt
|
|
||||||
@@ -25,7 +25,6 @@ else() # catkin
|
|
||||||
|
|
||||||
find_package(catkin REQUIRED
|
|
||||||
roscpp
|
|
||||||
- rostest
|
|
||||||
hardware_interface
|
|
||||||
urdfdom
|
|
||||||
)
|
|
||||||
@@ -49,6 +48,8 @@ else() # catkin
|
|
||||||
)
|
|
||||||
|
|
||||||
if(CATKIN_ENABLE_TESTING)
|
|
||||||
+ find_package(rostest)
|
|
||||||
+
|
|
||||||
catkin_add_gtest(joint_limits_interface_test test/joint_limits_interface_test.cpp)
|
|
||||||
target_link_libraries(joint_limits_interface_test ${catkin_LIBRARIES})
|
|
||||||
|
|
||||||
--
|
|
||||||
1.9.3
|
|
||||||
|
|
|
@ -1,8 +1,6 @@
|
||||||
SRC_URI = "https://github.com/ros-controls/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
|
SRC_URI = "https://github.com/ros-controls/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
|
||||||
SRC_URI[md5sum] = "4eadd134fcb828a341fc65ff521f7e5c"
|
SRC_URI[md5sum] = "58d4b8a8d98120bb3a46cee07168287d"
|
||||||
SRC_URI[sha256sum] = "7bc3bfde309e0938cf2cd639d97e95c06e837c140831357378df861e3b657577"
|
SRC_URI[sha256sum] = "48f841a2a4f048d08149488028289da8b8374a2aab91c5e2c628300a574cac37"
|
||||||
|
|
||||||
SRC_URI += "file://0001-make-rostest-in-CMakeLists-optional-ros-rosdistro-30.patch;patchdir=.."
|
|
||||||
|
|
||||||
S = "${WORKDIR}/${ROS_SP}/${ROS_BPN}"
|
S = "${WORKDIR}/${ROS_SP}/${ROS_BPN}"
|
||||||
|
|
||||||
|
|
Loading…
Reference in New Issue