DRAFT python3-flake8: Add patch to drop build dependency on pytest-runner
This commit is contained in:
parent
2f185c3360
commit
33fa6b7861
|
@ -0,0 +1,17 @@
|
|||
Remove unnecessary pytest-runner from setup_requires.
|
||||
|
||||
Modelled after similar patch to python3-mccabe.
|
||||
|
||||
Upstream-Status: Pending
|
||||
---
|
||||
diff -U3 -r flake8-3.5.0-orig/setup.py flake8-3.5.0/setup.py
|
||||
--- flake8-3.5.0-orig/setup.py 2019-04-25 15:11:52.406978457 -0700
|
||||
+++ flake8-3.5.0/setup.py 2019-04-25 15:12:38.102978457 -0700
|
||||
@@ -142,6 +142,5 @@
|
||||
"Topic :: Software Development :: Libraries :: Python Modules",
|
||||
"Topic :: Software Development :: Quality Assurance",
|
||||
],
|
||||
- tests_require=tests_require,
|
||||
- setup_requires=['pytest-runner'],
|
||||
+ tests_require=tests_require
|
||||
)
|
|
@ -1,8 +1,12 @@
|
|||
DESCRIPTION = "The modular source code checker: pep8, pyflakes and co"
|
||||
HOMEPAGE = "https://github.com/dreamhost/cliff"
|
||||
SECTION = "devel/python"
|
||||
LICENSE = "Apache-2.0"
|
||||
LIC_FILES_CHKSUM = "file://LICENSE;md5=7a76e57e683629e1ac2a49406169c2a3"
|
||||
LICENSE = "MIT"
|
||||
LIC_FILES_CHKSUM = "file://LICENSE;md5=75b26781f1adf1aa310bda6098937878"
|
||||
|
||||
SRC_URI += " \
|
||||
file://drop-pytest-runner-from-setup_requires.patch \
|
||||
"
|
||||
|
||||
SRC_URI[md5sum] = "7e5fe39d578a2c2d0962b61b35b8c3fc"
|
||||
SRC_URI[sha256sum] = "7253265f7abd8b313e3892944044a365e3f4ac3fcdcfb4298f55ee9ddf188ba0"
|
||||
|
|
Loading…
Reference in New Issue