Merge pull request #508 from bulwahn/indigo-updates
Recipe updates for the indigo distribution
This commit is contained in:
commit
36eb1dd4f2
|
@ -1,8 +1,6 @@
|
|||
SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
|
||||
SRC_URI[md5sum] = "34bb53fbcf57924cc2c15e185451869b"
|
||||
SRC_URI[sha256sum] = "9f2c6012f60e55e7735ba2d08dbc9bcd96f09ca9d3df223a0f1966bdab454dea"
|
||||
|
||||
SRC_URI += "file://0001-make-rostest-in-CMakeLists-optional-ros-rosdistro-30.patch;patchdir=.."
|
||||
SRC_URI[md5sum] = "9659e0b3e37108a78f3353ce55cee98e"
|
||||
SRC_URI[sha256sum] = "9cd6f439e55195b482b9702369514dde25865a256f3059eb7f475da7ddd483d6"
|
||||
|
||||
S = "${WORKDIR}/${ROS_SP}/${ROS_BPN}"
|
||||
|
||||
|
|
|
@ -1,77 +0,0 @@
|
|||
From aa8052e042192946386d2c564baa1883c4866593 Mon Sep 17 00:00:00 2001
|
||||
From: Lukas Bulwahn <lukas.bulwahn@gmail.com>
|
||||
Date: Wed, 5 Apr 2017 10:58:34 +0200
|
||||
Subject: [PATCH] make rostest in CMakeLists optional (ros/rosdistro#3010)
|
||||
|
||||
Upstream-Status: Submitted [https://github.com/ros/diagnostics/pull/60]
|
||||
|
||||
Signed-off-by: Lukas Bulwahn <lukas.bulwahn@gmail.com>
|
||||
---
|
||||
diagnostic_aggregator/CMakeLists.txt | 3 ++-
|
||||
diagnostic_analysis/CMakeLists.txt | 3 ++-
|
||||
diagnostic_updater/CMakeLists.txt | 3 ++-
|
||||
3 files changed, 6 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/diagnostic_aggregator/CMakeLists.txt b/diagnostic_aggregator/CMakeLists.txt
|
||||
index 5995f67..1660d94 100644
|
||||
--- a/diagnostic_aggregator/CMakeLists.txt
|
||||
+++ b/diagnostic_aggregator/CMakeLists.txt
|
||||
@@ -3,7 +3,7 @@ cmake_minimum_required(VERSION 2.8.3)
|
||||
project(diagnostic_aggregator)
|
||||
|
||||
# Load catkin and all dependencies required for this package
|
||||
-find_package(catkin REQUIRED diagnostic_msgs pluginlib roscpp rospy rostest xmlrpcpp bondcpp)
|
||||
+find_package(catkin REQUIRED diagnostic_msgs pluginlib roscpp rospy xmlrpcpp bondcpp)
|
||||
catkin_package(DEPENDS diagnostic_msgs pluginlib roscpp rospy xmlrpcpp bondcpp bondpy
|
||||
INCLUDE_DIRS include
|
||||
LIBRARIES ${PROJECT_NAME})
|
||||
@@ -46,6 +46,7 @@ add_executable(analyzer_loader test/analyzer_loader.cpp
|
||||
target_link_libraries(analyzer_loader diagnostic_aggregator)
|
||||
|
||||
if(CATKIN_ENABLE_TESTING)
|
||||
+ find_package(rostest REQUIRED)
|
||||
add_rostest(test/launch/test_agg.launch)
|
||||
add_rostest(test/launch/test_add_agg.launch)
|
||||
|
||||
diff --git a/diagnostic_analysis/CMakeLists.txt b/diagnostic_analysis/CMakeLists.txt
|
||||
index c20c24c..eb8cf64 100644
|
||||
--- a/diagnostic_analysis/CMakeLists.txt
|
||||
+++ b/diagnostic_analysis/CMakeLists.txt
|
||||
@@ -2,11 +2,12 @@ cmake_minimum_required(VERSION 2.8.3)
|
||||
project(diagnostic_analysis)
|
||||
|
||||
# Load catkin and all dependencies required for this package
|
||||
-find_package(catkin REQUIRED diagnostic_msgs rosbag roslib rostest)
|
||||
+find_package(catkin REQUIRED diagnostic_msgs rosbag roslib)
|
||||
|
||||
catkin_package(DEPENDS diagnostic_msgs rosbag roslib)
|
||||
|
||||
if(CATKIN_ENABLE_TESTING)
|
||||
+ find_package(rostest REQUIRED)
|
||||
catkin_add_nosetests(test/bag_csv_test.py)
|
||||
endif()
|
||||
|
||||
diff --git a/diagnostic_updater/CMakeLists.txt b/diagnostic_updater/CMakeLists.txt
|
||||
index 72f7af0..7dae0a1 100644
|
||||
--- a/diagnostic_updater/CMakeLists.txt
|
||||
+++ b/diagnostic_updater/CMakeLists.txt
|
||||
@@ -2,7 +2,7 @@ cmake_minimum_required(VERSION 2.8.3)
|
||||
project(diagnostic_updater)
|
||||
|
||||
# Load catkin and all dependencies required for this package
|
||||
-find_package(catkin REQUIRED diagnostic_msgs roscpp rostest std_msgs)
|
||||
+find_package(catkin REQUIRED diagnostic_msgs roscpp std_msgs)
|
||||
|
||||
catkin_python_setup()
|
||||
|
||||
@@ -15,6 +15,7 @@ add_executable(example src/example.cpp)
|
||||
target_link_libraries(example ${catkin_LIBRARIES})
|
||||
|
||||
if(CATKIN_ENABLE_TESTING)
|
||||
+ find_package(rostest REQUIRED)
|
||||
add_rostest_gtest(diagnostic_updater_test test/diagnostic_updater_test.xml test/diagnostic_updater_test.cpp)
|
||||
add_rostest(test/diagnostic_updater_fast_test.xml)
|
||||
target_link_libraries(diagnostic_updater_test ${catkin_LIBRARIES})
|
||||
--
|
||||
2.5.5
|
||||
|
|
@ -0,0 +1,33 @@
|
|||
From 579993db0e7ef1f6820b39f4e7598324c0bde097 Mon Sep 17 00:00:00 2001
|
||||
From: Lukas Bulwahn <lukas.bulwahn@gmail.com>
|
||||
Date: Tue, 2 May 2017 08:15:28 +0200
|
||||
Subject: [PATCH] find Eigen3 with ROS cmake_modules script
|
||||
|
||||
Upstream-Status: Pending
|
||||
|
||||
Signed-off-by: Lukas Bulwahn <lukas.bulwahn@gmail.com>
|
||||
---
|
||||
depth_image_proc/CMakeLists.txt | 7 ++-----
|
||||
1 file changed, 2 insertions(+), 5 deletions(-)
|
||||
|
||||
diff --git a/depth_image_proc/CMakeLists.txt b/depth_image_proc/CMakeLists.txt
|
||||
index 060d295..dbe26a5 100644
|
||||
--- a/depth_image_proc/CMakeLists.txt
|
||||
+++ b/depth_image_proc/CMakeLists.txt
|
||||
@@ -8,11 +8,8 @@ catkin_package(
|
||||
LIBRARIES ${PROJECT_NAME})
|
||||
|
||||
find_package(Boost REQUIRED)
|
||||
-find_package(Eigen3 QUIET)
|
||||
-if(NOT EIGEN3_FOUND)
|
||||
- find_package(Eigen REQUIRED)
|
||||
- set(EIGEN3_INCLUDE_DIRS ${EIGEN_INCLUDE_DIRS})
|
||||
-endif()
|
||||
+find_package(Eigen REQUIRED)
|
||||
+set(EIGEN3_INCLUDE_DIRS ${EIGEN_INCLUDE_DIRS})
|
||||
find_package(OpenCV REQUIRED)
|
||||
include_directories(include ${BOOST_INCLUDE_DIRS} ${catkin_INCLUDE_DIRS} ${EIGEN3_INCLUDE_DIRS})
|
||||
|
||||
--
|
||||
1.9.1
|
||||
|
|
@ -6,3 +6,5 @@ LIC_FILES_CHKSUM = "file://package.xml;beginline=14;endline=14;md5=d566ef916e9de
|
|||
DEPENDS = "boost cv-bridge eigen-conversions image-geometry image-transport message-filters nodelet sensor-msgs stereo-msgs tf2 tf2-ros"
|
||||
|
||||
require image-pipeline.inc
|
||||
|
||||
SRC_URI += "file://0001-find-Eigen3-with-ROS-cmake_modules-script.patch;striplevel=2"
|
|
@ -1,138 +0,0 @@
|
|||
From 6c2d65452bd5fe62723988a1a570789921900d59 Mon Sep 17 00:00:00 2001
|
||||
From: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
|
||||
Date: Fri, 30 Sep 2016 15:39:47 +0200
|
||||
Subject: [PATCH 1/2] address gcc6 build error
|
||||
|
||||
With gcc6, compiling fails with `stdlib.h: No such file or directory`,
|
||||
as including '-isystem /usr/include' breaks with gcc6, cf.,
|
||||
https://gcc.gnu.org/bugzilla/show_bug.cgi?id=70129.
|
||||
|
||||
This commit addresses this issue for this package in the same way
|
||||
it was addressed in various other ROS packages. A list of related
|
||||
commits and pull requests is at:
|
||||
|
||||
https://github.com/ros/rosdistro/issues/12783
|
||||
|
||||
Signed-off-by: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
|
||||
|
||||
Upstream-Status: Accepted [https://github.com/ros-perception/image_pipeline/commit/6c2d65452bd5fe62723988a1a570789921900d59]
|
||||
|
||||
This patch has been generated with:
|
||||
`git format-patch -2 562332df73781c1e56ce9123542334cc1d91b143`
|
||||
in the image_pipeline repository.
|
||||
|
||||
Signed-off-by: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
|
||||
---
|
||||
depth_image_proc/CMakeLists.txt | 6 +-----
|
||||
image_proc/CMakeLists.txt | 3 +--
|
||||
image_publisher/CMakeLists.txt | 3 +--
|
||||
image_rotate/CMakeLists.txt | 5 +----
|
||||
image_view/CMakeLists.txt | 8 ++++----
|
||||
stereo_image_proc/CMakeLists.txt | 4 +---
|
||||
6 files changed, 9 insertions(+), 20 deletions(-)
|
||||
|
||||
diff --git a/depth_image_proc/CMakeLists.txt b/depth_image_proc/CMakeLists.txt
|
||||
index 0a7c7e2..6ceebfe 100644
|
||||
--- a/depth_image_proc/CMakeLists.txt
|
||||
+++ b/depth_image_proc/CMakeLists.txt
|
||||
@@ -10,11 +10,7 @@ catkin_package(
|
||||
find_package(Boost REQUIRED)
|
||||
find_package(Eigen REQUIRED)
|
||||
find_package(OpenCV REQUIRED)
|
||||
-include_directories(include
|
||||
- SYSTEM ${BOOST_INCLUDE_DIRS}
|
||||
- ${catkin_INCLUDE_DIRS}
|
||||
- ${EIGEN_INCLUDE_DIRS}
|
||||
-)
|
||||
+include_directories(include ${BOOST_INCLUDE_DIRS} ${catkin_INCLUDE_DIRS} ${EIGEN_INCLUDE_DIRS})
|
||||
|
||||
add_library(${PROJECT_NAME} src/nodelets/convert_metric.cpp
|
||||
src/nodelets/crop_foremost.cpp
|
||||
diff --git a/image_proc/CMakeLists.txt b/image_proc/CMakeLists.txt
|
||||
index a13371f..34905f0 100755
|
||||
--- a/image_proc/CMakeLists.txt
|
||||
+++ b/image_proc/CMakeLists.txt
|
||||
@@ -17,8 +17,7 @@ catkin_package(
|
||||
LIBRARIES ${PROJECT_NAME}
|
||||
)
|
||||
|
||||
-include_directories(SYSTEM ${catkin_INCLUDE_DIRS} ${OpenCV_INCLUDE_DIRS})
|
||||
-include_directories(include)
|
||||
+include_directories(include ${catkin_INCLUDE_DIRS} ${OpenCV_INCLUDE_DIRS})
|
||||
|
||||
# Nodelet library
|
||||
add_library(${PROJECT_NAME} src/libimage_proc/processor.cpp
|
||||
diff --git a/image_publisher/CMakeLists.txt b/image_publisher/CMakeLists.txt
|
||||
index 8015a45..431109c 100644
|
||||
--- a/image_publisher/CMakeLists.txt
|
||||
+++ b/image_publisher/CMakeLists.txt
|
||||
@@ -8,8 +8,7 @@ generate_dynamic_reconfigure_options(cfg/ImagePublisher.cfg)
|
||||
|
||||
catkin_package()
|
||||
|
||||
-# add the executable
|
||||
-include_directories(SYSTEM ${catkin_INCLUDE_DIRS})
|
||||
+include_directories(${catkin_INCLUDE_DIRS})
|
||||
|
||||
add_library(${PROJECT_NAME} SHARED src/nodelet/image_publisher_nodelet.cpp)
|
||||
target_link_libraries(${PROJECT_NAME} ${catkin_LIBRARIES})
|
||||
diff --git a/image_rotate/CMakeLists.txt b/image_rotate/CMakeLists.txt
|
||||
index 04ba03b..75d8e77 100644
|
||||
--- a/image_rotate/CMakeLists.txt
|
||||
+++ b/image_rotate/CMakeLists.txt
|
||||
@@ -12,10 +12,7 @@ find_package(OpenCV REQUIRED core imgproc)
|
||||
find_package(Eigen REQUIRED)
|
||||
|
||||
# add the executable
|
||||
-include_directories(SYSTEM ${catkin_INCLUDE_DIRS}
|
||||
- ${EIGEN_INCLUDE_DIRS}
|
||||
- ${OpenCV_INCLUDE_DIRS}
|
||||
-)
|
||||
+include_directories(${catkin_INCLUDE_DIRS} ${EIGEN_INCLUDE_DIRS} ${OpenCV_INCLUDE_DIRS})
|
||||
|
||||
add_library(${PROJECT_NAME} SHARED src/nodelet/image_rotate_nodelet.cpp)
|
||||
target_link_libraries(${PROJECT_NAME} ${catkin_LIBRARIES} ${OpenCV_LIBRARIES})
|
||||
diff --git a/image_view/CMakeLists.txt b/image_view/CMakeLists.txt
|
||||
index 78b9eaa..93fabe7 100644
|
||||
--- a/image_view/CMakeLists.txt
|
||||
+++ b/image_view/CMakeLists.txt
|
||||
@@ -8,9 +8,9 @@ catkin_package(CATKIN_DEPENDS dynamic_reconfigure)
|
||||
find_package(Boost REQUIRED COMPONENTS signals thread)
|
||||
find_package(OpenCV REQUIRED)
|
||||
|
||||
-include_directories(SYSTEM ${Boost_INCLUDE_DIRS}
|
||||
- ${catkin_INCLUDE_DIRS}
|
||||
- ${OpenCV_INCLUDE_DIRS}
|
||||
+include_directories(${Boost_INCLUDE_DIRS}
|
||||
+ ${catkin_INCLUDE_DIRS}
|
||||
+ ${OpenCV_INCLUDE_DIRS}
|
||||
)
|
||||
|
||||
# Extra tools
|
||||
@@ -40,7 +40,7 @@ endif()
|
||||
|
||||
find_package(GTK2)
|
||||
add_definitions(-DHAVE_GTK)
|
||||
-include_directories(SYSTEM ${GTK2_INCLUDE_DIRS})
|
||||
+include_directories(${GTK2_INCLUDE_DIRS})
|
||||
|
||||
# Nodelet library
|
||||
add_library(image_view src/nodelets/image_nodelet.cpp src/nodelets/disparity_nodelet.cpp src/nodelets/window_thread.cpp)
|
||||
diff --git a/stereo_image_proc/CMakeLists.txt b/stereo_image_proc/CMakeLists.txt
|
||||
index b7127d2..e201436 100644
|
||||
--- a/stereo_image_proc/CMakeLists.txt
|
||||
+++ b/stereo_image_proc/CMakeLists.txt
|
||||
@@ -16,9 +16,7 @@ catkin_package(
|
||||
include_directories(include)
|
||||
|
||||
find_package(OpenCV REQUIRED)
|
||||
-include_directories(SYSTEM ${catkin_INCLUDE_DIRS}
|
||||
- ${OpenCV_INCLUDE_DIRS}
|
||||
-)
|
||||
+include_directories(${catkin_INCLUDE_DIRS} ${OpenCV_INCLUDE_DIRS})
|
||||
|
||||
# Nodelet library
|
||||
add_library(${PROJECT_NAME} src/libstereo_image_proc/processor.cpp src/nodelets/disparity.cpp src/nodelets/point_cloud2.cpp)
|
||||
--
|
||||
2.5.5
|
||||
|
|
@ -1,57 +0,0 @@
|
|||
From 562332df73781c1e56ce9123542334cc1d91b143 Mon Sep 17 00:00:00 2001
|
||||
From: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
|
||||
Date: Thu, 6 Oct 2016 08:55:27 +0200
|
||||
Subject: [PATCH 2/2] explicitly cast to std::vector<double> to make gcc6 happy
|
||||
|
||||
With gcc6, compiling image_publisher fails with this error:
|
||||
```
|
||||
/[...]/image_publisher/src/nodelet/image_publisher_nodelet.cpp: In member function 'virtual void image_publisher::ImagePublisherNodelet::onInit()':
|
||||
/[...]/image_publisher/src/nodelet/image_publisher_nodelet.cpp:180:43: error: ambiguous overload for 'operator=' (operand types are 'sensor_msgs::CameraInfo_<std::allocator<void> >::_D_type {aka std::vector<double>}' and 'boost::assign_detail::generic_list<int>')
|
||||
camera_info_.D = list_of(0)(0)(0)(0)(0);
|
||||
```
|
||||
|
||||
After adding an initial explicit type cast for the assignment,
|
||||
compiling fails further with:
|
||||
```
|
||||
| /[...]/image_publisher/src/nodelet/image_publisher_nodelet.cpp: In member function 'virtual void image_publisher::ImagePublisherNodelet::onInit()':
|
||||
| /[...]/image_publisher/src/nodelet/image_publisher_nodelet.cpp:180:65: error: call of overloaded 'vector(boost::assign_detail::generic_list<int>&)' is ambiguous
|
||||
| camera_info_.D = std::vector<double> (list_of(0)(0)(0)(0)(0));
|
||||
```
|
||||
|
||||
Various sources on the internet [1, 2, 3] point to use the
|
||||
`convert_to_container` method; hence, this commit follows those
|
||||
suggestions and with that image_publisher compiles with gcc6.
|
||||
|
||||
[1] http://stackoverflow.com/questions/16211410/ambiguity-when-using-boostassignlist-of-to-construct-a-stdvector
|
||||
[2] http://stackoverflow.com/questions/12352692/ambiguous-call-with-list-of-in-vs2010/12362548#12362548
|
||||
[3] http://stackoverflow.com/questions/13285272/using-boostassignlist-of?rq=1
|
||||
|
||||
Signed-off-by: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
|
||||
|
||||
Upstream-Status: Accepted [https://github.com/ros-perception/image_pipeline/commit/562332df73781c1e56ce9123542334cc1d91b143]
|
||||
|
||||
This patch has been generated with:
|
||||
`git format-patch -2 562332df73781c1e56ce9123542334cc1d91b143`
|
||||
in the image_pipeline repository.
|
||||
|
||||
Signed-off-by: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
|
||||
---
|
||||
image_publisher/src/nodelet/image_publisher_nodelet.cpp | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/image_publisher/src/nodelet/image_publisher_nodelet.cpp b/image_publisher/src/nodelet/image_publisher_nodelet.cpp
|
||||
index 4102d0d..26e1352 100644
|
||||
--- a/image_publisher/src/nodelet/image_publisher_nodelet.cpp
|
||||
+++ b/image_publisher/src/nodelet/image_publisher_nodelet.cpp
|
||||
@@ -177,7 +177,7 @@ public:
|
||||
camera_info_.width = image_.cols;
|
||||
camera_info_.height = image_.rows;
|
||||
camera_info_.distortion_model = "plumb_bob";
|
||||
- camera_info_.D = list_of(0)(0)(0)(0)(0);
|
||||
+ camera_info_.D = list_of(0)(0)(0)(0)(0).convert_to_container<std::vector<double> >();
|
||||
camera_info_.K = list_of(1)(0)(camera_info_.width/2)(0)(1)(camera_info_.height/2)(0)(0)(1);
|
||||
camera_info_.R = list_of(1)(0)(0)(0)(1)(0)(0)(0)(1);
|
||||
camera_info_.P = list_of(1)(0)(camera_info_.width/2)(0)(0)(1)(camera_info_.height/2)(0)(0)(0)(1)(0);
|
||||
--
|
||||
2.5.5
|
||||
|
|
@ -1,9 +1,6 @@
|
|||
SRC_URI = "https://github.com/ros-perception/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
|
||||
SRC_URI[md5sum] = "d727bc9da9f7772649ab7c5c7c9f652e"
|
||||
SRC_URI[sha256sum] = "fc3073428fc930523efd6ed4a86d838ab0f0ff04a312eb4188c72a854d300e97"
|
||||
|
||||
SRC_URI += "file://0001-address-gcc6-build-error.patch;patchdir=.."
|
||||
SRC_URI += "file://0002-explicitly-cast-to-std-vector-double-to-make-gcc6-ha.patch;patchdir=.."
|
||||
SRC_URI[md5sum] = "af3628ca8adaa73be854775c10ebe8a1"
|
||||
SRC_URI[sha256sum] = "b69307689c7fb4e62464254fc24ede26c85087b51519f0b43a33e995dabe1a53"
|
||||
|
||||
S = "${WORKDIR}/${ROS_SP}/${ROS_BPN}"
|
||||
|
||||
|
|
|
@ -3,6 +3,8 @@ SECTION = "devel"
|
|||
LICENSE = "BSD"
|
||||
LIC_FILES_CHKSUM = "file://package.xml;beginline=9;endline=9;md5=d566ef916e9dedc494f5f793a6690ba5"
|
||||
|
||||
DEPENDS = "boost camera-calibration-parsers cv-bridge dynamic-reconfigure image-geometry image-transport nodelet opencv roscpp sensor-msgs ${PYTHON_PN}-rospkg"
|
||||
DEPENDS = "boost camera-calibration-parsers cv-bridge dynamic-reconfigure \
|
||||
image-geometry image-transport nodelet nodelet-topic-tools opencv roscpp \
|
||||
sensor-msgs ${PYTHON_PN}-rospkg"
|
||||
|
||||
require image-pipeline.inc
|
|
@ -0,0 +1,35 @@
|
|||
From e125886b0c497f01541868dc184130e33089f116 Mon Sep 17 00:00:00 2001
|
||||
From: Lukas Bulwahn <lukas.bulwahn@gmail.com>
|
||||
Date: Tue, 2 May 2017 08:42:14 +0200
|
||||
Subject: [PATCH] also build with CATKIN_ENABLE_TESTING=OFF
|
||||
|
||||
Upstream-Status: Pending
|
||||
|
||||
Signed-off-by: Lukas Bulwahn <lukas.bulwahn@gmail.com>
|
||||
---
|
||||
CMakeLists.txt | 7 +++++--
|
||||
1 file changed, 5 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||
index 474363f..20367d9 100644
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -1,10 +1,13 @@
|
||||
cmake_minimum_required(VERSION 2.8.3)
|
||||
project(urdf_tutorial)
|
||||
|
||||
-find_package(catkin REQUIRED roslaunch)
|
||||
+find_package(catkin REQUIRED)
|
||||
catkin_package()
|
||||
|
||||
-roslaunch_add_file_check(launch)
|
||||
+if (CATKIN_ENABLE_TESTING)
|
||||
+ find_package(roslaunch REQUIRED)
|
||||
+ roslaunch_add_file_check(launch)
|
||||
+endif()
|
||||
|
||||
install(DIRECTORY config images meshes launch rviz urdf
|
||||
DESTINATION ${CATKIN_PACKAGE_SHARE_DESTINATION})
|
||||
--
|
||||
1.9.1
|
||||
|
|
@ -1,13 +1,15 @@
|
|||
DESCRIPTION = "This package contains a number of URDF tutorials."
|
||||
SECTION = "devel"
|
||||
LICENSE = "BSD"
|
||||
LIC_FILES_CHKSUM = "file://package.xml;beginline=10;endline=10;md5=5ee5b8b046ae48ad94a2037ca953a67b"
|
||||
LIC_FILES_CHKSUM = "file://package.xml;beginline=10;endline=10;md5=d566ef916e9dedc494f5f793a6690ba5"
|
||||
|
||||
DEPENDS = "urdf"
|
||||
|
||||
SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
|
||||
SRC_URI[md5sum] = "00ca53e1f00b58f39d3ca89cca1819a7"
|
||||
SRC_URI[sha256sum] = "ac6c1d666eae7987ace46bab78dc9cc837a17462e59a80574d5441d0653cf333"
|
||||
SRC_URI[md5sum] = "2ea186e30b865fb6c6e535add7bd445e"
|
||||
SRC_URI[sha256sum] = "c90e7ca21bb51e851f1609c853103f39711da18f79c9915cd4d5fc3f100031c2"
|
||||
|
||||
SRC_URI += "file://0001-also-build-with-CATKIN_ENABLE_TESTING-OFF.patch"
|
||||
|
||||
S = "${WORKDIR}/${ROS_SP}"
|
||||
|
Loading…
Reference in New Issue