DRAFT python-mccabe_0.4.0.bb: Import from meta-python@08355759b158f4098170a6bc64a26deae065bce8
This commit is contained in:
parent
2b3edf8be3
commit
3dcb5f4ba6
|
@ -0,0 +1,33 @@
|
|||
From 3484bdfa7adbaebcf8bb8e7d4820f64b12717932 Mon Sep 17 00:00:00 2001
|
||||
From: Mingli Yu <mingli.yu@windriver.com>
|
||||
Date: Fri, 29 Jul 2016 15:37:18 +0800
|
||||
Subject: [PATCH] python-mccabe: remove unnecessary setup_requires
|
||||
pytest-runner
|
||||
|
||||
* Remove setup_requires pytest-runner as the
|
||||
setup_requires pytest-runner actually is not
|
||||
used for pytest which only in do_compile phase
|
||||
via setup.py build
|
||||
|
||||
Upstream-Status: Pending
|
||||
|
||||
Signed-off-by: Mingli Yu <mingli.yu@windriver.com>
|
||||
---
|
||||
setup.py | 1 -
|
||||
1 file changed, 1 deletion(-)
|
||||
|
||||
diff --git a/setup.py b/setup.py
|
||||
index e59903d..bf2aaba 100644
|
||||
--- a/setup.py
|
||||
+++ b/setup.py
|
||||
@@ -33,7 +33,6 @@ setup(
|
||||
license='Expat license',
|
||||
py_modules=['mccabe'],
|
||||
zip_safe=False,
|
||||
- setup_requires=['pytest-runner'],
|
||||
tests_require=['pytest'],
|
||||
entry_points={
|
||||
'flake8.extension': [
|
||||
--
|
||||
2.8.1
|
||||
|
|
@ -0,0 +1,20 @@
|
|||
SUMMARY = "McCabe checker, plugin for flake8"
|
||||
HOMEPAGE = "https://github.com/dreamhost/cliff"
|
||||
LICENSE = "Apache-2.0"
|
||||
LIC_FILES_CHKSUM = "file://README.rst;md5=f8b50fba1711ecac6bcdb6324f85a66d"
|
||||
|
||||
SRC_URI += " \
|
||||
file://0001-python-mccabe-remove-unnecessary-setup_requires-pyte.patch \
|
||||
"
|
||||
|
||||
SRC_URI[md5sum] = "8c425db05f310adcd4bb174b991f26f5"
|
||||
SRC_URI[sha256sum] = "9a2b12ebd876e77c72e41ebf401cc2e7c5b566649d50105ca49822688642207b"
|
||||
|
||||
inherit pypi setuptools
|
||||
|
||||
RDEPENDS_${PN} += " \
|
||||
python-prettytable \
|
||||
python-cmd2 \
|
||||
python-pyparsing"
|
||||
|
||||
BBCLASSEXTEND = "native nativesdk"
|
Loading…
Reference in New Issue