realsense_camera: bump to version 1.8.0

This version includes important fixes for those working with point
cloud.

The remaining patch was already merged upstream on intel-ros/realsense
and will probably make through v1.8.1. So it will be possible to drop
it soon.

Signed-off-by: Murilo Belluzzo <murilo.belluzzo@intel.com>
This commit is contained in:
Murilo Belluzzo 2017-04-10 14:31:48 -07:00 committed by Dmitry Rozhkov
parent 0775857f4a
commit 3e559b5b43
4 changed files with 3 additions and 169 deletions

View File

@ -1,96 +0,0 @@
From abaadefbb17d7ecebd5c4081122621f524a92b07 Mon Sep 17 00:00:00 2001
From: Dmitry Rozhkov <dmitry.rozhkov@linux.intel.com>
Date: Wed, 15 Feb 2017 10:44:55 +0200
Subject: [PATCH 1/2] Add option to link against non-catkin librealsense
In OpenEmbedded setups where both meta-ros and
meta-intel-realsense layers are used it's problematic
to avoid two copies of librealsense installed onto
an embedded target: one catkit-based installed under
/opt/ros and one other installed to a standard system
location.
This patch adds an option making realsense_camera link
against librealsense provided by the host system.
By default the currently existing behavior is preserved.
Upstream-Status: Submitted [https://github.com/intel-ros/realsense/pull/204]
Signed-off-by: Dmitry Rozhkov <dmitry.rozhkov@linux.intel.com>
---
CMakeLists.txt | 37 ++++++++++++++++++++++++++++++-------
1 file changed, 30 insertions(+), 7 deletions(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 796da59..ae10f84 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -14,8 +14,9 @@ set(CMAKE_EXE_LINKER_FLAGS "-pie -z noexecstack -z relro -z now")
# Flags shared libraries
set(CMAKE_SHARED_LINKER_FLAGS "-z noexecstack -z relro -z now ${CMAKE_SHARED_LINKER_FLAGS}")
-find_package(catkin REQUIRED COMPONENTS
- librealsense
+option(USE_SYSTEM_LIBREALSENSE "Build realsense_camera against system librealsense, not the one built with catkin" OFF)
+
+set(REALSENSE_CATKIN_BASED_DEPS
dynamic_reconfigure
roscpp
nodelet
@@ -30,6 +31,16 @@ find_package(catkin REQUIRED COMPONENTS
roslint
)
+if(USE_SYSTEM_LIBREALSENSE)
+ find_package(realsense REQUIRED)
+else()
+ list(APPEND REALSENSE_CATKIN_BASED_DEPS librealsense)
+endif()
+
+find_package(catkin REQUIRED COMPONENTS
+ ${REALSENSE_CATKIN_BASED_DEPS}
+)
+
add_message_files(
FILES
IMUInfo.msg
@@ -71,11 +82,20 @@ roslint_add_test()
# LIBRARIES: libraries you create in this project that dependent projects also need
# CATKIN_DEPENDS: catkin_packages dependent projects also need
# DEPENDS: system dependencies of this project that dependent projects also need
-catkin_package(
- INCLUDE_DIRS include
- CATKIN_DEPENDS librealsense std_msgs message_runtime sensor_msgs
- LIBRARIES ${PROJECT_NAME}_nodelet
-)
+if(USE_SYSTEM_LIBREALSENSE)
+ catkin_package(
+ INCLUDE_DIRS include
+ CATKIN_DEPENDS std_msgs message_runtime sensor_msgs
+ DEPENDS realsense
+ LIBRARIES ${PROJECT_NAME}_nodelet
+ )
+else()
+ catkin_package(
+ INCLUDE_DIRS include
+ CATKIN_DEPENDS std_msgs message_runtime sensor_msgs librealsense
+ LIBRARIES ${PROJECT_NAME}_nodelet
+ )
+endif()
# Specify additional locations of header files
include_directories(
@@ -93,6 +113,9 @@ add_dependencies(${PROJECT_NAME}_nodelet ${catkin_EXPORTED_TARGETS})
add_executable(get_debug_info src/get_debug_info.cpp)
target_link_libraries(get_debug_info ${catkin_LIBRARIES})
+if(USE_SYSTEM_LIBREALSENSE)
+ target_link_libraries(get_debug_info PRIVATE realsense::realsense)
+endif()
if (CATKIN_ENABLE_TESTING)
find_package(rostest REQUIRED)
--
2.7.4

View File

@ -1,68 +0,0 @@
From 787ebb1f9b598e4444ab820a9d6c36142935f793 Mon Sep 17 00:00:00 2001
From: Dmitry Rozhkov <dmitry.rozhkov@linux.intel.com>
Date: Fri, 17 Mar 2017 10:40:26 +0200
Subject: [PATCH 2/2] Enable roslint when CATKIN_ENABLE_TESTING is True
roslint depends on catkin_run_tests_target() which is defined only
when CATKIN_ENABLE_TESTING is True.
Thus run roslint functions in CMakeLists.txt only when testing
is enabled.
Upstream-Status: Submitted [https://github.com/intel-ros/realsense/pull/204]
Signed-off-by: Dmitry Rozhkov <dmitry.rozhkov@linux.intel.com>
---
CMakeLists.txt | 15 +++++++++------
1 file changed, 9 insertions(+), 6 deletions(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ae10f84..a1ec2f6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -28,7 +28,6 @@ set(REALSENSE_CATKIN_BASED_DEPS
std_msgs
sensor_msgs
pcl_ros
- roslint
)
if(USE_SYSTEM_LIBREALSENSE)
@@ -37,6 +36,10 @@ else()
list(APPEND REALSENSE_CATKIN_BASED_DEPS librealsense)
endif()
+if(CATKIN_ENABLE_TESTING)
+ list(APPEND REALSENSE_CATKIN_BASED_DEPS roslint)
+endif()
+
find_package(catkin REQUIRED COMPONENTS
${REALSENSE_CATKIN_BASED_DEPS}
)
@@ -68,11 +71,6 @@ generate_dynamic_reconfigure_options(
cfg/zr300_params.cfg
)
-# ROS Lint the code
-roslint_cpp()
-roslint_python()
-roslint_add_test()
-
#################################
# catkin specific configuration #
#################################
@@ -120,6 +118,11 @@ endif()
if (CATKIN_ENABLE_TESTING)
find_package(rostest REQUIRED)
+ # ROS Lint the code
+ roslint_cpp()
+ roslint_python()
+ roslint_add_test()
+
add_executable(tests_camera_core test/camera_core.cpp)
target_link_libraries(tests_camera_core
${catkin_LIBRARIES}
--
2.7.4

View File

@ -6,12 +6,10 @@ DEPENDS = "librealsense cv-bridge camera-info-manager pcl-ros roscpp"
RDEPENDS_${PN} = "rgbd-launch"
SRC_URI = "https://github.com/intel-ros/realsense/archive/${PV}.tar.gz \
file://0001-Add-option-to-link-against-non-catkin-librealsense.patch \
file://0002-Enable-roslint-when-CATKIN_ENABLE_TESTING-is-True.patch \
file://0003-librealsense-Fix-link-when-the-system-library-is-use.patch \
file://0001-librealsense-Fix-link-when-the-system-library-is-use.patch \
"
SRC_URI[md5sum] = "aaa0d0ddaaee210e2a2529767ba45a4b"
SRC_URI[sha256sum] = "65c6c4a0b6bd0214dffa8528033f03c0fbc4be00e52e058cfbd96b4f7d733b10"
SRC_URI[md5sum] = "d2b6b4ef563e82acca28597e542b5049"
SRC_URI[sha256sum] = "18e2d3e847b3b1158c124b6167ea2751236a2749aca03532ca7d9f5b7b59e975"
S = "${WORKDIR}/realsense-${PV}/realsense_camera"