librealsense: Set build type to ROS explicitly
The fix for build type detection in librealsense's CMakeLists.txt turned out to be non-functional in the official ROS build farm as explained in https://github.com/IntelRealSense/librealsense/pull/404 Since this recipe is specific to meta-ros set the build type explicitly to ROS to guaranty the catkin-related configs for librealsense get created and installed properly. Signed-off-by: Dmitry Rozhkov <dmitry.rozhkov@linux.intel.com>
This commit is contained in:
parent
75a14ef32d
commit
43690b8b0d
|
@ -1,35 +0,0 @@
|
||||||
From e036c870bca711ef419f6942df125b20d988353c Mon Sep 17 00:00:00 2001
|
|
||||||
From: Dmitry Rozhkov <dmitry.rozhkov@linux.intel.com>
|
|
||||||
Date: Fri, 9 Dec 2016 16:10:21 +0200
|
|
||||||
Subject: [PATCH] Fix detection of ROS build
|
|
||||||
|
|
||||||
CMAKE_PREFIX_PATH is not an environment variable, but CMake's
|
|
||||||
internal one that contains a list of items (strings). This
|
|
||||||
list needs to be concattenated into a single string in order
|
|
||||||
to become "match"-able against a regex.
|
|
||||||
|
|
||||||
Upstream-Status: Submitted [https://github.com/IntelRealSense/librealsense/pull/387]
|
|
||||||
|
|
||||||
Signed-off-by: Dmitry Rozhkov <dmitry.rozhkov@linux.intel.com>
|
|
||||||
---
|
|
||||||
CMakeLists.txt | 4 ++--
|
|
||||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|
||||||
index 8772f10..44295ee 100644
|
|
||||||
--- a/CMakeLists.txt
|
|
||||||
+++ b/CMakeLists.txt
|
|
||||||
@@ -3,8 +3,8 @@
|
|
||||||
# ubuntu 16.04 LTS cmake version 3.5.1
|
|
||||||
cmake_minimum_required(VERSION 2.8.3)
|
|
||||||
|
|
||||||
-IF(DEFINED ENV{CMAKE_PREFIX_PATH})
|
|
||||||
- IF($ENV{CMAKE_PREFIX_PATH} MATCHES "/opt/ros")
|
|
||||||
+IF(DEFINED CMAKE_PREFIX_PATH)
|
|
||||||
+ IF("${CMAKE_PREFIX_PATH}" MATCHES "/opt/ros")
|
|
||||||
set(ROS_BUILD_TYPE TRUE)
|
|
||||||
ENDIF()
|
|
||||||
ENDIF()
|
|
||||||
--
|
|
||||||
2.7.4
|
|
||||||
|
|
|
@ -2,11 +2,13 @@ DESCRIPTION = "Cross-platform camera capture for Intel® RealSense™ F200, SR30
|
||||||
LICENSE = "Apache-2.0"
|
LICENSE = "Apache-2.0"
|
||||||
LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
|
LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
|
||||||
|
|
||||||
SRC_URI = "https://github.com/IntelRealSense/librealsense/archive/v${PV}.tar.gz \
|
SRC_URI = "https://github.com/IntelRealSense/librealsense/archive/v${PV}.tar.gz"
|
||||||
file://0001-Fix-detection-of-ROS-build.patch \
|
|
||||||
"
|
|
||||||
SRC_URI[md5sum] = "27ce627c02731623c23894baeb73b2b1"
|
SRC_URI[md5sum] = "27ce627c02731623c23894baeb73b2b1"
|
||||||
|
|
||||||
|
EXTRA_OECMAKE_prepend = "\
|
||||||
|
-DROS_BUILD_TYPE=TRUE \
|
||||||
|
"
|
||||||
|
|
||||||
DEPENDS = "libusb1"
|
DEPENDS = "libusb1"
|
||||||
|
|
||||||
inherit catkin
|
inherit catkin
|
||||||
|
|
Loading…
Reference in New Issue