laser-assembler: adding patch to make rostest optional

This commit is contained in:
Lukas Bulwahn 2014-07-27 11:36:20 +02:00
parent 85c44368f2
commit 443b041147
2 changed files with 39 additions and 1 deletions

View File

@ -0,0 +1,36 @@
From a4404ea5ee0f4fb192c5765ee4dce6a265a70ec9 Mon Sep 17 00:00:00 2001
From: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
Date: Sun, 27 Jul 2014 09:58:36 +0200
Subject: [PATCH] make rostest in CMakeLists optional (ros/rosdistro#3010)
Upstream-Status: Submitted
---
CMakeLists.txt | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1ad9dbc..7309f3d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -10,8 +10,7 @@ tf sensor_msgs message_filters roscpp laser_geometry filters)
find_package(catkin REQUIRED COMPONENTS
${THIS_PACKAGE_ROS_DEPS}
- message_generation
- rostest)
+ message_generation)
find_package(Boost REQUIRED COMPONENTS system signals)
include_directories(include ${catkin_INCLUDE_DIRS} ${Boost_INCLUDE_DIRS})
@@ -68,6 +67,8 @@ add_dependencies(point_cloud2_assembler ${PROJECT_NAME}_gencpp)
## unit testing
if(CATKIN_ENABLE_TESTING)
+ find_package(rostest)
+
add_executable(periodic_snapshotter examples/periodic_snapshotter.cpp)
target_link_libraries(periodic_snapshotter ${catkin_LIBRARIES} ${Boost_LIBRARIES})
add_dependencies(periodic_snapshotter ${PROJECT_NAME}_gencpp)
--
1.9.1

View File

@ -3,12 +3,14 @@ SECTION = "devel"
LICENSE = "BSD" LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://package.xml;beginline=13;endline=13;md5=d566ef916e9dedc494f5f793a6690ba5" LIC_FILES_CHKSUM = "file://package.xml;beginline=13;endline=13;md5=d566ef916e9dedc494f5f793a6690ba5"
DEPENDS = "message-generation sensor-msgs message-filters tf roscpp rostest filters laser-geometry pluginlib" DEPENDS = "message-generation sensor-msgs message-filters tf roscpp filters laser-geometry pluginlib"
SRC_URI = "https://github.com/ros-perception/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz" SRC_URI = "https://github.com/ros-perception/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
SRC_URI[md5sum] = "1e0fe2d0b5fb26eca1e9137d64767419" SRC_URI[md5sum] = "1e0fe2d0b5fb26eca1e9137d64767419"
SRC_URI[sha256sum] = "de6637a229d84d6215dc0176ea05bc40c2eb2d8dec8ca520c4a29822f089e74a" SRC_URI[sha256sum] = "de6637a229d84d6215dc0176ea05bc40c2eb2d8dec8ca520c4a29822f089e74a"
SRC_URI += "file://0001-make-rostest-in-CMakeLists-optional-ros-rosdistro-30.patch"
S = "${WORKDIR}/${ROS_SP}" S = "${WORKDIR}/${ROS_SP}"
inherit catkin inherit catkin