sphinxbase: initial commit

This commit is contained in:
Kristof Robot 2014-04-19 22:41:39 +02:00
parent aab16dd255
commit 4f88ffb3ad
3 changed files with 46 additions and 0 deletions

View File

@ -0,0 +1,9 @@
SRC_URI = "http://sourceforge.net/projects/cmusphinx/files/${PN}/${PV}/${P}.tar.gz;downloadfilename=${P}.tar.gz"
inherit autotools pythonnative python-dir
# required for python binding
export HOST_SYS
export BUILD_SYS
export STAGING_LIBDIR
export STAGING_INCDIR

View File

@ -0,0 +1,16 @@
diff --git a/test/regression/Makefile.am b/test/regression/Makefile.am
index d13d2a7..3bdb18a 100644
--- a/test/regression/Makefile.am
+++ b/test/regression/Makefile.am
@@ -33,9 +33,9 @@ CLEANFILES = test*.err test*.out \
# Disable sphinx_fe tests for now if fixed-point due to imprecision
if FIXED_POINT
-TESTS = $(srcdir)/test-cepview.sh $(srcdir)/test-sphinx_pitch.sh
+TESTS = test-cepview.sh test-sphinx_pitch.sh
else
-TESTS = $(srcdir)/test-*.sh
+TESTS = test-*.sh
endif
EXTRA_DIST += $(TESTS)

View File

@ -0,0 +1,21 @@
DESCRIPTION = "This package contains the basic libraries shared by the CMU Sphinx \
trainer and all the Sphinx decoders (Sphinx-II, Sphinx-III, and \
PocketSphinx), as well as some common utilities for manipulating \
acoustic feature and audio files."
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://COPYING;md5=c550e8ca1106e5eeaf4e2b4cbf960fcf"
SRC_URI[md5sum] = "7335d233f7ad4ecc4b508aec7b5dc101"
SRC_URI[sha256sum] = "55708944872bab1015b8ae07b379bf463764f469163a8fd114cbb16c5e486ca8"
require cmusphinx.inc
SRC_URI += "file://0001-TESTS-srcdir-remove.patch"
do_install_append () {
#remove egg-info
rm -rf ${D}/${PYTHON_SITEPACKAGES_DIR}/*.egg-info
}
FILES_${PN} += "${PYTHON_SITEPACKAGES_DIR}/sphinxbase.so"
FILES_${PN}-dbg += "${PYTHON_SITEPACKAGES_DIR}/.debug/*"