adding log4cxx recipes based on existing openembedded (classic) recipes
This commit is contained in:
parent
40676a4f06
commit
5375503109
|
@ -0,0 +1,50 @@
|
|||
From af4e8f0eccdc2f562f9e591b101ee856a962e01d Mon Sep 17 00:00:00 2001
|
||||
From: Tasslehoff Kjappfot <tasskjapp@gmail.com>
|
||||
Date: Thu, 14 Oct 2010 08:57:08 +0200
|
||||
Subject: [PATCH 1/2] log4cxx_0-10-0_add missing includes
|
||||
|
||||
---
|
||||
src/examples/cpp/console.cpp | 1 +
|
||||
src/main/cpp/inputstreamreader.cpp | 1 +
|
||||
src/main/cpp/socketoutputstream.cpp | 1 +
|
||||
3 files changed, 3 insertions(+), 0 deletions(-)
|
||||
|
||||
diff --git a/src/examples/cpp/console.cpp b/src/examples/cpp/console.cpp
|
||||
index 6a01d8a..a673a10 100644
|
||||
--- a/src/examples/cpp/console.cpp
|
||||
+++ b/src/examples/cpp/console.cpp
|
||||
@@ -22,6 +22,7 @@
|
||||
#include <log4cxx/logmanager.h>
|
||||
#include <iostream>
|
||||
#include <locale.h>
|
||||
+#include <cstring>
|
||||
|
||||
using namespace log4cxx;
|
||||
using namespace log4cxx::helpers;
|
||||
diff --git a/src/main/cpp/inputstreamreader.cpp b/src/main/cpp/inputstreamreader.cpp
|
||||
index 52b1c0a..cb45181 100644
|
||||
--- a/src/main/cpp/inputstreamreader.cpp
|
||||
+++ b/src/main/cpp/inputstreamreader.cpp
|
||||
@@ -20,6 +20,7 @@
|
||||
#include <log4cxx/helpers/exception.h>
|
||||
#include <log4cxx/helpers/pool.h>
|
||||
#include <log4cxx/helpers/bytebuffer.h>
|
||||
+#include <cstring>
|
||||
|
||||
using namespace log4cxx;
|
||||
using namespace log4cxx::helpers;
|
||||
diff --git a/src/main/cpp/socketoutputstream.cpp b/src/main/cpp/socketoutputstream.cpp
|
||||
index 185f835..c61eb11 100644
|
||||
--- a/src/main/cpp/socketoutputstream.cpp
|
||||
+++ b/src/main/cpp/socketoutputstream.cpp
|
||||
@@ -19,6 +19,7 @@
|
||||
#include <log4cxx/helpers/socketoutputstream.h>
|
||||
#include <log4cxx/helpers/socket.h>
|
||||
#include <log4cxx/helpers/bytebuffer.h>
|
||||
+#include <cstring>
|
||||
|
||||
using namespace log4cxx;
|
||||
using namespace log4cxx::helpers;
|
||||
--
|
||||
1.7.0.4
|
||||
|
|
@ -0,0 +1,39 @@
|
|||
From a32da098ded31e6399658a01dd5c994e23f8c5a8 Mon Sep 17 00:00:00 2001
|
||||
From: Tasslehoff Kjappfot <tasskjapp@gmail.com>
|
||||
Date: Thu, 14 Oct 2010 09:02:11 +0200
|
||||
Subject: [PATCH 2/2] Remove duplicates
|
||||
|
||||
---
|
||||
src/main/include/log4cxx/Makefile.am | 2 +-
|
||||
src/main/include/log4cxx/private/Makefile.am | 2 +-
|
||||
2 files changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/src/main/include/log4cxx/Makefile.am b/src/main/include/log4cxx/Makefile.am
|
||||
index 719c2dd..53e99b0 100644
|
||||
--- a/src/main/include/log4cxx/Makefile.am
|
||||
+++ b/src/main/include/log4cxx/Makefile.am
|
||||
@@ -15,7 +15,7 @@
|
||||
#
|
||||
SUBDIRS = helpers net nt rolling spi varia xml config db private pattern filter
|
||||
log4cxxincdir = $(includedir)/log4cxx
|
||||
-log4cxxinc_HEADERS= $(top_srcdir)/src/main/include/log4cxx/*.h log4cxx.h
|
||||
+log4cxxinc_HEADERS= $(top_srcdir)/src/main/include/log4cxx/*.h
|
||||
DISTCLEANFILES = log4cxx.h
|
||||
EXTRA_DIST = log4cxx.hw
|
||||
|
||||
diff --git a/src/main/include/log4cxx/private/Makefile.am b/src/main/include/log4cxx/private/Makefile.am
|
||||
index 3a896ea..474e31d 100644
|
||||
--- a/src/main/include/log4cxx/private/Makefile.am
|
||||
+++ b/src/main/include/log4cxx/private/Makefile.am
|
||||
@@ -14,7 +14,7 @@
|
||||
# limitations under the License.
|
||||
#
|
||||
privateincdir = $(includedir)/log4cxx/private
|
||||
-privateinc_HEADERS= $(top_builddir)/src/main/include/log4cxx/private/*.h log4cxx_private.h
|
||||
+privateinc_HEADERS= $(top_builddir)/src/main/include/log4cxx/private/*.h
|
||||
DISTCLEANFILES = log4cxx_private.h
|
||||
EXTRA_DIST = log4cxx_private.hw
|
||||
|
||||
--
|
||||
1.7.0.4
|
||||
|
|
@ -0,0 +1,33 @@
|
|||
--- apache-log4cxx-0.10.0.orig//src/examples/cpp/console.cpp 2008-04-01 00:34:52.000000000 +0200
|
||||
+++ apache-log4cxx-0.10.0//src/examples/cpp/console.cpp 2010-05-04 23:52:38.270096842 +0200
|
||||
@@ -23,6 +23,8 @@
|
||||
#include <iostream>
|
||||
#include <locale.h>
|
||||
|
||||
+#include <cstring>
|
||||
+
|
||||
using namespace log4cxx;
|
||||
using namespace log4cxx::helpers;
|
||||
|
||||
--- apache-log4cxx-0.10.0.orig//src/main/cpp/inputstreamreader.cpp 2008-04-01 00:34:09.000000000 +0200
|
||||
+++ apache-log4cxx-0.10.0//src/main/cpp/inputstreamreader.cpp 2010-05-04 23:45:21.583105063 +0200
|
||||
@@ -21,6 +21,8 @@
|
||||
#include <log4cxx/helpers/pool.h>
|
||||
#include <log4cxx/helpers/bytebuffer.h>
|
||||
|
||||
+#include <cstring>
|
||||
+
|
||||
using namespace log4cxx;
|
||||
using namespace log4cxx::helpers;
|
||||
|
||||
--- apache-log4cxx-0.10.0.orig//src/main/cpp/socketoutputstream.cpp 2008-04-01 00:34:09.000000000 +0200
|
||||
+++ apache-log4cxx-0.10.0//src/main/cpp/socketoutputstream.cpp 2010-05-04 23:49:22.838093204 +0200
|
||||
@@ -20,6 +20,8 @@
|
||||
#include <log4cxx/helpers/socket.h>
|
||||
#include <log4cxx/helpers/bytebuffer.h>
|
||||
|
||||
+#include <cstring>
|
||||
+
|
||||
using namespace log4cxx;
|
||||
using namespace log4cxx::helpers;
|
||||
|
|
@ -0,0 +1,48 @@
|
|||
--- log4cxx-0.9.7/src/socketoutputstream.cpp~ 2009-05-21 10:06:47.000000000 +0100
|
||||
+++ log4cxx-0.9.7/src/socketoutputstream.cpp 2009-05-21 10:06:47.000000000 +0100
|
||||
@@ -13,7 +13,8 @@
|
||||
* See the License for the specific language governing permissions and
|
||||
* limitations under the License.
|
||||
*/
|
||||
-
|
||||
+
|
||||
+#include <string.h>
|
||||
#include <log4cxx/helpers/socketoutputstream.h>
|
||||
#include <log4cxx/helpers/socket.h>
|
||||
#include <log4cxx/helpers/loglog.h>
|
||||
|
||||
--- log4cxx-0.9.7/src/stringtokenizer.cpp~ 2009-05-21 10:11:19.000000000 +0100
|
||||
+++ log4cxx-0.9.7/src/stringtokenizer.cpp 2009-05-21 10:11:20.000000000 +0100
|
||||
@@ -13,7 +13,8 @@
|
||||
* See the License for the specific language governing permissions and
|
||||
* limitations under the License.
|
||||
*/
|
||||
-
|
||||
+
|
||||
+#include <string.h>
|
||||
#include <log4cxx/helpers/stringtokenizer.h>
|
||||
|
||||
using namespace log4cxx;
|
||||
|
||||
--- log4cxx-0.9.7/src/timezone.cpp~ 2009-05-21 10:14:27.000000000 +0100
|
||||
+++ log4cxx-0.9.7/src/timezone.cpp 2009-05-21 10:14:27.000000000 +0100
|
||||
@@ -13,7 +13,8 @@
|
||||
* See the License for the specific language governing permissions and
|
||||
* limitations under the License.
|
||||
*/
|
||||
-
|
||||
+
|
||||
+#include <string.h>
|
||||
#include <log4cxx/helpers/timezone.h>
|
||||
#include <locale>
|
||||
|
||||
--- log4cxx-0.9.7/src/xmlsocketappender.cpp~ 2009-05-21 10:16:24.000000000 +0100
|
||||
+++ log4cxx-0.9.7/src/xmlsocketappender.cpp 2009-05-21 10:16:25.000000000 +0100
|
||||
@@ -14,6 +14,7 @@
|
||||
* limitations under the License.
|
||||
*/
|
||||
|
||||
+#include <string.h>
|
||||
#include <log4cxx/net/xmlsocketappender.h>
|
||||
#include <log4cxx/helpers/loglog.h>
|
||||
#include <log4cxx/helpers/socketoutputstream.h>
|
|
@ -0,0 +1,18 @@
|
|||
DESCRIPTION = "Apache logging framework for C++ library"
|
||||
SECTION = "libs"
|
||||
DEPENDS = "apr apr-util expat gdbm"
|
||||
LICENSE = "Apache License Version 2.0"
|
||||
LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
|
||||
HOMEPAGE = "http://logging.apache.org/log4cxx/"
|
||||
PR = "r0"
|
||||
|
||||
SRC_URI = "http://archive.apache.org/dist/logging/log4cxx/0.10.0/apache-log4cxx-0.10.0.tar.gz \
|
||||
file://0001-log4cxx_0-10-0_add-missing-includes.patch \
|
||||
file://0002-Remove-duplicates-from-makefile.patch"
|
||||
|
||||
S = "${WORKDIR}/apache-${PN}-${PV}"
|
||||
|
||||
inherit autotools pkgconfig
|
||||
|
||||
SRC_URI[md5sum] = "b30ffb8da3665178e68940ff7a61084c"
|
||||
SRC_URI[sha256sum] = "0de0396220a9566a580166e66b39674cb40efd2176f52ad2c65486c99c920c8c"
|
|
@ -0,0 +1,18 @@
|
|||
DESCRIPTION = "Apache logging framework for C++ library"
|
||||
SECTION = "libs"
|
||||
DEPENDS = "apr apr-util expat gdbm"
|
||||
LICENSE = "Apache License, Version 2.0"
|
||||
HOMEPAGE = "http://logging.apache.org/log4cxx/"
|
||||
# PV = "0.10.0"
|
||||
PR = "r1"
|
||||
|
||||
SRC_URI = "http://archive.apache.org/dist/logging/log4cxx/log4cxx-0.9.7.tar.gz \
|
||||
file://log4cxx097.patch"
|
||||
|
||||
#build this:
|
||||
S = "${WORKDIR}/${PN}-${PV}"
|
||||
|
||||
inherit autotools pkgconfig
|
||||
|
||||
SRC_URI[md5sum] = "fd09abc90b8c0c8af1d5146a75590792"
|
||||
SRC_URI[sha256sum] = "5b41b2fc267595bdb0fa4cd1152309413bc70e6d9196293113ebb82751eb7ec6"
|
|
@ -0,0 +1,19 @@
|
|||
DESCRIPTION = "Apache logging framework for C++ library"
|
||||
SECTION = "libs"
|
||||
DEPENDS = "apr apr-util expat gdbm"
|
||||
LICENSE = "Apache License Version 2.0"
|
||||
LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
|
||||
HOMEPAGE = "http://logging.apache.org/log4cxx/"
|
||||
|
||||
SRCREV = "${AUTOREV}"
|
||||
PV = "0.0+svnr${SRCPV}"
|
||||
PR = "r0"
|
||||
|
||||
SRC_URI = "svn://svn.apache.org/repos/asf/logging/log4cxx/;protocol=http;module=trunk"
|
||||
|
||||
S = "${WORKDIR}/trunk"
|
||||
|
||||
inherit autotools pkgconfig
|
||||
|
||||
SRC_URI[md5sum] = "b30ffb8da3665178e68940ff7a61084c"
|
||||
SRC_URI[sha256sum] = "0de0396220a9566a580166e66b39674cb40efd2176f52ad2c65486c99c920c8c"
|
Loading…
Reference in New Issue