Merge pull request #621 from aizelauna/master
tf, tf2, message-filters, roscpp: remove signals from find_package() calls to support boost 1.69
This commit is contained in:
commit
54261d5a83
|
@ -0,0 +1,24 @@
|
||||||
|
From 65a6507591ba13333c4d79d119b3316a29e49f6a Mon Sep 17 00:00:00 2001
|
||||||
|
From: =?UTF-8?q?Jo=C3=ABl=20Esponde?= <joel.esponde@easymile.com>
|
||||||
|
Date: Wed, 27 Feb 2019 15:18:57 +0100
|
||||||
|
Subject: [PATCH] cmake: remove boost signals search as it is removed since
|
||||||
|
1.69
|
||||||
|
|
||||||
|
Upstream-Status: Inappropriate [upstream source code changed]
|
||||||
|
---
|
||||||
|
tf/CMakeLists.txt | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/tf/CMakeLists.txt b/tf/CMakeLists.txt
|
||||||
|
index 8429516..9fcdebd 100644
|
||||||
|
--- a/tf/CMakeLists.txt
|
||||||
|
+++ b/tf/CMakeLists.txt
|
||||||
|
@@ -13,7 +13,7 @@ find_package(catkin REQUIRED COMPONENTS
|
||||||
|
std_msgs
|
||||||
|
tf2_ros
|
||||||
|
)
|
||||||
|
-find_package(Boost REQUIRED COMPONENTS thread signals system)
|
||||||
|
+find_package(Boost REQUIRED COMPONENTS thread system)
|
||||||
|
|
||||||
|
catkin_python_setup()
|
||||||
|
|
|
@ -9,6 +9,8 @@ require geometry.inc
|
||||||
|
|
||||||
RDEPENDS_${PN} = "${PYTHON_PN}-numpy"
|
RDEPENDS_${PN} = "${PYTHON_PN}-numpy"
|
||||||
|
|
||||||
|
SRC_URI += "file://0001-cmake-remove-boost-signals-search-as-it-is-removed-s.patch;striplevel=2"
|
||||||
|
|
||||||
# This option disables python support in case of python3 flavour of ROS because
|
# This option disables python support in case of python3 flavour of ROS because
|
||||||
# only python2 is supported by tf.
|
# only python2 is supported by tf.
|
||||||
EXTRA_OECMAKE =+ "${@'-DANDROID=ON' if d.getVar('PYTHON_PN', True) == 'python3' else ''}"
|
EXTRA_OECMAKE =+ "${@'-DANDROID=ON' if d.getVar('PYTHON_PN', True) == 'python3' else ''}"
|
||||||
|
|
|
@ -0,0 +1,24 @@
|
||||||
|
From 075784dd6599521ee03b7103e0b13d1a4d229e0f Mon Sep 17 00:00:00 2001
|
||||||
|
From: =?UTF-8?q?Jo=C3=ABl=20Esponde?= <joel.esponde@easymile.com>
|
||||||
|
Date: Wed, 27 Feb 2019 14:24:38 +0100
|
||||||
|
Subject: [PATCH] cmake: remove boost signals search as it is removed since
|
||||||
|
1.69
|
||||||
|
|
||||||
|
Upstream-Status: Inappropriate [upstream source code changed]
|
||||||
|
---
|
||||||
|
CMakeLists.txt | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/tf2/CMakeLists.txt b/tf2/CMakeLists.txt
|
||||||
|
index 0d5754f..c9e2597 100644
|
||||||
|
--- a/tf2/CMakeLists.txt
|
||||||
|
+++ b/tf2/CMakeLists.txt
|
||||||
|
@@ -3,7 +3,7 @@ project(tf2)
|
||||||
|
|
||||||
|
find_package(console_bridge REQUIRED)
|
||||||
|
find_package(catkin REQUIRED COMPONENTS geometry_msgs rostime tf2_msgs)
|
||||||
|
-find_package(Boost REQUIRED COMPONENTS signals system thread)
|
||||||
|
+find_package(Boost REQUIRED COMPONENTS system thread)
|
||||||
|
|
||||||
|
catkin_package(
|
||||||
|
INCLUDE_DIRS include
|
|
@ -9,3 +9,5 @@ DEPENDS = "tf2-msgs geometry-msgs console-bridge rospy"
|
||||||
RDEPENDS_${PN} += "tf2-msgs geometry-msgs console-bridge rostime"
|
RDEPENDS_${PN} += "tf2-msgs geometry-msgs console-bridge rostime"
|
||||||
|
|
||||||
require geometry2.inc
|
require geometry2.inc
|
||||||
|
|
||||||
|
SRC_URI += "file://0001-cmake-remove-boost-signals-search-as-it-is-removed-s.patch;striplevel=2"
|
||||||
|
|
|
@ -0,0 +1,24 @@
|
||||||
|
From 8fa4972c5059597f79265bc64af7e2f6f65d6d04 Mon Sep 17 00:00:00 2001
|
||||||
|
From: =?UTF-8?q?Jo=C3=ABl=20Esponde?= <joel.esponde@easymile.com>
|
||||||
|
Date: Wed, 27 Feb 2019 14:46:29 +0100
|
||||||
|
Subject: [PATCH] cmake: remove boost signals search as it is removed since
|
||||||
|
1.69
|
||||||
|
|
||||||
|
Upstream-Status: Inappropriate [upstream source code changed]
|
||||||
|
---
|
||||||
|
CMakeLists.txt | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/utilities/message_filters/CMakeLists.txt b/utilities/message_filters/CMakeLists.txt
|
||||||
|
index 03e906a1..2503cfae 100644
|
||||||
|
--- a/utilities/message_filters/CMakeLists.txt
|
||||||
|
+++ b/utilities/message_filters/CMakeLists.txt
|
||||||
|
@@ -13,7 +13,7 @@ catkin_package(
|
||||||
|
)
|
||||||
|
catkin_python_setup()
|
||||||
|
|
||||||
|
-find_package(Boost REQUIRED COMPONENTS signals thread)
|
||||||
|
+find_package(Boost REQUIRED COMPONENTS thread)
|
||||||
|
|
||||||
|
include_directories(include ${catkin_INCLUDE_DIRS} ${Boost_INCLUDE_DIRS})
|
||||||
|
link_directories(${catkin_LIBRARY_DIRS})
|
|
@ -9,4 +9,6 @@ require ros-comm.inc
|
||||||
|
|
||||||
ROS_PKG_SUBDIR = "utilities"
|
ROS_PKG_SUBDIR = "utilities"
|
||||||
|
|
||||||
SRC_URI += "file://0001-Changed-invocation-to-add-to-conform-template-syntax.patch;patchdir=../.."
|
SRC_URI += "\
|
||||||
|
file://0001-Changed-invocation-to-add-to-conform-template-syntax.patch;striplevel=3\
|
||||||
|
file://0002-cmake-remove-boost-signals-search-as-it-is-removed-s.patch;striplevel=3"
|
||||||
|
|
|
@ -0,0 +1,23 @@
|
||||||
|
From 80858e3ba7ea3d89cb745e79c50794edf7c568f8 Mon Sep 17 00:00:00 2001
|
||||||
|
From: =?UTF-8?q?Jo=C3=ABl=20Esponde?= <joel.esponde@easymile.com>
|
||||||
|
Date: Wed, 27 Feb 2019 13:15:13 +0100
|
||||||
|
Subject: [PATCH] cmake: remove boost signals search as it is removed since
|
||||||
|
1.69
|
||||||
|
|
||||||
|
Upstream-Status: Inappropriate [upstream source code changed]
|
||||||
|
---
|
||||||
|
CMakeLists.txt | 2 ++--
|
||||||
|
1 file changed, 1 insertions(+), 1 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/clients/roscpp/CMakeLists.txt b/clients/roscpp/CMakeLists.txt
|
||||||
|
index 91bd3113..c3a38487 100644
|
||||||
|
--- a/clients/roscpp/CMakeLists.txt
|
||||||
|
+++ b/clients/roscpp/CMakeLists.txt
|
||||||
|
@@ -22,7 +22,7 @@ list(GET roscpp_VERSION_LIST 2 roscpp_VERSION_PATCH)
|
||||||
|
|
||||||
|
configure_file(${CMAKE_CURRENT_SOURCE_DIR}/include/ros/common.h.in ${CATKIN_DEVEL_PREFIX}/${CATKIN_GLOBAL_INCLUDE_DESTINATION}/ros/common.h)
|
||||||
|
|
||||||
|
-find_package(Boost REQUIRED COMPONENTS signals filesystem system)
|
||||||
|
+find_package(Boost REQUIRED COMPONENTS filesystem system)
|
||||||
|
|
||||||
|
include_directories(include ${CATKIN_DEVEL_PREFIX}/${CATKIN_GLOBAL_INCLUDE_DESTINATION}/ros ${catkin_INCLUDE_DIRS} ${Boost_INCLUDE_DIRS})
|
|
@ -12,7 +12,8 @@ require ros-comm.inc
|
||||||
|
|
||||||
SRC_URI += "\
|
SRC_URI += "\
|
||||||
file://0001-roscpp-add-missing-header-for-writev.patch;striplevel=3\
|
file://0001-roscpp-add-missing-header-for-writev.patch;striplevel=3\
|
||||||
file://0001-make-implicit-cast-explicit.patch;striplevel=3"
|
file://0002-make-implicit-cast-explicit.patch;striplevel=3\
|
||||||
|
file://0003-cmake-remove-boost-signals-search-as-it-is-removed-s.patch;striplevel=3"
|
||||||
|
|
||||||
ROS_PKG_SUBDIR = "clients"
|
ROS_PKG_SUBDIR = "clients"
|
||||||
|
|
||||||
|
|
Loading…
Reference in New Issue