geometric-shapes: updating to 0.3.6
The version 0.3.6 contains the local patch for CATKIN_ENABLE_TESTING, and hence the local patch can be removed.
This commit is contained in:
parent
c9da551841
commit
60a8de14e2
|
@ -1,43 +0,0 @@
|
|||
From 597828ebc85f552fd38537664cbe72c1c775049b Mon Sep 17 00:00:00 2001
|
||||
From: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
|
||||
Date: Sun, 13 Oct 2013 05:41:53 +0200
|
||||
Subject: [PATCH] check for CATKIN_ENABLE_TESTING
|
||||
|
||||
---
|
||||
CMakeLists.txt | 6 ++++--
|
||||
package.xml | 2 +-
|
||||
2 files changed, 5 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||
index 4b41961..821f929 100644
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -64,8 +64,10 @@ add_library(${PROJECT_NAME}
|
||||
target_link_libraries(${PROJECT_NAME} ${ASSIMP_LIBRARIES} ${QHULL_LIBRARIES} ${catkin_LIBRARIES} ${Boost_LIBRARIES})
|
||||
|
||||
|
||||
-# Unit tests
|
||||
-add_subdirectory(test)
|
||||
+if(CATKIN_ENABLE_TESTING)
|
||||
+ # Unit tests
|
||||
+ add_subdirectory(test)
|
||||
+endif()
|
||||
|
||||
install(TARGETS ${PROJECT_NAME}
|
||||
ARCHIVE DESTINATION lib
|
||||
diff --git a/package.xml b/package.xml
|
||||
index 4001019..4dbd6d1 100644
|
||||
--- a/package.xml
|
||||
+++ b/package.xml
|
||||
@@ -8,7 +8,7 @@
|
||||
<license>BSD</license>
|
||||
<url>http://ros.org/wiki/geometric_shapes</url>
|
||||
|
||||
- <buildtool_depend>catkin</buildtool_depend>
|
||||
+ <buildtool_depend version_gte="0.5.68">catkin</buildtool_depend>
|
||||
|
||||
<build_depend>boost</build_depend>
|
||||
<build_depend>shape_msgs</build_depend>
|
||||
--
|
||||
1.8.1.2
|
||||
|
|
@ -6,10 +6,8 @@ LIC_FILES_CHKSUM = "file://package.xml;beginline=8;endline=8;md5=5ee5b8b046ae48a
|
|||
DEPENDS = "boost shape-msgs shape-tools octomap assimp libeigen qhull console-bridge random-numbers eigen-stl-containers resource-retriever"
|
||||
|
||||
SRC_URI = "https://github.com/ros-planning/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
|
||||
SRC_URI[md5sum] = "7b7b803890baf1a5f27264a2906e3d9c"
|
||||
SRC_URI[sha256sum] = "a26443007e39c7c6355c83d703df04969e8b60b7e44d851f44df026e168243c7"
|
||||
|
||||
SRC_URI += "file://0001-check-for-CATKIN_ENABLE_TESTING.patch;striplevel=1"
|
||||
SRC_URI[md5sum] = "53d43fd2d624c18d47789d1fcca26047"
|
||||
SRC_URI[sha256sum] = "90dd882471147c981bf6395997d2b5318b970565cf5045c15bd0a5a4f465638c"
|
||||
|
||||
S = "${WORKDIR}/${ROS_SP}"
|
||||
|
Loading…
Reference in New Issue