Merge pull request #129 from bulwahn/libpoco
libpoco: new recipe based on digitalstrom's recipe (resolves #118)
This commit is contained in:
commit
666989718a
4
README
4
README
|
@ -13,6 +13,7 @@ CONTRIBUTORS
|
|||
Kartik Mohta <kartikmohta@gmail.com>
|
||||
Koen Kooi <koen@dominion.thruhere.net>
|
||||
Victor Mayoral Vilches <v.mayoralv@gmail.com>
|
||||
Sergey 'Jin' Bostandzhyan <jin@dev.digitalstrom.org>
|
||||
|
||||
HOW TO CONTRIBUTE
|
||||
|
||||
|
@ -101,6 +102,9 @@ REDISTRIBUTIONS
|
|||
The yaml-cpp recipe originated from the recipe in Kartik Mohta's OpenEmbedded layer
|
||||
(cf. https://github.com/kartikmohta/meta-km/blob/master/recipes-devtools/yaml-cpp/yaml-cpp_0.3.0.bb)
|
||||
licensed with the MIT License.
|
||||
The libpoco recipe originated from the recipe in digitalSTROM's OpenEmbedded layer
|
||||
(cf. https://gitorious.digitalstrom.org/dss-oe/dss-oe/blobs/master/dS/meta-dss11-production/recipes-support/poco/poco_1.3.6p2.bb)
|
||||
licensed with the MIT License.
|
||||
The core-image-ros-* recipes originated from the core-image-minimal recipe in OpenEmbedded Core
|
||||
(cf. http://cgit.openembedded.org/openembedded-core/tree/meta/recipes-core/images/core-image-minimal.bb)
|
||||
licensed with the MIT License.
|
||||
|
|
|
@ -0,0 +1,78 @@
|
|||
#
|
||||
# $Id: //poco/1.3/build/config/Angstrom#1 $
|
||||
#
|
||||
# Angstrom
|
||||
#
|
||||
# Make settings for Open Embedded/Angstrom
|
||||
#
|
||||
# ^^^ I wonder what the guy who wrote the above lines was thinking...
|
||||
# Yeah, right, Angstrom is only for ARM, and why would we want to override
|
||||
# the compiler name? What, uclibc, what is that? And please also explain us
|
||||
# what environment variables are!
|
||||
|
||||
|
||||
#
|
||||
# General Settings
|
||||
#
|
||||
LINKMODE = SHARED
|
||||
POCO_TARGET_OSNAME = Linux
|
||||
POCO_TARGET_OSARCH ?= armv5te
|
||||
TOOL ?= arm-angstrom-linux-gnueabi
|
||||
|
||||
#
|
||||
# Define Tools
|
||||
#
|
||||
CC ?= $(TOOL)-gcc
|
||||
CXX ?= $(TOOL)-g++
|
||||
LINK ?= $(CXX)
|
||||
STRIP ?= $(TOOL)-strip
|
||||
LIB ?= $(TOOL)-ar -cr
|
||||
RANLIB ?= $(TOOL)-ranlib
|
||||
SHLIB ?= $(CXX) -shared -Wl,-soname,$(notdir $@) -o $@
|
||||
SHLIBLN ?= $(POCO_BASE)/build/script/shlibln
|
||||
DEP ?= $(POCO_BASE)/build/script/makedepend.gcc
|
||||
SHELL ?= sh
|
||||
RM ?= rm -rf
|
||||
CP ?= cp
|
||||
MKDIR ?= mkdir -p
|
||||
|
||||
#
|
||||
# Extension for Shared Libraries
|
||||
#
|
||||
SHAREDLIBEXT = .so.$(target_version)
|
||||
SHAREDLIBLINKEXT = .so
|
||||
|
||||
#
|
||||
# Compiler and Linker Flags
|
||||
#
|
||||
CFLAGS = -Isrc
|
||||
CFLAGS32 =
|
||||
CFLAGS64 =
|
||||
CXXFLAGS =
|
||||
CXXFLAGS32 =
|
||||
CXXFLAGS64 =
|
||||
LINKFLAGS =
|
||||
LINKFLAGS32 =
|
||||
LINKFLAGS64 =
|
||||
STATICOPT_CC =
|
||||
STATICOPT_CXX =
|
||||
STATICOPT_LINK = -static
|
||||
SHAREDOPT_CC = -fPIC
|
||||
SHAREDOPT_CXX = -fPIC
|
||||
SHAREDOPT_LINK = -Wl,-rpath,$(LIBPATH)
|
||||
DEBUGOPT_CC = -g -D_DEBUG
|
||||
DEBUGOPT_CXX = -g -D_DEBUG
|
||||
DEBUGOPT_LINK = -g
|
||||
RELEASEOPT_CC = -O3 -DNDEBUG
|
||||
RELEASEOPT_CXX = -O2 -DNDEBUG
|
||||
RELEASEOPT_LINK = -O2
|
||||
|
||||
#
|
||||
# System Specific Flags
|
||||
#
|
||||
SYSFLAGS = -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -D_REENTRANT -D_THREAD_SAFE -DPOCO_NO_FPENVIRONMENT
|
||||
|
||||
#
|
||||
# System Specific Libraries
|
||||
#
|
||||
SYSLIBS = -lpthread -ldl -lrt
|
|
@ -0,0 +1,11 @@
|
|||
diff -Naur a/Foundation/Makefile b/Foundation/Makefile
|
||||
--- a/Foundation/Makefile 2013-07-26 13:16:29.590566734 +0200
|
||||
+++ b/Foundation/Makefile 2013-07-26 13:19:34.138559575 +0200
|
||||
@@ -44,6 +44,7 @@
|
||||
|
||||
ifdef POCO_UNBUNDLED
|
||||
SYSLIBS += -lpcre -lz
|
||||
+ objects += $(pcre_utf8_objects)
|
||||
else
|
||||
objects += $(zlib_objects) $(pcre_objects) $(pcre_utf8_objects)
|
||||
endif
|
|
@ -1,14 +0,0 @@
|
|||
DESCRIPTION = "C++ class libraries and frameworks for building network- and internet-based applications"
|
||||
HOMEPAGE = "http://pocoproject.org/"
|
||||
SECTION = "libs"
|
||||
|
||||
LICENSE = "BSL-1.0"
|
||||
LIC_FILES_CHKSUM = "file://LICENSE;md5=e4224ccaecb14d942c71d31bef20d78c"
|
||||
|
||||
SRC_URI = "http://pocoproject.org/releases/poco-${PV}/poco-${PV}p1.tar.gz"
|
||||
SRC_URI[md5sum] = "8d9cf241dfa7c99842a7ef73c207994b"
|
||||
SRC_URI[sha256sum] = "f9eddd5e7f963693e9da008a2992f211630560856edfc0f954532b0f42fc66e7"
|
||||
|
||||
S = "${WORKDIR}/poco-${PV}p1"
|
||||
|
||||
inherit autotools
|
|
@ -0,0 +1,27 @@
|
|||
DESCRIPTION = "POCO C++ Libraries"
|
||||
HOMEPAGE = "http://pocoproject.org"
|
||||
LICENSE = "BSL-1.0"
|
||||
LIC_FILES_CHKSUM = "file://LICENSE;md5=e4224ccaecb14d942c71d31bef20d78c"
|
||||
|
||||
DEPENDS = "expat zlib libpcre"
|
||||
|
||||
SRC_URI = "${SOURCEFORGE_MIRROR}/poco/poco-${PV}-all.tar.bz2 \
|
||||
file://OE \
|
||||
file://add_pcre_utf8_objects.patch"
|
||||
SRC_URI[md5sum] = "2598b53d481e2bd3fb92bd23172abe53"
|
||||
SRC_URI[sha256sum] = "95af0382257614c70841629c928184cddc228831a8bfc4c57399931bed8a16f8"
|
||||
|
||||
S = "${WORKDIR}/poco-${PV}-all"
|
||||
|
||||
inherit autotools binconfig pkgconfig
|
||||
|
||||
TARGET_CC_ARCH += "${LDFLAGS}"
|
||||
|
||||
EXTRA_OECONF += "--config=OE --no-samples --no-wstring --no-tests --unbundled \
|
||||
--omit=Data/MySQL,Data/SQLite,Data/ODBC,PageCompiler \
|
||||
"
|
||||
|
||||
do_configure_prepend() {
|
||||
install ${WORKDIR}/OE ${S}/build/config/OE
|
||||
export POCO_TARGET_OSARCH=${TARGET_ARCH}
|
||||
}
|
|
@ -10,7 +10,7 @@ RDEPENDS_${PN} = "cmake make binutils binutils-symlinks gcc gcc-symlinks g++ g++
|
|||
python-catkin-pkg python-argparse python-misc python-multiprocessing \
|
||||
python-shell python-subprocess python-xml"
|
||||
|
||||
SRC_URI = "https://github.com/ros/catkin/archive/${PV}.tar.gz;downloadfilename={ROS_BP}.tar.gz \
|
||||
SRC_URI = "https://github.com/ros/catkin/archive/${PV}.tar.gz;downloadfilename=${ROS_BP}.tar.gz \
|
||||
file://0001-CATKIN_WORKSPACES-Don-t-require-.catkin-file.patch \
|
||||
"
|
||||
SRC_URI[md5sum] = "1c30ac4fcc82ce2aedf610ea972ab4d2"
|
||||
|
|
|
@ -6,9 +6,13 @@ SECTION = "devel"
|
|||
LICENSE = "BSD"
|
||||
LIC_FILES_CHKSUM = "file://package.xml;beginline=9;endline=9;md5=5ee5b8b046ae48ad94a2037ca953a67b"
|
||||
|
||||
SRC_URI = "https://github.com/ros/${ROS_BPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_BP}.tar.gz"
|
||||
SRC_URI[md5sum] = "9061fd30e5a04e8376eaddffaae86b07"
|
||||
SRC_URI[sha256sum] = "4203b0a8389d9ac3203110b507d23fa353262cf26253f40abece6418d6c2bdd4"
|
||||
SRC_URI = "https://github.com/ros/${ROS_BPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_BP}.tar.gz;name=archive"
|
||||
SRC_URI[archive.md5sum] = "9061fd30e5a04e8376eaddffaae86b07"
|
||||
SRC_URI[archive.sha256sum] = "4203b0a8389d9ac3203110b507d23fa353262cf26253f40abece6418d6c2bdd4"
|
||||
|
||||
SRC_URI += "https://github.com/ros/dynamic_reconfigure/commit/b7b222534f7259ca457ea354d92c5708f895202e.patch;name=patch"
|
||||
SRC_URI[patch.md5sum] = "0607963ca3f940362c9e78b5f8019cb9"
|
||||
SRC_URI[patch.sha256sum] = "e132ed52fe35c287658700857f7d9439793ff2be7f9fa9a19731024152ccaf29"
|
||||
|
||||
DEPENDS = "roscpp std-msgs roslib"
|
||||
RDEPENDS_${PN} = "roslib"
|
||||
|
|
|
@ -1 +1 @@
|
|||
Subproject commit 8d9d29077b88130828ac834ba2ca247dfa7e46a1
|
||||
Subproject commit fb3414e6e565577b3a50c2634acac602843c0215
|
Loading…
Reference in New Issue