mavros: refresh patches

* fixes:
WARNING: mavros-0.18.7-r0 do_patch:
Some of the context lines in patches were ignored. This can lead to incorrectly applied patches.
The context lines in the patches can be updated with devtool:

    devtool modify <recipe>
    devtool finish --force-patch-refresh <recipe> <layer_path>

Then the updated patches and the source tree (in devtool's workspace)
should be reviewed to make sure the patches apply in the correct place
and don't introduce duplicate lines (which can, and does happen
when some of the context is ignored). Further information:
http://lists.openembedded.org/pipermail/openembedded-core/2018-March/148675.html
https://bugzilla.yoctoproject.org/show_bug.cgi?id=10450
Details:
Applying patch 0001-CMake-explicitly-link-the-atomic-library-797.patch
patching file CMakeLists.txt
Hunk #1 succeeded at 90 with fuzz 1 (offset -12 lines).

Now at patch 0001-CMake-explicitly-link-the-atomic-library-797.patch

Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
This commit is contained in:
Martin Jansa 2018-04-10 09:32:48 +00:00
parent a7eeafe2c2
commit 694c11782a
2 changed files with 8 additions and 12 deletions

View File

@ -1,4 +1,4 @@
From 658347978fc97675dbdff480f4557eb772e915dc Mon Sep 17 00:00:00 2001 From 06d862fcf3bdcd50fe726e5364200cc5e7b87fcd Mon Sep 17 00:00:00 2001
From: Lukas Bulwahn <lukas.bulwahn@gmail.com> From: Lukas Bulwahn <lukas.bulwahn@gmail.com>
Date: Mon, 4 Sep 2017 16:17:12 +0100 Date: Mon, 4 Sep 2017 16:17:12 +0100
Subject: [PATCH] CMake: explicitly link the atomic library (#797) Subject: [PATCH] CMake: explicitly link the atomic library (#797)
@ -35,22 +35,20 @@ This patch has been generated with:
in the mavros repository. in the mavros repository.
Signed-off-by: Lukas Bulwahn <lukas.bulwahn@gmail.com> Signed-off-by: Lukas Bulwahn <lukas.bulwahn@gmail.com>
--- ---
mavros/CMakeLists.txt | 1 + mavros/CMakeLists.txt | 1 +
1 file changed, 1 insertion(+) 1 file changed, 1 insertion(+)
diff --git a/mavros/CMakeLists.txt b/mavros/CMakeLists.txt diff --git a/mavros/CMakeLists.txt b/mavros/CMakeLists.txt
index a4ac3cb..5233e96 100644 index 47a24a9..a0bec5d 100644
--- a/mavros/CMakeLists.txt --- a/mavros/CMakeLists.txt
+++ b/mavros/CMakeLists.txt +++ b/mavros/CMakeLists.txt
@@ -102,6 +102,7 @@ add_library(mavros @@ -90,6 +90,7 @@ add_library(mavros
src/lib/rosconsole_bridge.cpp src/lib/rosconsole_bridge.cpp
) )
target_link_libraries(mavros target_link_libraries(mavros
+ atomic + atomic
${catkin_LIBRARIES} ${catkin_LIBRARIES}
${Boost_LIBRARIES} ${Boost_LIBRARIES}
${GeographicLib_LIBRARIES} )
--
1.9.1

View File

@ -1,15 +1,16 @@
From d7b00940cb69d659d77bb08b1cbbf5aad4ea4617 Mon Sep 17 00:00:00 2001 From 800775cf398c51db878524755fde3c29490f2f5d Mon Sep 17 00:00:00 2001
From: Lukas Bulwahn <lukas.bulwahn@gmail.com> From: Lukas Bulwahn <lukas.bulwahn@gmail.com>
Date: Sun, 7 May 2017 06:14:18 +0200 Date: Sun, 7 May 2017 06:14:18 +0200
Subject: [PATCH] always find Eigen with cmake_modules mechanism Subject: [PATCH] always find Eigen with cmake_modules mechanism
Upstream-Status: Pending Upstream-Status: Pending
--- ---
mavros/CMakeLists.txt | 12 ++++-------- mavros/CMakeLists.txt | 12 ++++--------
1 file changed, 4 insertions(+), 8 deletions(-) 1 file changed, 4 insertions(+), 8 deletions(-)
diff --git a/mavros/CMakeLists.txt b/mavros/CMakeLists.txt diff --git a/mavros/CMakeLists.txt b/mavros/CMakeLists.txt
index 3b3a0bd..bcc7924 100644 index 9c33dff..47a24a9 100644
--- a/mavros/CMakeLists.txt --- a/mavros/CMakeLists.txt
+++ b/mavros/CMakeLists.txt +++ b/mavros/CMakeLists.txt
@@ -26,14 +26,10 @@ find_package(catkin REQUIRED COMPONENTS @@ -26,14 +26,10 @@ find_package(catkin REQUIRED COMPONENTS
@ -31,6 +32,3 @@ index 3b3a0bd..bcc7924 100644
include(EnableCXX11) include(EnableCXX11)
include(MavrosMavlink) include(MavrosMavlink)
--
1.9.1