moveit: updating to 0.7.9
Due to the update, this commit also drops the patch that has been accepted upstream. Signed-off-by: Lukas Bulwahn <lukas.bulwahn@gmail.com>
This commit is contained in:
parent
6ccdb17381
commit
71c24b3473
|
@ -1,49 +0,0 @@
|
|||
From 6734257c8d611e7561372be93e31ea5c4887c7e2 Mon Sep 17 00:00:00 2001
|
||||
From: Dmitry Rozhkov <dmitry.rozhkov@linux.intel.com>
|
||||
Date: Wed, 25 Jan 2017 11:02:22 +0200
|
||||
Subject: [PATCH 1/2] address gcc6 build error
|
||||
|
||||
With gcc6, compiling fails with `stdlib.h: No such file or directory`,
|
||||
as including '-isystem /usr/include' breaks with gcc6, cf.,
|
||||
https://gcc.gnu.org/bugzilla/show_bug.cgi?id=70129.
|
||||
|
||||
This commit addresses this issue for this package in almost the same way
|
||||
it was addressed in various other ROS packages. A list of related
|
||||
commits and pull requests is at:
|
||||
|
||||
https://github.com/ros/rosdistro/issues/12783
|
||||
|
||||
Particularly when searching for the Boost library CMake sets
|
||||
Boost_INCLUDE_DIRS to @SYSROOT@/usr/include which should be
|
||||
avoided in the `-isystem` option of gcc.
|
||||
|
||||
Upstream-Status: Accepted
|
||||
|
||||
Signed-off-by: Dmitry Rozhkov <dmitry.rozhkov@linux.intel.com>
|
||||
---
|
||||
CMakeLists.txt | 7 ++++---
|
||||
1 file changed, 4 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||
index 2f41991..4829da0 100644
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -62,11 +62,12 @@ catkin_package(
|
||||
|
||||
include_directories(${THIS_PACKAGE_INCLUDE_DIRS}
|
||||
${catkin_INCLUDE_DIRS}
|
||||
- )
|
||||
+ ${Boost_INCLUDE_DIRS}
|
||||
+)
|
||||
include_directories(SYSTEM
|
||||
${EIGEN_INCLUDE_DIRS}
|
||||
- ${Boost_INCLUDE_DIRS}
|
||||
- )
|
||||
+)
|
||||
+
|
||||
|
||||
link_directories(${Boost_LIBRARY_DIRS})
|
||||
link_directories(${catkin_LIBRARY_DIRS})
|
||||
--
|
||||
2.7.4
|
||||
|
|
@ -9,6 +9,4 @@ require moveit.inc
|
|||
|
||||
ROS_BPN = "moveit_ros/planning"
|
||||
|
||||
SRC_URI += "file://0001-address-gcc6-build-error.patch"
|
||||
|
||||
FILES_${PN} += "${ros_libdir}/moveit_ros_planning/*"
|
|
@ -1,6 +1,6 @@
|
|||
SRC_URI = "https://github.com/ros-planning/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
|
||||
SRC_URI[md5sum] = "fadd453134bb64559b989d2b3f02ca28"
|
||||
SRC_URI[sha256sum] = "d14103ddf4545f42acaabfcdda36eeff9a293e07269d339eeb7ac4ab6dd3c522"
|
||||
SRC_URI[md5sum] = "6ebfe9fc33837fcea079bcd7f3741eb5"
|
||||
SRC_URI[sha256sum] = "9ec381e6589a663b03f8468d095599b90b14e102be221f9b19dc8b833dbc05bb"
|
||||
|
||||
S = "${WORKDIR}/${ROS_SP}/${ROS_BPN}"
|
||||
|
||||
|
|
Loading…
Reference in New Issue