Merge pull request #228 from KristofRobot/robot-pose-ekf
new recipe for navigation/robot_pose_ekf
This commit is contained in:
commit
7737a04a81
|
@ -0,0 +1,16 @@
|
||||||
|
DESCRIPTION = "This package contains a recent version of the Bayesian Filtering Library (BFL), distributed by the Orocos Project."
|
||||||
|
SECTION = "devel"
|
||||||
|
LICENSE = "LGPL-2.1"
|
||||||
|
LIC_FILES_CHKSUM = "file://COPYING;md5=7fbc338309ac38fefcd64b04bb903e34"
|
||||||
|
|
||||||
|
DEPENDS = "cppunit boost"
|
||||||
|
|
||||||
|
SRC_URI = "https://github.com/ros-gbp/${PN}-release/archive/release/hydro/${PN}/${PV}.tar.gz"
|
||||||
|
SRC_URI[md5sum] = "0ef8a8dd76d7ecc78cd8f9aab80ba5a5"
|
||||||
|
SRC_URI[sha256sum] = "ecc97e979e47eefeade93c6e3905420b3e780ea434247cd2171a5f4d731352f9"
|
||||||
|
|
||||||
|
S = "${WORKDIR}/bfl-release-release-hydro-${P}"
|
||||||
|
|
||||||
|
inherit cmake
|
||||||
|
|
||||||
|
FILES_${PN}-dbg += "${bindir}/bfl/.debug"
|
|
@ -0,0 +1,16 @@
|
||||||
|
--- a/robot_pose_ekf/CMakeLists.txt 2014-02-26 22:23:47.631541505 +0100
|
||||||
|
+++ b/robot_pose_ekf/CMakeLists.txt 2014-02-26 22:23:58.219541227 +0100
|
||||||
|
@@ -77,6 +77,7 @@
|
||||||
|
## Tests are failing on OSX for an unknown reason
|
||||||
|
include(CMakeDetermineSystem)
|
||||||
|
if(CMAKE_SYSTEM_NAME MATCHES "Linux")
|
||||||
|
+if(CATKIN_ENABLE_TESTING)
|
||||||
|
|
||||||
|
catkin_download_test_data(download_data_ekf_test2_indexed.bag http://download.ros.org/data/robot_pose_ekf/ekf_test2_indexed.bag FILENAME test/ekf_test2.bag MD5 71addef0ed900e05b301e0b4fdca99e2)
|
||||||
|
add_executable(test_robot_pose_ekf test/test_robot_pose_ekf.cpp)
|
||||||
|
@@ -98,4 +99,5 @@
|
||||||
|
)
|
||||||
|
add_rostest(${CMAKE_CURRENT_SOURCE_DIR}/test/test_robot_pose_ekf_zero_covariance.launch)
|
||||||
|
|
||||||
|
+endif(CATKIN_ENABLE_TESTING)
|
||||||
|
endif(CMAKE_SYSTEM_NAME MATCHES "Linux")
|
|
@ -0,0 +1,10 @@
|
||||||
|
DESCRIPTION = "The Robot Pose EKF package is used to estimate the 3D pose of a robot, based on (partial) pose measurements coming from different sources. It uses an extended Kalman filter with a 6D model (3D position and 3D orientation) to combine measurements from wheel odometry, IMU sensor and visual odometry. The basic idea is to offer loosely coupled integration with different sensors, where sensor signals are received as ROS messages."
|
||||||
|
SECTION = "devel"
|
||||||
|
LICENSE = "BSD"
|
||||||
|
LIC_FILES_CHKSUM = "file://package.xml;beginline=12;endline=12;md5=01c2bc31767ccb3a68e12f02612b2a97"
|
||||||
|
|
||||||
|
DEPENDS = "roscpp bfl std-msgs geometry-msgs sensor-msgs nav-msgs tf"
|
||||||
|
|
||||||
|
require navigation.inc
|
||||||
|
|
||||||
|
SRC_URI += "file://0001-check-for-CATKIN_ENABLE_TESTING.patch;striplevel=2"
|
Loading…
Reference in New Issue