navigation: updating to 1.12.14

This commit also drops patches included in version 1.12.14 and
adjusts to new enforced dependencies in the move_base package.

Signed-off-by: Lukas Bulwahn <lukas.bulwahn@gmail.com>
This commit is contained in:
Lukas Bulwahn 2017-12-28 11:15:54 +01:00
parent 090f7fbc00
commit 7830e48b87
20 changed files with 6 additions and 112 deletions

View File

@ -1,35 +0,0 @@
From e6f3979ff8b988fe7992bf08a8267f1e11f58627 Mon Sep 17 00:00:00 2001
From: Lukas Bulwahn <lukas.bulwahn@gmail.com>
Date: Tue, 4 Apr 2017 14:39:25 +0200
Subject: [PATCH] make rostest in CMakeLists optional (ros/rosdistro#3010)
Upstream-Status: Submitted [https://github.com/ros-planning/navigation/pull/565]
Signed-off-by: Lukas Bulwahn <lukas.bulwahn@gmail.com>
---
base_local_planner/CMakeLists.txt | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/base_local_planner/CMakeLists.txt b/base_local_planner/CMakeLists.txt
index 2444ae1..507af18 100644
--- a/base_local_planner/CMakeLists.txt
+++ b/base_local_planner/CMakeLists.txt
@@ -10,7 +10,6 @@ find_package(catkin REQUIRED
dynamic_reconfigure
nav_core
pcl_conversions
- rostest
costmap_2d
pluginlib
angles
@@ -129,6 +128,7 @@ install(DIRECTORY include/${PROJECT_NAME}/
)
if(CATKIN_ENABLE_TESTING)
+ find_package(rostest)
catkin_add_gtest(base_local_planner_utest
test/gtest_main.cpp
test/utest.cpp
--
2.5.5

View File

@ -9,5 +9,3 @@ DEPENDS = "angles costmap-2d dynamic-reconfigure geometry-msgs libeigen message-
voxel-grid visualization-msgs"
require navigation.inc
SRC_URI += "file://0001-make-rostest-in-CMakeLists-optional-ros-rosdistro-30.patch;striplevel=2"

View File

@ -1,69 +0,0 @@
From def48f89c985736901bb7bbe427f65acd18ef8d6 Mon Sep 17 00:00:00 2001
From: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
Date: Tue, 27 Sep 2016 15:25:19 +0200
Subject: [PATCH] address gcc6 build error
With gcc6, compiling fails with `stdlib.h: No such file or directory`,
as including '-isystem /usr/include' breaks with gcc6, cf.,
https://gcc.gnu.org/bugzilla/show_bug.cgi?id=70129.
This commit addresses this issue for this package in the same way
it was addressed in various other ROS packages. A list of related
commits and pull requests is at:
https://github.com/ros/rosdistro/issues/12783
The SYSTEM attribute for the eigen and pcl include directories
was added in commit 9e876d2b [1] on 2012-09-16 during the
package's transition to ROS Groovy. The reason for using
the SYSTEM attribute cannot be inferred from that commit.
This attribute remained in the CMakeLists.txt during further
refinements in commits be4aebdb and 3a156140 on 2014-02-24, and
was not further touched until now.
[1] https://github.com/ros-planning/navigation/commit/9e876d2b45aca2e2166ac5a508b0e7c7abc50717
[2] https://github.com/ros-planning/navigation/commit/be4aebdb658381104b8e70f832091926e67ea0b4
[3] https://github.com/ros-planning/navigation/commit/3a156140439ea2300aaad45f7f2a65dab503ff24
Signed-off-by: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
Upstream-Status: Pending [https://github.com/ros-planning/navigation/pull/522]
Signed-off-by: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
---
move_slow_and_clear/CMakeLists.txt | 5 ++---
navfn/CMakeLists.txt | 1 -
2 files changed, 2 insertions(+), 4 deletions(-)
diff --git a/move_slow_and_clear/CMakeLists.txt b/move_slow_and_clear/CMakeLists.txt
index 078052d..686596e 100644
--- a/move_slow_and_clear/CMakeLists.txt
+++ b/move_slow_and_clear/CMakeLists.txt
@@ -19,9 +19,8 @@ find_package(Boost REQUIRED COMPONENTS thread)
include_directories(
include
${catkin_INCLUDE_DIRS}
- SYSTEM
- ${EIGEN_INCLUDE_DIRS}
- ${PCL_INCLUDE_DIRS}
+ ${EIGEN_INCLUDE_DIRS}
+ ${PCL_INCLUDE_DIRS}
)
add_definitions(${EIGEN_DEFINITIONS})
diff --git a/navfn/CMakeLists.txt b/navfn/CMakeLists.txt
index ad01c3a..3e3995f 100644
--- a/navfn/CMakeLists.txt
+++ b/navfn/CMakeLists.txt
@@ -21,7 +21,6 @@ find_package(PCL REQUIRED)
include_directories(
include
${catkin_INCLUDE_DIRS}
- SYSTEM
${EIGEN_INCLUDE_DIRS}
${PCL_INCLUDE_DIRS}
)
--
2.5.5

View File

@ -4,7 +4,8 @@ SECTION = "devel"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://package.xml;beginline=13;endline=13;md5=01c2bc31767ccb3a68e12f02612b2a97"
DEPENDS = "actionlib costmap-2d dynamic-reconfigure geometry-msgs message-generation move-base-msgs \
nav-core nav-msgs pluginlib roscpp rospy std-msgs std-srvs tf visualization-msgs"
DEPENDS = "actionlib base-local-planner clear-costmap-recovery costmap-2d dynamic-reconfigure \
geometry-msgs message-generation move-base-msgs nav-core navfn nav-msgs pluginlib roscpp \
rospy rotate-recovery std-msgs std-srvs tf visualization-msgs"
require navigation.inc

View File

@ -1,9 +1,8 @@
SRC_URI = "https://github.com/ros-planning/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
SRC_URI[md5sum] = "d7a392da183b3c2a5fce063e90cbf1f2"
SRC_URI[sha256sum] = "169f89a4a3a94437ffbf80a9b06b65471c17529169d1940a217e92d85481f18f"
SRC_URI[md5sum] = "25918a8c5e9b64a74ed7776fcd9419cd"
SRC_URI[sha256sum] = "0f98fae839023002769f4cbd770db87ad3ab9dd02faae7feda492fd38bda1407"
SRC_URI += "file://0001-address-gcc6-build-error.patch;patchdir=.. \
file://0001-amcl-fix-compilation-with-gcc-v7.patch;patchdir=.."
SRC_URI += "file://0001-amcl-fix-compilation-with-gcc-v7.patch;patchdir=.."
S = "${WORKDIR}/${ROS_SP}/${ROS_BPN}"