image-pipeline: updating to 1.11.4

The version 1.11.4 contains the local patches for
CATKIN_ENABLE_TESTING, and hence the local patches can be removed.
This commit is contained in:
Lukas Bulwahn 2013-11-23 17:01:43 +01:00
parent 0fb748c3b0
commit 808e449c44
9 changed files with 3 additions and 110 deletions

View File

@ -1,61 +0,0 @@
From 7d0a39237d5b6570aa4c931670420b44975a2447 Mon Sep 17 00:00:00 2001
From: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
Date: Sat, 12 Oct 2013 13:43:17 +0200
Subject: [PATCH] check for CATKIN_ENABLE_TESTING
---
camera_calibration/CMakeLists.txt | 21 +++++++++++----------
camera_calibration/package.xml | 2 +-
2 files changed, 12 insertions(+), 11 deletions(-)
diff --git a/camera_calibration/CMakeLists.txt b/camera_calibration/CMakeLists.txt
index 129294f..69f1eeb 100644
--- a/camera_calibration/CMakeLists.txt
+++ b/camera_calibration/CMakeLists.txt
@@ -6,19 +6,20 @@ catkin_package()
catkin_python_setup()
-# Unit test of calibrator.py
-catkin_add_nosetests(test/directed.py)
+if(CATKIN_ENABLE_TESTING)
+ # Unit test of calibrator.py
+ catkin_add_nosetests(test/directed.py)
-# Unit test of the approximate synchronizer
-catkin_add_nosetests(test/testapproxsync.py)
+ # Unit test of the approximate synchronizer
+ catkin_add_nosetests(test/testapproxsync.py)
-# Tests simple calibration dataset
-catkin_download_test_data(camera_calibration.tar.gz http://download.ros.org/data/camera_calibration/camera_calibration.tar.gz MD5 6da43ea314640a4c15dd7a90cbc3aee0)
-
-# Tests multiple checkerboards
-catkin_download_test_data(multi_board_calibration.tar.gz http://download.ros.org/data/camera_calibration/multi_board_calibration.tar.gz MD5 ddc0f69582d140e33f9d3bfb681956bb)
-catkin_add_nosetests(test/multiple_boards.py)
+ # Tests simple calibration dataset
+ catkin_download_test_data(camera_calibration.tar.gz http://download.ros.org/data/camera_calibration/camera_calibration.tar.gz MD5 6da43ea314640a4c15dd7a90cbc3aee0)
+ # Tests multiple checkerboards
+ catkin_download_test_data(multi_board_calibration.tar.gz http://download.ros.org/data/camera_calibration/multi_board_calibration.tar.gz MD5 ddc0f69582d140e33f9d3bfb681956bb)
+ catkin_add_nosetests(test/multiple_boards.py)
+endif()
install(PROGRAMS nodes/camera_calibrate_from_disk.py
nodes/cameracalibrator.py
diff --git a/camera_calibration/package.xml b/camera_calibration/package.xml
index 620f958..662e938 100644
--- a/camera_calibration/package.xml
+++ b/camera_calibration/package.xml
@@ -9,7 +9,7 @@
<author>Patrick Mihelich</author>
<maintainer email="vincent.rabaud@gmail.com">Vincent Rabaud</maintainer>
- <buildtool_depend>catkin</buildtool_depend>
+ <buildtool_depend version_gte="0.5.68">catkin</buildtool_depend>
<test_depend>rostest</test_depend>
--
1.8.1.2

View File

@ -2,8 +2,6 @@ DESCRIPTION = "camera_calibration allows easy calibration of monocular or stereo
cameras using a checkerboard calibration target."
SECTION = "devel"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://package.xml;beginline=22;endline=22;md5=d566ef916e9dedc494f5f793a6690ba5"
LIC_FILES_CHKSUM = "file://package.xml;beginline=24;endline=24;md5=d566ef916e9dedc494f5f793a6690ba5"
require image-pipeline.inc
SRC_URI += "file://0001-check-for-CATKIN_ENABLE_TESTING.patch;striplevel=2"

View File

@ -1,6 +1,6 @@
SRC_URI = "https://github.com/ros-perception/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
SRC_URI[md5sum] = "655ceb0d966d7105679d8c96304b2537"
SRC_URI[sha256sum] = "76bda6a0179de44a65f51a14d1967b81d45fe4e71c167cde25bd273bc63d22e0"
SRC_URI[md5sum] = "1c13b6e63b31dc336b4f48825a3fb271"
SRC_URI[sha256sum] = "d7f68f40e937f47e49121442825c30d9af4fdab68d53cff23863f885956f90ae"
S = "${WORKDIR}/${ROS_SP}/${ROS_BPN}"

View File

@ -1,42 +0,0 @@
From caee053fb6a82bf1552a7ca226f80014d830a089 Mon Sep 17 00:00:00 2001
From: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
Date: Sat, 12 Oct 2013 13:55:06 +0200
Subject: [PATCH] check for CATKIN_ENABLE_TESTING
---
image_proc/CMakeLists.txt | 8 +++++---
image_proc/package.xml | 2 +-
2 files changed, 6 insertions(+), 4 deletions(-)
diff --git a/image_proc/CMakeLists.txt b/image_proc/CMakeLists.txt
index 25f9499..3653279 100644
--- a/image_proc/CMakeLists.txt
+++ b/image_proc/CMakeLists.txt
@@ -54,6 +54,8 @@ install(DIRECTORY launch
DESTINATION ${CATKIN_PACKAGE_SHARE_DESTINATION}/
)
-# Tests
-catkin_add_gtest(image_proc_rostest test/rostest.cpp)
-target_link_libraries(image_proc_rostest ${catkin_LIBRARIES} ${Boost_LIBRARIES})
+if(CATKIN_ENABLE_TESTING)
+ # Tests
+ catkin_add_gtest(image_proc_rostest test/rostest.cpp)
+ target_link_libraries(image_proc_rostest ${catkin_LIBRARIES} ${Boost_LIBRARIES})
+endif()
diff --git a/image_proc/package.xml b/image_proc/package.xml
index ebe5882..fd7dd92 100644
--- a/image_proc/package.xml
+++ b/image_proc/package.xml
@@ -13,7 +13,7 @@
<nodelet plugin="${prefix}/nodelet_plugins.xml" />
</export>
- <buildtool_depend>catkin</buildtool_depend>
+ <buildtool_depend version_gte="0.5.68">catkin</buildtool_depend>
<test_depend>rostest</test_depend>
--
1.8.1.2

View File

@ -6,5 +6,3 @@ LIC_FILES_CHKSUM = "file://package.xml;beginline=9;endline=9;md5=d566ef916e9dedc
DEPENDS = "boost camera-calibration-parsers cv-bridge dynamic-reconfigure image-geometry image-transport nodelet opencv roscpp sensor-msgs"
require image-pipeline.inc
SRC_URI += "file://0001-check-for-CATKIN_ENABLE_TESTING.patch;striplevel=2"