DRAFT [thud] Drop assimp_3.3.1.bb: Use later v4.1.0 from openembedded/meta that matches Ubuntu bionic
This commit is contained in:
parent
207e132e31
commit
9f87b05f9a
|
@ -1,33 +0,0 @@
|
||||||
From c2c12c1db5c8d7610ad46b1970aabf4afde0eef4 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Daniel Knezevic <danielknezevic90@gmail.com>
|
|
||||||
Date: Thu, 18 Aug 2016 10:51:20 +0200
|
|
||||||
Subject: [PATCH] Use Assimp namespace to fix build for big-endian
|
|
||||||
architectures
|
|
||||||
|
|
||||||
Upstream-Status: Backport [https://github.com/assimp/assimp/commit/c2c12c1db5c8d7610ad46b1970aabf4afde0eef4]
|
|
||||||
|
|
||||||
This patch has been generated with:
|
|
||||||
`git format-patch -1 c2c12c1db5c8d7610ad46b1970aabf4afde0eef4`
|
|
||||||
in the assimp repository.
|
|
||||||
|
|
||||||
Signed-off-by: Lukas Bulwahn <lukas.bulwahn@gmail.com>
|
|
||||||
---
|
|
||||||
code/glTFAsset.inl | 2 ++
|
|
||||||
1 file changed, 2 insertions(+)
|
|
||||||
|
|
||||||
diff --git a/code/glTFAsset.inl b/code/glTFAsset.inl
|
|
||||||
index d52c825..470246c 100644
|
|
||||||
--- a/code/glTFAsset.inl
|
|
||||||
+++ b/code/glTFAsset.inl
|
|
||||||
@@ -40,6 +40,8 @@ OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
|
||||||
|
|
||||||
#include "StringUtils.h"
|
|
||||||
|
|
||||||
+using namespace Assimp;
|
|
||||||
+
|
|
||||||
namespace glTF {
|
|
||||||
|
|
||||||
namespace {
|
|
||||||
--
|
|
||||||
1.9.1
|
|
||||||
|
|
|
@ -1,18 +0,0 @@
|
||||||
DESCRIPTION = "Open Asset Import Library"
|
|
||||||
SECTION = "devel"
|
|
||||||
LICENSE = "BSD"
|
|
||||||
LIC_FILES_CHKSUM = "file://LICENSE;md5=4cd8c0aedc7a0623476669377d7eeda8"
|
|
||||||
|
|
||||||
DEPENDS = "boost"
|
|
||||||
|
|
||||||
SRC_URI = "https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz;downloadfilename=${PN}-${PV}.tar.gz"
|
|
||||||
SRC_URI[md5sum] = "fc57b024e80ebb13301bd0983826cad3"
|
|
||||||
SRC_URI[sha256sum] = "d385c3f90876241343f09e45f4e5033a6a05861b971c63d1f6d512371ffdc7bf"
|
|
||||||
|
|
||||||
SRC_URI += "file://0001-Use-Assimp-namespace-to-fix-build-for-big-endian-arc.patch"
|
|
||||||
|
|
||||||
S = "${WORKDIR}/${PN}-${PV}"
|
|
||||||
|
|
||||||
inherit cmake
|
|
||||||
|
|
||||||
FILES_${PN}-dev += "${libdir}/cmake/assimp-3.3/*.cmake"
|
|
Loading…
Reference in New Issue