audio-common: updating to 0.2.9
This commit is contained in:
parent
63c57f961f
commit
a7490bf9c8
|
@ -1,6 +1,6 @@
|
|||
SRC_URI = "https://github.com/ros-drivers/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
|
||||
SRC_URI[md5sum] = "e66d263bef1cd36b89f739b8937fd009"
|
||||
SRC_URI[sha256sum] = "459ce6d834026969b3bec3fc9d59c446d8bd433661138464b90b9f2df38e6f1c"
|
||||
SRC_URI[md5sum] = "1bf6135fae371901db1afea03186fa9a"
|
||||
SRC_URI[sha256sum] = "7b0ee18352a251aea212a701881f59841741272cd9bb62970a32c726dd69d54f"
|
||||
|
||||
S = "${WORKDIR}/${ROS_SP}/${ROS_BPN}"
|
||||
|
||||
|
|
|
@ -0,0 +1,35 @@
|
|||
From ecdde483c81fb89e35f025ee3aacba7cd45528ab Mon Sep 17 00:00:00 2001
|
||||
From: Alexis Ballier <aballier@gentoo.org>
|
||||
Date: Fri, 4 Dec 2015 12:38:42 +0100
|
||||
Subject: [PATCH 2/2] sound_play: Fix build with -DCATKIN_ENABLE_TESTING=OFF.
|
||||
|
||||
https://bugs.gentoo.org/show_bug.cgi?id=567466
|
||||
|
||||
Upstream-Status: Backport [commit ecdde483c81fb89e35f025ee3aacba7cd45528ab]
|
||||
|
||||
Signed-off-by: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
|
||||
---
|
||||
sound_play/CMakeLists.txt | 6 ++++--
|
||||
1 file changed, 4 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/sound_play/CMakeLists.txt b/sound_play/CMakeLists.txt
|
||||
index ada0b07..3f9604c 100644
|
||||
--- a/sound_play/CMakeLists.txt
|
||||
+++ b/sound_play/CMakeLists.txt
|
||||
@@ -16,9 +16,11 @@ generate_messages(DEPENDENCIES actionlib_msgs)
|
||||
catkin_package(CATKIN_DEPENDS message_runtime actionlib_msgs
|
||||
INCLUDE_DIRS include)
|
||||
|
||||
-catkin_add_nosetests(scripts/test)
|
||||
+if(CATKIN_ENABLE_TESTING)
|
||||
+ catkin_add_nosetests(scripts/test)
|
||||
|
||||
-add_subdirectory(test)
|
||||
+ add_subdirectory(test)
|
||||
+endif()
|
||||
|
||||
install(PROGRAMS
|
||||
scripts/playbuiltin.py
|
||||
--
|
||||
2.4.3
|
||||
|
|
@ -11,4 +11,6 @@ DEPENDS += "roscpp roslib audio-common-msgs diagnostic-msgs"
|
|||
|
||||
require audio-common.inc
|
||||
|
||||
SRC_URI += "file://0002-sound_play-Fix-build-with-DCATKIN_ENABLE_TESTING-OFF.patch;striplevel=2"
|
||||
|
||||
RRECOMMENDS_${PN} += "roscpp roslib audio-common-msgs diagnostic-msgs gst-plugins-base gst-plugins-ugly gst-plugins-good rospy festival python-gst gst-meta-audio"
|
Loading…
Reference in New Issue