kdl-parser: refresh patch

* fixes:
WARNING: kdl-parser-1.11.14-r0 do_patch:
Some of the context lines in patches were ignored. This can lead to incorrectly applied patches.
The context lines in the patches can be updated with devtool:

    devtool modify <recipe>
    devtool finish --force-patch-refresh <recipe> <layer_path>

Then the updated patches and the source tree (in devtool's workspace)
should be reviewed to make sure the patches apply in the correct place
and don't introduce duplicate lines (which can, and does happen
when some of the context is ignored). Further information:
http://lists.openembedded.org/pipermail/openembedded-core/2018-March/148675.html
https://bugzilla.yoctoproject.org/show_bug.cgi?id=10450
Details:
Applying patch 0001-add-explicit-dependency-on-libeigen.patch
patching file CMakeLists.txt
Hunk #1 succeeded at 9 with fuzz 1.

Now at patch 0001-add-explicit-dependency-on-libeigen.patch

Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
This commit is contained in:
Martin Jansa 2018-04-10 09:32:08 +00:00
parent 6cfb5c946c
commit a7eeafe2c2
2 changed files with 9 additions and 11 deletions

View File

@ -1,4 +1,4 @@
From 48eebb8144f326040c82ea37e8cf00291fbc1403 Mon Sep 17 00:00:00 2001
From 473d1546f7bbc3bacce1c9b8ada28d591e4ff3f0 Mon Sep 17 00:00:00 2001
From: Dmitry Rozhkov <dmitry.rozhkov@linux.intel.com>
Date: Fri, 17 Feb 2017 10:49:30 +0200
Subject: [PATCH] add explicit dependency on libeigen
@ -20,14 +20,15 @@ been declarated as a dependency in kdl-parser's recipe.
Upstream-Status: Inappropriate [It's not kdl-parser's problem, but orocos-kdl's one]
Signed-off-by: Dmitry Rozhkov <dmitry.rozhkov@linux.intel.com>
---
CMakeLists.txt | 3 ++-
kdl_parser/CMakeLists.txt | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 43b96b7..5c96e55 100644
--- aCMakeLists.txt
+++ bCMakeLists.txt
diff --git a/kdl_parser/CMakeLists.txt b/kdl_parser/CMakeLists.txt
index fe6eab9..2ad285e 100644
--- a/kdl_parser/CMakeLists.txt
+++ b/kdl_parser/CMakeLists.txt
@@ -9,9 +9,10 @@ find_package(catkin REQUIRED
COMPONENTS roscpp rosconsole urdf cmake_modules
)
@ -39,7 +40,4 @@ index 43b96b7..5c96e55 100644
+include_directories(include ${EIGEN3_INCLUDE_DIR} ${orocos_kdl_INCLUDE_DIRS} ${TinyXML_INCLUDE_DIRS} ${catkin_INCLUDE_DIRS})
link_directories(${catkin_LIBRARY_DIRS})
link_directories(${orocos_kdl_LIBRARY_DIRS})
--
2.7.4
link_directories(${Boost_LIBRARY_DIRS})

View File

@ -7,4 +7,4 @@ DEPENDS = "libeigen orocos-kdl rosconsole roscpp urdf cmake-modules"
require kdl-parser.inc
SRC_URI += "file://0001-add-explicit-dependency-on-libeigen.patch"
SRC_URI += "file://0001-add-explicit-dependency-on-libeigen.patch;patchdir=.."