DRAFT python-matplotlib: Upgrade to v2.1.1
This commit is contained in:
parent
8a632928e8
commit
b2d736c3fa
|
@ -1,10 +1,10 @@
|
||||||
This fixes the numpy import problem in setupext.py using a hard-coded path.
|
This fixes the numpy import problem in setupext.py using a hard-coded path.
|
||||||
|
|
||||||
Index: matplotlib-2.0.2/setupext.py
|
Index: matplotlib-2.1.1/setupext.py
|
||||||
===================================================================
|
===================================================================
|
||||||
--- matplotlib-2.0.2.orig/setupext.py
|
--- matplotlib-2.1.1.orig/setupext.py 2018-01-17 20:21:34.000000000 -0800
|
||||||
+++ matplotlib-2.0.2/setupext.py
|
+++ matplotlib-2.1.1/setupext.py 2019-04-24 16:08:56.634978457 -0700
|
||||||
@@ -148,6 +148,7 @@ def has_include_file(include_dirs, filen
|
@@ -150,6 +150,7 @@ def has_include_file(include_dirs, filen
|
||||||
Returns `True` if `filename` can be found in one of the
|
Returns `True` if `filename` can be found in one of the
|
||||||
directories in `include_dirs`.
|
directories in `include_dirs`.
|
||||||
"""
|
"""
|
||||||
|
@ -12,16 +12,16 @@ Index: matplotlib-2.0.2/setupext.py
|
||||||
if sys.platform == 'win32':
|
if sys.platform == 'win32':
|
||||||
include_dirs += os.environ.get('INCLUDE', '.').split(';')
|
include_dirs += os.environ.get('INCLUDE', '.').split(';')
|
||||||
for dir in include_dirs:
|
for dir in include_dirs:
|
||||||
@@ -172,7 +173,7 @@ def get_base_dirs():
|
@@ -174,7 +175,7 @@ def get_base_dirs():
|
||||||
Returns a list of standard base directories on this platform.
|
Returns a list of standard base directories on this platform.
|
||||||
"""
|
"""
|
||||||
if options['basedirlist']:
|
if options['basedirlist']:
|
||||||
- return options['basedirlist']
|
- return options['basedirlist']
|
||||||
+ return [os.environ['STAGING_LIBDIR']]
|
+ return [os.environ['STAGING_LIBDIR']]
|
||||||
|
|
||||||
basedir_map = {
|
if os.environ.get('MPLBASEDIRLIST'):
|
||||||
'win32': ['win32_static', ],
|
return os.environ.get('MPLBASEDIRLIST').split(os.pathsep)
|
||||||
@@ -260,14 +261,6 @@ def make_extension(name, files, *args, *
|
@@ -274,14 +275,6 @@ def make_extension(name, files, *args, *
|
||||||
`distutils.core.Extension` constructor.
|
`distutils.core.Extension` constructor.
|
||||||
"""
|
"""
|
||||||
ext = DelayedExtension(name, files, *args, **kwargs)
|
ext = DelayedExtension(name, files, *args, **kwargs)
|
||||||
|
@ -36,7 +36,7 @@ Index: matplotlib-2.0.2/setupext.py
|
||||||
ext.include_dirs.append('.')
|
ext.include_dirs.append('.')
|
||||||
|
|
||||||
return ext
|
return ext
|
||||||
@@ -314,6 +307,7 @@ class PkgConfig(object):
|
@@ -328,6 +321,7 @@ class PkgConfig(object):
|
||||||
" matplotlib may not be able to find some of its dependencies")
|
" matplotlib may not be able to find some of its dependencies")
|
||||||
|
|
||||||
def set_pkgconfig_path(self):
|
def set_pkgconfig_path(self):
|
||||||
|
@ -61,18 +61,18 @@ Index: matplotlib-2.0.2/setupext.py
|
||||||
|
|
||||||
def check(self):
|
def check(self):
|
||||||
min_version = extract_versions()['__version__numpy__']
|
min_version = extract_versions()['__version__numpy__']
|
||||||
Index: matplotlib-2.0.2/setup.py
|
Index: matplotlib-2.1.1/setup.py
|
||||||
===================================================================
|
===================================================================
|
||||||
--- matplotlib-2.0.2.orig/setup.py
|
--- matplotlib-2.1.1.orig/setup.py 2018-01-17 20:21:34.000000000 -0800
|
||||||
+++ matplotlib-2.0.2/setup.py
|
+++ matplotlib-2.1.1/setup.py 2019-04-24 16:01:42.474978457 -0700
|
||||||
@@ -66,28 +66,6 @@ mpl_packages = [
|
@@ -66,27 +66,6 @@ mpl_packages = [
|
||||||
setupext.Python(),
|
setupext.Python(),
|
||||||
setupext.Platform(),
|
setupext.Platform(),
|
||||||
'Required dependencies and extensions',
|
'Required dependencies and extensions',
|
||||||
- setupext.Numpy(),
|
- setupext.Numpy(),
|
||||||
- setupext.Six(),
|
- setupext.Six(),
|
||||||
- setupext.Dateutil(),
|
- setupext.Dateutil(),
|
||||||
- setupext.FuncTools32(),
|
- setupext.BackportsFuncToolsLRUCache(),
|
||||||
- setupext.Subprocess32(),
|
- setupext.Subprocess32(),
|
||||||
- setupext.Pytz(),
|
- setupext.Pytz(),
|
||||||
- setupext.Cycler(),
|
- setupext.Cycler(),
|
||||||
|
@ -88,13 +88,12 @@ Index: matplotlib-2.0.2/setup.py
|
||||||
- setupext.Path(),
|
- setupext.Path(),
|
||||||
- setupext.ContourLegacy(),
|
- setupext.ContourLegacy(),
|
||||||
- setupext.Contour(),
|
- setupext.Contour(),
|
||||||
- setupext.Delaunay(),
|
|
||||||
- setupext.QhullWrap(),
|
- setupext.QhullWrap(),
|
||||||
- setupext.Tri(),
|
- setupext.Tri(),
|
||||||
'Optional subpackages',
|
'Optional subpackages',
|
||||||
setupext.SampleData(),
|
setupext.SampleData(),
|
||||||
setupext.Toolkits(),
|
setupext.Toolkits(),
|
||||||
@@ -100,13 +78,8 @@ mpl_packages = [
|
@@ -99,13 +78,8 @@ mpl_packages = [
|
||||||
setupext.BackendMacOSX(),
|
setupext.BackendMacOSX(),
|
||||||
setupext.BackendQt5(),
|
setupext.BackendQt5(),
|
||||||
setupext.BackendQt4(),
|
setupext.BackendQt4(),
|
||||||
|
|
|
@ -9,8 +9,8 @@ RDEPENDS_${PN} = "python-core python-distutils python-numpy freetype libpng pyth
|
||||||
SRC_URI = "https://github.com/matplotlib/matplotlib/archive/v${PV}.tar.gz;downloadfilename=${BP}.tar.gz \
|
SRC_URI = "https://github.com/matplotlib/matplotlib/archive/v${PV}.tar.gz;downloadfilename=${BP}.tar.gz \
|
||||||
file://fix_setupext.patch \
|
file://fix_setupext.patch \
|
||||||
"
|
"
|
||||||
SRC_URI[md5sum] = "89717c1ef3c6fdcd6fb1f3b597a4858c"
|
SRC_URI[md5sum] = "495773801b8ae731d382284dcf87cbc6"
|
||||||
SRC_URI[sha256sum] = "aebed23921562792b68b8ca355de5abc176af4424f1987e2fa95f65e5c5e7e89"
|
SRC_URI[sha256sum] = "40830d614384f0d837c81f1ca3cef795cfb871cb1d49cde0fc5beea157cec372"
|
||||||
S = "${WORKDIR}/matplotlib-${PV}"
|
S = "${WORKDIR}/matplotlib-${PV}"
|
||||||
EXTRA_OECONF = "--disable-docs"
|
EXTRA_OECONF = "--disable-docs"
|
||||||
|
|
Loading…
Reference in New Issue