log4cxx: update to current svn version (resolves #390)
The svn version of log4cxx does not require the previous patches and hence, they are dropped.
This commit is contained in:
parent
e8e859ac4e
commit
b4baa4a896
|
@ -1,50 +0,0 @@
|
|||
From af4e8f0eccdc2f562f9e591b101ee856a962e01d Mon Sep 17 00:00:00 2001
|
||||
From: Tasslehoff Kjappfot <tasskjapp@gmail.com>
|
||||
Date: Thu, 14 Oct 2010 08:57:08 +0200
|
||||
Subject: [PATCH 1/2] log4cxx_0-10-0_add missing includes
|
||||
|
||||
---
|
||||
src/examples/cpp/console.cpp | 1 +
|
||||
src/main/cpp/inputstreamreader.cpp | 1 +
|
||||
src/main/cpp/socketoutputstream.cpp | 1 +
|
||||
3 files changed, 3 insertions(+), 0 deletions(-)
|
||||
|
||||
diff --git a/src/examples/cpp/console.cpp b/src/examples/cpp/console.cpp
|
||||
index 6a01d8a..a673a10 100644
|
||||
--- a/src/examples/cpp/console.cpp
|
||||
+++ b/src/examples/cpp/console.cpp
|
||||
@@ -22,6 +22,7 @@
|
||||
#include <log4cxx/logmanager.h>
|
||||
#include <iostream>
|
||||
#include <locale.h>
|
||||
+#include <cstring>
|
||||
|
||||
using namespace log4cxx;
|
||||
using namespace log4cxx::helpers;
|
||||
diff --git a/src/main/cpp/inputstreamreader.cpp b/src/main/cpp/inputstreamreader.cpp
|
||||
index 52b1c0a..cb45181 100644
|
||||
--- a/src/main/cpp/inputstreamreader.cpp
|
||||
+++ b/src/main/cpp/inputstreamreader.cpp
|
||||
@@ -20,6 +20,7 @@
|
||||
#include <log4cxx/helpers/exception.h>
|
||||
#include <log4cxx/helpers/pool.h>
|
||||
#include <log4cxx/helpers/bytebuffer.h>
|
||||
+#include <cstring>
|
||||
|
||||
using namespace log4cxx;
|
||||
using namespace log4cxx::helpers;
|
||||
diff --git a/src/main/cpp/socketoutputstream.cpp b/src/main/cpp/socketoutputstream.cpp
|
||||
index 185f835..c61eb11 100644
|
||||
--- a/src/main/cpp/socketoutputstream.cpp
|
||||
+++ b/src/main/cpp/socketoutputstream.cpp
|
||||
@@ -19,6 +19,7 @@
|
||||
#include <log4cxx/helpers/socketoutputstream.h>
|
||||
#include <log4cxx/helpers/socket.h>
|
||||
#include <log4cxx/helpers/bytebuffer.h>
|
||||
+#include <cstring>
|
||||
|
||||
using namespace log4cxx;
|
||||
using namespace log4cxx::helpers;
|
||||
--
|
||||
1.7.0.4
|
||||
|
|
@ -1,39 +0,0 @@
|
|||
From a32da098ded31e6399658a01dd5c994e23f8c5a8 Mon Sep 17 00:00:00 2001
|
||||
From: Tasslehoff Kjappfot <tasskjapp@gmail.com>
|
||||
Date: Thu, 14 Oct 2010 09:02:11 +0200
|
||||
Subject: [PATCH 2/2] Remove duplicates
|
||||
|
||||
---
|
||||
src/main/include/log4cxx/Makefile.am | 2 +-
|
||||
src/main/include/log4cxx/private/Makefile.am | 2 +-
|
||||
2 files changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/src/main/include/log4cxx/Makefile.am b/src/main/include/log4cxx/Makefile.am
|
||||
index 719c2dd..53e99b0 100644
|
||||
--- a/src/main/include/log4cxx/Makefile.am
|
||||
+++ b/src/main/include/log4cxx/Makefile.am
|
||||
@@ -15,7 +15,7 @@
|
||||
#
|
||||
SUBDIRS = helpers net nt rolling spi varia xml config db private pattern filter
|
||||
log4cxxincdir = $(includedir)/log4cxx
|
||||
-log4cxxinc_HEADERS= $(top_srcdir)/src/main/include/log4cxx/*.h log4cxx.h
|
||||
+log4cxxinc_HEADERS= $(top_srcdir)/src/main/include/log4cxx/*.h
|
||||
DISTCLEANFILES = log4cxx.h
|
||||
EXTRA_DIST = log4cxx.hw
|
||||
|
||||
diff --git a/src/main/include/log4cxx/private/Makefile.am b/src/main/include/log4cxx/private/Makefile.am
|
||||
index 3a896ea..474e31d 100644
|
||||
--- a/src/main/include/log4cxx/private/Makefile.am
|
||||
+++ b/src/main/include/log4cxx/private/Makefile.am
|
||||
@@ -14,7 +14,7 @@
|
||||
# limitations under the License.
|
||||
#
|
||||
privateincdir = $(includedir)/log4cxx/private
|
||||
-privateinc_HEADERS= $(top_builddir)/src/main/include/log4cxx/private/*.h log4cxx_private.h
|
||||
+privateinc_HEADERS= $(top_builddir)/src/main/include/log4cxx/private/*.h
|
||||
DISTCLEANFILES = log4cxx_private.h
|
||||
EXTRA_DIST = log4cxx_private.hw
|
||||
|
||||
--
|
||||
1.7.0.4
|
||||
|
|
@ -1,13 +0,0 @@
|
|||
diff -cr apache-log4cxx-0.10.0.orig/src/examples/cpp/console.cpp apache-log4cxx-0.10.0/src/examples/cpp/console.cpp
|
||||
*** apache-log4cxx-0.10.0.orig/src/examples/cpp/console.cpp 2012-12-05 08:55:15.750389873 +0100
|
||||
--- apache-log4cxx-0.10.0/src/examples/cpp/console.cpp 2012-12-05 08:56:09.538392104 +0100
|
||||
***************
|
||||
*** 16,21 ****
|
||||
--- 16,22 ----
|
||||
*/
|
||||
|
||||
#include <stdlib.h>
|
||||
+ #include <stdio.h>
|
||||
#include <log4cxx/logger.h>
|
||||
#include <log4cxx/consoleappender.h>
|
||||
#include <log4cxx/simplelayout.h>
|
|
@ -1,20 +0,0 @@
|
|||
DESCRIPTION = "Apache logging framework for C++ library"
|
||||
SECTION = "libs"
|
||||
DEPENDS = "apr apr-util expat gdbm"
|
||||
LICENSE = "Apache-2.0"
|
||||
LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
|
||||
HOMEPAGE = "http://logging.apache.org/log4cxx/"
|
||||
PR = "r0"
|
||||
|
||||
SRC_URI = "http://archive.apache.org/dist/logging/log4cxx/0.10.0/apache-log4cxx-0.10.0.tar.gz \
|
||||
file://0001-log4cxx_0-10-0_add-missing-includes.patch \
|
||||
file://0002-Remove-duplicates-from-makefile.patch \
|
||||
file://0003-log4cxx-0.10.0-add_stdio_header.patch"
|
||||
SRC_URI[md5sum] = "b30ffb8da3665178e68940ff7a61084c"
|
||||
SRC_URI[sha256sum] = "0de0396220a9566a580166e66b39674cb40efd2176f52ad2c65486c99c920c8c"
|
||||
|
||||
S = "${WORKDIR}/apache-${BP}"
|
||||
|
||||
inherit autotools-brokensep pkgconfig
|
||||
|
||||
BBCLASSEXTEND += "native"
|
|
@ -0,0 +1,15 @@
|
|||
DESCRIPTION = "Apache logging framework for C++ library"
|
||||
SECTION = "libs"
|
||||
DEPENDS = "apr apr-util expat gdbm"
|
||||
LICENSE = "Apache-2.0"
|
||||
LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
|
||||
HOMEPAGE = "http://logging.apache.org/log4cxx/"
|
||||
|
||||
SRC_URI = "svn://svn.apache.org/repos/asf;module=incubator/log4cxx/trunk;protocol=http"
|
||||
SRCREV = "1738416"
|
||||
|
||||
S = "${WORKDIR}/incubator/log4cxx/trunk"
|
||||
|
||||
inherit autotools-brokensep pkgconfig
|
||||
|
||||
BBCLASSEXTEND += "native"
|
Loading…
Reference in New Issue