Merge pull request #318 from bulwahn/master-next
resolving last major issue and last updates for 0.2-rc1
This commit is contained in:
commit
bdc603b821
|
@ -35,6 +35,12 @@ Currently, this layer is still under continuous development.
|
|||
* Khem Raj <raj.khem@gmail.com>
|
||||
* Esteve Fernandez <esteve@apache.org>
|
||||
* Jonas Sticha <jonas.sticha@bmw-carit.de>
|
||||
* Pascal Bach <pascal.bach@siemens.com>
|
||||
* Andreas Galauner <andreas@galauner.de>
|
||||
* Peter S. Housel <housel@acm.org>
|
||||
* Gauthier Monserand <simkim@simkim.net>
|
||||
* Timo Mueller <timo.mueller@bmw-carit.de>
|
||||
* Andreas Baak <andreas.baak@bmw-carit.de>
|
||||
|
||||
|
||||
## HOW TO CONTRIBUTE ##
|
||||
|
|
|
@ -4,6 +4,8 @@ LICENSE = "BSD"
|
|||
LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=e910b35b0ef4e1f665b9a75d6afb7709"
|
||||
SRCNAME = "rosdep"
|
||||
|
||||
DEPENDS = "python-nose"
|
||||
|
||||
SRC_URI = "http://pypi.python.org/packages/source/r/rosdep/rosdep-${PV}.tar.gz"
|
||||
SRC_URI[md5sum] = "c1e3f200d9beddb5c70cc0a74ab47734"
|
||||
SRC_URI[sha256sum] = "6d043e1fb58d8b366f90b63ccfaff3140416bf1a6f4014bb3bb1b85af7a77073"
|
||||
|
|
|
@ -9,7 +9,8 @@ SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilena
|
|||
SRC_URI[md5sum] = "a0dd74c4a665a56b02af9f8c873c451d"
|
||||
SRC_URI[sha256sum] = "71441206945e8d77dace831375effde5b5f54b95e3a054106848432eceec58c0"
|
||||
|
||||
SRC_URI += "file://0001-CATKIN_WORKSPACES-Don-t-require-.catkin-file.patch"
|
||||
SRC_URI += "file://0001-CATKIN_WORKSPACES-Don-t-require-.catkin-file.patch\
|
||||
file://0002-PKG_CONFIG_LIB_PATHS-use-cmake-root-path.patch"
|
||||
|
||||
inherit catkin
|
||||
|
||||
|
|
|
@ -0,0 +1,28 @@
|
|||
From 25b1c65090ece840e29844253577d7ed6dc8251f Mon Sep 17 00:00:00 2001
|
||||
From: Kristof Robot <krirobo@gmail.com>
|
||||
Date: Thu, 21 Aug 2014 12:48:41 +0200
|
||||
Subject: [PATCH] catkin: including root path in library search
|
||||
|
||||
Upstream-Status: Inappropriate [only for our setup]
|
||||
|
||||
Signed-off-by: Kristof Robot <krirobo@gmail.com>
|
||||
---
|
||||
cmake/templates/pkgConfig.cmake.in | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/cmake/templates/pkgConfig.cmake.in b/cmake/templates/pkgConfig.cmake.in
|
||||
index 91f6d65..f7bf2b2 100644
|
||||
--- a/cmake/templates/pkgConfig.cmake.in
|
||||
+++ b/cmake/templates/pkgConfig.cmake.in
|
||||
@@ -125,7 +125,7 @@ foreach(library ${libraries})
|
||||
foreach(path @PKG_CONFIG_LIB_PATHS@)
|
||||
find_library(lib ${library}
|
||||
PATHS ${path}
|
||||
- NO_DEFAULT_PATH NO_CMAKE_FIND_ROOT_PATH)
|
||||
+ NO_DEFAULT_PATH)
|
||||
if(lib)
|
||||
set(lib_path ${path})
|
||||
break()
|
||||
--
|
||||
1.8.3.2
|
||||
|
|
@ -6,7 +6,7 @@ LIC_FILES_CHKSUM = "file://package.xml;beginline=10;endline=10;md5=d566ef916e9de
|
|||
DEPENDS = "genmsg"
|
||||
|
||||
SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
|
||||
SRC_URI[md5sum] = "03f0c73d79e35d4704289b18e4e4b6f2"
|
||||
SRC_URI[sha256sum] = "c12ae21100b11635672c17bdeb165c17ae74bddf4ce8f9bc97711fed0eef9698"
|
||||
SRC_URI[md5sum] = "74ae3d474fe0d8c7d67f85039a6a0b57"
|
||||
SRC_URI[sha256sum] = "cc170a66f92e17945168479974ba24ed6970e9f09eb555b0225a99d339e22a5a"
|
||||
|
||||
inherit catkin
|
|
@ -30,7 +30,7 @@ configurations.
|
|||
|
||||
Signed-off-by: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
|
||||
|
||||
Upstream-Status: Submitted [https://github.com/ros-drivers/gscam/pull/24]
|
||||
Upstream-Status: Accepted
|
||||
---
|
||||
include/gscam/gscam_nodelet.h | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
|
|
@ -28,7 +28,7 @@ find_package resolved to the hard-coded value.
|
|||
|
||||
Signed-off-by: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
|
||||
|
||||
Upstream-Status: Submitted [https://github.com/ros-planning/navigation/pull/311]
|
||||
Upstream-Status: Accepted [in indigo-devel branch]
|
||||
---
|
||||
dwa_local_planner/CMakeLists.txt | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
|
|
@ -152,6 +152,7 @@ RDEPENDS_${PN} = "\
|
|||
roslint \
|
||||
ros-pocketsphinx \
|
||||
sound-play \
|
||||
rt-tests-support \
|
||||
communication-tests \
|
||||
cyclic-timer-tests \
|
||||
oneshot-timer-tests \
|
||||
|
@ -163,6 +164,11 @@ RDEPENDS_${PN} = "\
|
|||
ar-track-alvar \
|
||||
razor-imu-9dof \
|
||||
xv-11-laser-driver \
|
||||
ros-arduino-firmware \
|
||||
ros-arduino-msgs \
|
||||
ros-arduino-python \
|
||||
frontier-exploration \
|
||||
hector-mapping \
|
||||
"
|
||||
|
||||
# joint-state-publisher still has some issues.
|
||||
|
|
|
@ -7,9 +7,11 @@ SECTION = "devel"
|
|||
LICENSE = "BSD"
|
||||
LIC_FILES_CHKSUM = "file://package.xml;beginline=15;endline=15;md5=d566ef916e9dedc494f5f793a6690ba5"
|
||||
|
||||
DEPENDS = "dynamic-reconfigure"
|
||||
|
||||
SRC_URI = "https://github.com/KristofRobot/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
|
||||
SRC_URI[md5sum] = "3a05ce324d043400a2a214bcc040f843"
|
||||
SRC_URI[sha256sum] = "4a948cc34e36ce5be9c3e4a2e681eed713e1a5a3df674dd4761a0795e607da35"
|
||||
SRC_URI[md5sum] = "8b82e5752d5d4f788e87b434ffee6a39"
|
||||
SRC_URI[sha256sum] = "97dac4e4d287b41d40aa9c1a4bb09f716e244a49f928cfc1ec31a9d2962965f9"
|
||||
|
||||
S = "${WORKDIR}/${ROS_SP}"
|
||||
|
Loading…
Reference in New Issue