DRAFT graphviz_2.40.1.bb: Import from meta-oe[master]@a07c969aebea4edb66babbc264777f626ed8eb7b
This commit is contained in:
parent
e3055a1231
commit
d2516aeb9b
|
@ -0,0 +1,31 @@
|
||||||
|
From 5e53b643615fd53f3ff960521bbe9d95641e5f68 Mon Sep 17 00:00:00 2001
|
||||||
|
From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@gmail.com>
|
||||||
|
Date: Sun, 20 Jan 2019 23:58:29 +0100
|
||||||
|
Subject: [PATCH] Use native mkdefs
|
||||||
|
MIME-Version: 1.0
|
||||||
|
Content-Type: text/plain; charset=UTF-8
|
||||||
|
Content-Transfer-Encoding: 8bit
|
||||||
|
|
||||||
|
Upstream-Status: Inappropriate [embedded specific]
|
||||||
|
|
||||||
|
Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
|
||||||
|
---
|
||||||
|
lib/gvpr/Makefile.am | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/lib/gvpr/Makefile.am b/lib/gvpr/Makefile.am
|
||||||
|
index ac3c098..4914854 100644
|
||||||
|
--- a/lib/gvpr/Makefile.am
|
||||||
|
+++ b/lib/gvpr/Makefile.am
|
||||||
|
@@ -57,7 +57,7 @@ endif
|
||||||
|
mkdefs_SOURCES = mkdefs.c
|
||||||
|
|
||||||
|
gdefs.h: $(top_srcdir)/lib/gvpr/gprdata mkdefs$(EXEEXT)
|
||||||
|
- ./mkdefs$(EXEEXT) gdefs.h < $(top_srcdir)/lib/gvpr/gprdata
|
||||||
|
+ mkdefs$(EXEEXT) gdefs.h < $(top_srcdir)/lib/gvpr/gprdata
|
||||||
|
|
||||||
|
EXTRA_DIST = $(man_MANS) $(pdf_DATA) gprdata mkdefs.c gdefs.h trie.c gvprlib.vcxproj*
|
||||||
|
|
||||||
|
--
|
||||||
|
2.20.1
|
||||||
|
|
|
@ -0,0 +1,59 @@
|
||||||
|
SUMMARY = "Graph Visualization Tools"
|
||||||
|
HOMEPAGE = "http://www.graphviz.org"
|
||||||
|
LICENSE = "EPL-1.0"
|
||||||
|
LIC_FILES_CHKSUM = "file://COPYING;md5=9109f5fc16cf963fb3cdd32781b3ce04"
|
||||||
|
|
||||||
|
DEPENDS = " \
|
||||||
|
intltool-native \
|
||||||
|
bison-native \
|
||||||
|
groff-native \
|
||||||
|
libtool \
|
||||||
|
gdk-pixbuf \
|
||||||
|
librsvg \
|
||||||
|
cairo \
|
||||||
|
pango \
|
||||||
|
expat \
|
||||||
|
freetype \
|
||||||
|
"
|
||||||
|
DEPENDS_append_class-target = " ${BPN}-native"
|
||||||
|
|
||||||
|
inherit autotools-brokensep pkgconfig gettext
|
||||||
|
|
||||||
|
# The source tarball suggested at
|
||||||
|
# https://graphviz.gitlab.io/_pages/Download/Download_source.html has no
|
||||||
|
# version in its name. So once graphviz is updgraded, only first time users will
|
||||||
|
# get checksum errors. Fedora people seem to expect same so they use a versioned
|
||||||
|
# source - see https://src.fedoraproject.org/cgit/rpms/graphviz.git/tree/graphviz.spec
|
||||||
|
|
||||||
|
SRC_URI = "https://gitlab.com/graphviz/graphviz/-/archive/stable_release_${PV}/graphviz-stable_release_${PV}.tar.gz \
|
||||||
|
"
|
||||||
|
# Use native mkdefs
|
||||||
|
SRC_URI_append_class-target = " file://0001-Use-native-mkdefs.patch"
|
||||||
|
SRC_URI[md5sum] = "2acf30ca8e6cc8b001b0334db65fd072"
|
||||||
|
SRC_URI[sha256sum] = "e6c3f8dbfde1c4523055403927bef29f97f9fc12715c1042b5dcf648a2c1c62a"
|
||||||
|
|
||||||
|
S = "${WORKDIR}/${BPN}-stable_release_${PV}"
|
||||||
|
|
||||||
|
EXTRA_OECONF_class-target = "\
|
||||||
|
--with-expatincludedir=${STAGING_INCDIR} \
|
||||||
|
--with-expatlibdir=${STAGING_LIBDIR} \
|
||||||
|
--without-included-ltdl \
|
||||||
|
--disable-java \
|
||||||
|
--disable-r \
|
||||||
|
--disable-sharp \
|
||||||
|
"
|
||||||
|
CFLAGS_append_class-target = " -D_typ_ssize_t=1 -D_long_double=1"
|
||||||
|
do_configure_prepend() {
|
||||||
|
cd ${S}
|
||||||
|
# create version.m4 and ignore libtoolize errors
|
||||||
|
./autogen.sh NOCONFIG || true
|
||||||
|
}
|
||||||
|
|
||||||
|
do_install_append_class-native() {
|
||||||
|
# install mkdefs for target build
|
||||||
|
install -m755 ${B}/lib/gvpr/mkdefs ${D}${bindir}
|
||||||
|
}
|
||||||
|
|
||||||
|
FILES_SOLIBSDEV_append = " ${libdir}/graphviz/lib*${SOLIBSDEV}"
|
||||||
|
|
||||||
|
BBCLASSEXTEND = "native"
|
Loading…
Reference in New Issue