xacro: updating to 1.8.5

The version 1.8.5 incorporates the local patch, and hence the local
patch is removed. Furthermore, it now requires roslint.
This commit is contained in:
Lukas Bulwahn 2014-05-07 08:18:14 +02:00
parent 1b9dd58c4d
commit d802ac2bef
2 changed files with 4 additions and 45 deletions

View File

@ -1,41 +0,0 @@
From 1a534325ce98bd1250c3f586b243c85a0515fcac Mon Sep 17 00:00:00 2001
From: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
Date: Sat, 12 Oct 2013 11:14:26 +0200
Subject: [PATCH] check for CATKIN_ENABLE_TESTING
Upstream-Status: Accepted
---
CMakeLists.txt | 6 ++++--
package.xml | 2 +-
2 files changed, 5 insertions(+), 3 deletions(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2d67593..f68faa8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -16,5 +16,7 @@ install(PROGRAMS xacro.py DESTINATION ${CATKIN_PACKAGE_SHARE_DESTINATION})
install(PROGRAMS scripts/xacro DESTINATION ${CATKIN_PACKAGE_BIN_DESTINATION})
-## Add folders to be run by python nosetests
-catkin_add_nosetests(test)
+if(CATKIN_ENABLE_TESTING)
+ ## Add folders to be run by python nosetests
+ catkin_add_nosetests(test)
+endif()
diff --git a/package.xml b/package.xml
index 69cb9e7..26f61e2 100644
--- a/package.xml
+++ b/package.xml
@@ -17,7 +17,7 @@
<author>Stuart Glaser</author>
- <buildtool_depend>catkin</buildtool_depend>
+ <buildtool_depend version_gte="0.5.68">catkin</buildtool_depend>
<run_depend>roslaunch</run_depend>
--
1.8.1.2

View File

@ -3,10 +3,10 @@ SECTION = "devel"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://package.xml;beginline=12;endline=12;md5=d566ef916e9dedc494f5f793a6690ba5"
SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
SRC_URI[md5sum] = "32848b03f52b6a4b4040ccc4634c13ce"
SRC_URI[sha256sum] = "44f7190cecab31ab67460d40c7872d99fe89907fad20106dbf5205f33ba54718"
DEPENDS = "roslint"
SRC_URI += "file://0001-check-for-CATKIN_ENABLE_TESTING.patch"
SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
SRC_URI[md5sum] = "0ab54d837509adc0579eacae4f27d8b6"
SRC_URI[sha256sum] = "bcb0c5706a7da913431d49478b795667b32c7f7dee28639024b267e022ffc25a"
inherit catkin