base-local-planner: remove rostest dependency

This commit is contained in:
Lukas Bulwahn 2017-04-06 10:51:42 +02:00
parent b3ffbe4ec9
commit d8a4759236
2 changed files with 38 additions and 1 deletions

View File

@ -0,0 +1,35 @@
From e6f3979ff8b988fe7992bf08a8267f1e11f58627 Mon Sep 17 00:00:00 2001
From: Lukas Bulwahn <lukas.bulwahn@gmail.com>
Date: Tue, 4 Apr 2017 14:39:25 +0200
Subject: [PATCH] make rostest in CMakeLists optional (ros/rosdistro#3010)
Upstream-Status: Submitted [https://github.com/ros-planning/navigation/pull/565]
Signed-off-by: Lukas Bulwahn <lukas.bulwahn@gmail.com>
---
base_local_planner/CMakeLists.txt | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/base_local_planner/CMakeLists.txt b/base_local_planner/CMakeLists.txt
index 2444ae1..507af18 100644
--- a/base_local_planner/CMakeLists.txt
+++ b/base_local_planner/CMakeLists.txt
@@ -10,7 +10,6 @@ find_package(catkin REQUIRED
dynamic_reconfigure
nav_core
pcl_conversions
- rostest
costmap_2d
pluginlib
angles
@@ -129,6 +128,7 @@ install(DIRECTORY include/${PROJECT_NAME}/
)
if(CATKIN_ENABLE_TESTING)
+ find_package(rostest)
catkin_add_gtest(base_local_planner_utest
test/gtest_main.cpp
test/utest.cpp
--
2.5.5

View File

@ -6,6 +6,8 @@ LIC_FILES_CHKSUM = "file://package.xml;beginline=14;endline=14;md5=01c2bc31767cc
DEPENDS = "angles costmap-2d dynamic-reconfigure geometry-msgs libeigen message-generation \
nav-core nav-msgs pcl-conversions pcl-ros pluginlib rosconsole roscpp rospy std-msgs tf \
voxel-grid visualization-msgs rostest"
voxel-grid visualization-msgs"
require navigation.inc
SRC_URI += "file://0001-make-rostest-in-CMakeLists-optional-ros-rosdistro-30.patch;striplevel=2"