socketcan-interface: refresh patches

* fixes:
WARNING: socketcan-interface-0.6.8-r0 do_patch:
Some of the context lines in patches were ignored. This can lead to incorrectly applied patches.
The context lines in the patches can be updated with devtool:

    devtool modify <recipe>
    devtool finish --force-patch-refresh <recipe> <layer_path>

Then the updated patches and the source tree (in devtool's workspace)
should be reviewed to make sure the patches apply in the correct place
and don't introduce duplicate lines (which can, and does happen
when some of the context is ignored). Further information:
http://lists.openembedded.org/pipermail/openembedded-core/2018-March/148675.html
https://bugzilla.yoctoproject.org/show_bug.cgi?id=10450
Details:
Applying patch 0001-find-and-link-the-thread-library-properly.patch
patching file CMakeLists.txt
Hunk #2 succeeded at 45 with fuzz 1.

Now at patch 0001-find-and-link-the-thread-library-properly.patch

Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
This commit is contained in:
Martin Jansa 2018-04-10 09:34:32 +00:00
parent c028899a33
commit eb7e744891
3 changed files with 9 additions and 15 deletions

View File

@ -1,4 +1,4 @@
From 89b29ca3a3c23ee07bb2df36b95ccfd60af98028 Mon Sep 17 00:00:00 2001
From 430b5e4dbb1e047b016cb7a4e244aca73f8bafc8 Mon Sep 17 00:00:00 2001
From: Lukas Bulwahn <lukas.bulwahn@gmail.com>
Date: Sat, 17 Feb 2018 20:15:12 +0100
Subject: [PATCH] compile also with boost >= 1.66.0
@ -20,6 +20,7 @@ Signed-off-by: Lukas Bulwahn <lukas.bulwahn@gmail.com>
Upstream-Status: Accepted [https://github.com/ros-industrial/ros_canopen/commit/89b29ca3a3c23ee07bb2df36b95ccfd60af98028]
Signed-off-by: Lukas Bulwahn <lukas.bulwahn@gmail.com>
---
socketcan_interface/include/socketcan_interface/asio_base.h | 4 ++++
1 file changed, 4 insertions(+)
@ -40,6 +41,3 @@ index c54ff12..1a14480 100644
Socket socket_;
Frame input_;
--
2.7.4

View File

@ -1,4 +1,4 @@
From 3bf9d9726b278b000a829f639af21d423a38798a Mon Sep 17 00:00:00 2001
From 221747309d445a38412c2bb97c4b06e301ea7136 Mon Sep 17 00:00:00 2001
From: Lukas Bulwahn <lukas.bulwahn@gmail.com>
Date: Sat, 2 Dec 2017 09:17:02 +0100
Subject: [PATCH] explicitly include iostream to compile with boost >= 1.65.0
@ -39,12 +39,13 @@ This patch has been generated with:
in the ros_canopen repository.
Signed-off-by: Lukas Bulwahn <lukas.bulwahn@gmail.com>
---
socketcan_interface/include/socketcan_interface/interface.h | 1 +
1 file changed, 1 insertion(+)
diff --git a/socketcan_interface/include/socketcan_interface/interface.h b/socketcan_interface/include/socketcan_interface/interface.h
index f60f308..33378de 100644
index a78a392..0912bc7 100644
--- a/socketcan_interface/include/socketcan_interface/interface.h
+++ b/socketcan_interface/include/socketcan_interface/interface.h
@@ -190,6 +190,7 @@ public:
@ -55,6 +56,3 @@ index f60f308..33378de 100644
#include <boost/thread/mutex.hpp>
struct _cout_wrapper{
--
2.7.4

View File

@ -1,4 +1,4 @@
From 401544fa4aab80c0b511df6e629a90c439f5e067 Mon Sep 17 00:00:00 2001
From 16469e41f490c96d01dd8d894b784baf3d20f340 Mon Sep 17 00:00:00 2001
From: Lukas Bulwahn <lukas.bulwahn@gmail.com>
Date: Tue, 16 Jan 2018 15:57:59 +0100
Subject: [PATCH] find and link the thread library properly
@ -38,12 +38,13 @@ Signed-off-by: Lukas Bulwahn <lukas.bulwahn@gmail.com>
Upstream-Status: Submitted [https://github.com/ros-industrial/ros_canopen/pull/263]
Signed-off-by: Lukas Bulwahn <lukas.bulwahn@gmail.com>
---
socketcan_interface/CMakeLists.txt | 3 +++
1 file changed, 3 insertions(+)
diff --git a/socketcan_interface/CMakeLists.txt b/socketcan_interface/CMakeLists.txt
index 97dc658..c1ee4e4 100644
index 934451d..340872f 100644
--- a/socketcan_interface/CMakeLists.txt
+++ b/socketcan_interface/CMakeLists.txt
@@ -13,6 +13,8 @@ find_package(Boost REQUIRED
@ -56,13 +57,10 @@ index 97dc658..c1ee4e4 100644
INCLUDE_DIRS
include
@@ -43,6 +45,7 @@ target_link_libraries(socketcan_dump
${PROJECT_NAME}_string
socketcan_interface_string
${catkin_LIBRARIES}
${Boost_LIBRARIES}
+ ${CMAKE_THREAD_LIBS_INIT}
)
# socketcan_bcm
--
2.7.4