image-view: remove signals from find_package() calls to support boost 1.69

Deprecated signals library was dropped in 1.69.0 release:
https://www.boost.org/users/history/version_1_69_0.html

Signals (v1) is now removed. Its removal was announced in 1.68 and its
deprecation was announced in 1.54. Boost 1.68 is the last release that
provides this library. Users are encouraged to use Signals2 instead. The
Boost community thanks Douglas Gregor for his work on Signals which
served its users well and which also inspired Signals2.

image-view doesn't use signals at all.

Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
This commit is contained in:
Martin Jansa 2019-07-03 17:07:29 +00:00
parent 727d061f26
commit ebe2011819
2 changed files with 16 additions and 0 deletions

View File

@ -0,0 +1,14 @@
Upstream-Status: Pending
diff -uNr image_pipeline-1.12.23.orig/image_view/CMakeLists.txt image_pipeline-1.12.23/image_view/CMakeLists.txt
--- image_pipeline-1.12.23.orig/image_view/CMakeLists.txt 2018-05-10 12:52:54.000000000 +0000
+++ image_pipeline-1.12.23/image_view/CMakeLists.txt 2019-07-03 17:02:21.775288064 +0000
@@ -5,7 +5,7 @@
generate_dynamic_reconfigure_options(cfg/ImageView.cfg)
catkin_package(CATKIN_DEPENDS dynamic_reconfigure)
-find_package(Boost REQUIRED COMPONENTS signals thread)
+find_package(Boost REQUIRED COMPONENTS thread)
find_package(OpenCV REQUIRED)
include_directories(${Boost_INCLUDE_DIRS}

View File

@ -9,3 +9,5 @@ require image-pipeline.inc
inherit distro_features_check
ANY_OF_DISTRO_FEATURES = "${GTK2DISTROFEATURES}"
SRC_URI += "file://image-view-remove-unused-signals-boost-component.patch;patchdir=.."