Merge pull request #634 from shr-project/jansa/thud
Various simple fixes
This commit is contained in:
commit
f1a2de5a19
|
@ -13,6 +13,6 @@ LICENSE_PATH += "${LAYERDIR}/licenses"
|
|||
# Version 1 is the manually created meta-ros, prior to the introduction of superflore.
|
||||
LAYERVERSION_ros-layer = "1"
|
||||
|
||||
LAYERSERIES_COMPAT_ros-layer = "rocko sumo thud"
|
||||
LAYERSERIES_COMPAT_ros-layer = "rocko sumo thud warrior"
|
||||
|
||||
ROSDISTRO := "indigo"
|
||||
|
|
|
@ -1,12 +1,12 @@
|
|||
inherit pypi
|
||||
PYPI_PACKAGE = "pyproj"
|
||||
|
||||
DESCRIPTION = "Python interface to PROJ.4 library"
|
||||
SECTION = "devel/python"
|
||||
LICENSE = "ISC & MIT"
|
||||
LIC_FILES_CHKSUM = "file://LICENSE;md5=77d9726a341183ab262b28b3d66dfd94 \
|
||||
file://LICENSE_proj4;md5=74d9aaec5fa0cd734341e8c4dc91b608"
|
||||
SRCNAME = "pyproj"
|
||||
file://LICENSE_proj4;md5=74d9aaec5fa0cd734341e8c4dc91b608 \
|
||||
"
|
||||
|
||||
SRC_URI = "http://pypi.python.org/packages/source/p/pyproj/pyproj-${PV}.tar.gz"
|
||||
SRC_URI[md5sum] = "027345e3c033fa400e0e64a1c80d34c9"
|
||||
SRC_URI[sha256sum] = "53fa54c8fa8a1dfcd6af4bf09ce1aae5d4d949da63b90570ac5ec849efaf3ea8"
|
||||
|
||||
S = "${WORKDIR}/${SRCNAME}-${PV}"
|
||||
SRC_URI[md5sum] = "0f02376d59f796108e6e36db42f773c8"
|
||||
SRC_URI[sha256sum] = "e0c02b1554b20c710d16d673817b2a89ff94738b0b537aead8ecb2edc4c4487b"
|
||||
|
|
|
@ -13,3 +13,7 @@ S = "${WORKDIR}/${SRCNAME}-${PV}"
|
|||
RDEPENDS_${PN} += "python-vcstools python-pyyaml python-rosinstall"
|
||||
|
||||
inherit setuptools
|
||||
|
||||
PACKAGES =+ "${PN}-zsh-completion"
|
||||
FILES_${PN}-zsh-completion += "${datadir}/zsh/"
|
||||
RDEPENDS_${PN}-zsh-completion += "zsh"
|
||||
|
|
|
@ -28,3 +28,5 @@ FILES_gstreamer0.10-${PN} += "${libdir}/gstreamer-0.10/libgstpocketsphinx.so"
|
|||
FILES_gstreamer0.10-${PN}-staticdev += "${libdir}/gstreamer-0.10/libgstpocketsphinx.a \
|
||||
${libdir}/gstreamer-0.10/libgstpocketsphinx.la"
|
||||
FILES_gstreamer0.10-${PN}-dbg += "${libdir}/gstreamer-0.10/.debug"
|
||||
|
||||
PNBLACKLIST[pocketsphinx] ?= "Depends on old gstreamer 0.10 recipes removed from meta-oe in 2.7 Warrior"
|
||||
|
|
|
@ -7,12 +7,12 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=929d21c5ebf729ca3fa206e0b64ff0c7"
|
|||
|
||||
DEPENDS = "speech-tools"
|
||||
|
||||
SRC_URI = "http://www.cstr.ed.ac.uk/downloads/${PN}/${PV}/${PN}-${PV}-release.tar.gz;name=festival \
|
||||
http://www.cstr.ed.ac.uk/downloads/${PN}/${PV}/festlex_CMU.tar.gz;name=CMU \
|
||||
http://www.cstr.ed.ac.uk/downloads/${PN}/${PV}/festlex_OALD.tar.gz;name=OALD \
|
||||
http://www.cstr.ed.ac.uk/downloads/${PN}/${PV}/festlex_POSLEX.tar.gz;name=POSLEX \
|
||||
http://www.cstr.ed.ac.uk/downloads/${PN}/${PV}/voices/festvox_kallpc16k.tar.gz;name=kallpc16k \
|
||||
http://www.cstr.ed.ac.uk/downloads/${PN}/${PV}/voices/festvox_rablpc16k.tar.gz;name=rablpc16k \
|
||||
SRC_URI = "http://www.cstr.ed.ac.uk/downloads/${BPN}/${PV}/${BP}-release.tar.gz;name=festival \
|
||||
http://www.cstr.ed.ac.uk/downloads/${BPN}/${PV}/festlex_CMU.tar.gz;name=CMU \
|
||||
http://www.cstr.ed.ac.uk/downloads/${BPN}/${PV}/festlex_OALD.tar.gz;name=OALD \
|
||||
http://www.cstr.ed.ac.uk/downloads/${BPN}/${PV}/festlex_POSLEX.tar.gz;name=POSLEX \
|
||||
http://www.cstr.ed.ac.uk/downloads/${BPN}/${PV}/voices/festvox_kallpc16k.tar.gz;name=kallpc16k \
|
||||
http://www.cstr.ed.ac.uk/downloads/${BPN}/${PV}/voices/festvox_rablpc16k.tar.gz;name=rablpc16k \
|
||||
"
|
||||
SRC_URI[festival.md5sum] = "49707d2f6744d5a67f81a96c36f7cb59"
|
||||
SRC_URI[festival.sha256sum] = "1e47f293e0857ffde2bccead97947c040ea0b35ea12dd5796edb51583e5e5d84"
|
||||
|
@ -27,13 +27,15 @@ SRC_URI[kallpc16k.sha256sum] = "7a357c34086fbba8b813f9750f6b5ba13e2a00478a0a2e78
|
|||
SRC_URI[rablpc16k.md5sum] = "34cb2478f5b8fa1ed02f5cbb496c1dcd"
|
||||
SRC_URI[rablpc16k.sha256sum] = "a017ef70f6d3e64d51d3772ab438eb47a26b529b456dae3cea18936925ec20e8"
|
||||
|
||||
S = "${WORKDIR}/${PN}"
|
||||
S = "${WORKDIR}/${BPN}"
|
||||
|
||||
inherit autotools-brokensep
|
||||
|
||||
#disable parallel make (make -j), as festival cannot handle that
|
||||
PARALLEL_MAKE = ""
|
||||
|
||||
EXTRA_OEMAKE = "CC='${CC}' CXX='${CXX} ${LDFLAGS}'"
|
||||
|
||||
do_configure_prepend() {
|
||||
#point to speech-tools in sysroots
|
||||
sed -i 's:EST=$(TOP)/../speech_tools:EST=${STAGING_DIR_TARGET}${datadir}/speech-tools:g' ${S}/config/config.in
|
||||
|
@ -77,6 +79,6 @@ do_install() {
|
|||
install -m 0755 -d ${D}${datadir}/festival/multisyn
|
||||
install -m 0644 ${S}/lib/multisyn/*scm ${D}${datadir}/festival/multisyn
|
||||
|
||||
cp -a ${S}/lib/dicts ${D}${datadir}/festival
|
||||
cp -a ${S}/lib/voices ${D}${datadir}/festival
|
||||
cp -R --no-dereference --preserve=mode,links -v ${S}/lib/dicts ${D}${datadir}/festival
|
||||
cp -R --no-dereference --preserve=mode,links -v ${S}/lib/voices ${D}${datadir}/festival
|
||||
}
|
||||
|
|
|
@ -10,4 +10,7 @@ SRC_URI[sha256sum] = "dde46626a62a1cd9cf48a11951cdd592e7067c345cffe193a149dfd47a
|
|||
|
||||
S = "${WORKDIR}/freeglut-${PV}"
|
||||
|
||||
inherit autotools
|
||||
inherit autotools distro_features_check
|
||||
|
||||
# Depends on libxi libglu which need x11 in DISTRO_FEATURES
|
||||
REQUIRED_DISTRO_FEATURES = "x11"
|
||||
|
|
|
@ -12,3 +12,8 @@ SRC_URI[sha256sum] = "7203d56123b6f6fb31842295d57b2418f79fb0db9a06f2f65ee9e415c6
|
|||
S = "${WORKDIR}/GeographicLib-${PV}"
|
||||
|
||||
inherit cmake
|
||||
|
||||
PACKAGES =+ "${PN}-python ${PN}-node ${PN}-matlab"
|
||||
FILES_${PN}-python += "${libdir}/python/"
|
||||
FILES_${PN}-node += "${libdir}/node_modules/"
|
||||
FILES_${PN}-matlab += "${datadir}/matlab/"
|
||||
|
|
|
@ -8,7 +8,10 @@ SRC_URI = "https://github.com/OpenKinect/libfreenect/archive/v${PV}.tar.gz;downl
|
|||
SRC_URI[md5sum] = "4d683cffe79f741aeb777cacaa88fd44"
|
||||
SRC_URI[sha256sum] = "91af5c09b7eae217c4be69234ae5a6371f24da8ff6986f98c2db19f1993f2a71"
|
||||
|
||||
inherit cmake
|
||||
inherit cmake distro_features_check
|
||||
|
||||
# Depends on freeglut libxi libxmu which need x11 in DISTRO_FEATURES
|
||||
REQUIRED_DISTRO_FEATURES = "x11"
|
||||
|
||||
#force libs always into /usr/lib, even when compiling on 64bit arch
|
||||
EXTRA_OECMAKE += " -DLIB_SUFFIX=''"
|
||||
|
|
|
@ -1,46 +0,0 @@
|
|||
From a0b3ce9ca5c69a945695c1c83dab7937a3d99b83 Mon Sep 17 00:00:00 2001
|
||||
From: Jochen Sprickerhof <git@jochen.sprickerhof.de>
|
||||
Date: Sat, 5 May 2018 23:58:13 +0200
|
||||
Subject: [PATCH] Dereference shared_ptr, fix for GCC8
|
||||
|
||||
Upstream-Status: Accepted [https://github.com/PointCloudLibrary/pcl/commit/a0b3ce9ca5c69a945695c1c83dab7937a3d99b83]
|
||||
|
||||
This patch has been generated with:
|
||||
`git format-patch -1 a0b3ce9ca5c69a945695c1c83dab7937a3d99b83`
|
||||
in the pcl repository.
|
||||
|
||||
Signed-off-by: Lukas Bulwahn <lukas.bulwahn@gmail.com>
|
||||
---
|
||||
segmentation/include/pcl/segmentation/ground_plane_comparator.h | 2 +-
|
||||
segmentation/include/pcl/segmentation/plane_coefficient_comparator.h | 2 +-
|
||||
2 files changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/segmentation/include/pcl/segmentation/ground_plane_comparator.h b/segmentation/include/pcl/segmentation/ground_plane_comparator.h
|
||||
index e39354d..f96f38b 100644
|
||||
--- a/segmentation/include/pcl/segmentation/ground_plane_comparator.h
|
||||
+++ b/segmentation/include/pcl/segmentation/ground_plane_comparator.h
|
||||
@@ -147,7 +147,7 @@ namespace pcl
|
||||
const std::vector<float>&
|
||||
getPlaneCoeffD () const
|
||||
{
|
||||
- return (plane_coeff_d_);
|
||||
+ return (*plane_coeff_d_);
|
||||
}
|
||||
|
||||
/** \brief Set the tolerance in radians for difference in normal direction between neighboring points, to be considered part of the same plane.
|
||||
diff --git a/segmentation/include/pcl/segmentation/plane_coefficient_comparator.h b/segmentation/include/pcl/segmentation/plane_coefficient_comparator.h
|
||||
index 9c94813..a21725a 100644
|
||||
--- a/segmentation/include/pcl/segmentation/plane_coefficient_comparator.h
|
||||
+++ b/segmentation/include/pcl/segmentation/plane_coefficient_comparator.h
|
||||
@@ -141,7 +141,7 @@ namespace pcl
|
||||
const std::vector<float>&
|
||||
getPlaneCoeffD () const
|
||||
{
|
||||
- return (plane_coeff_d_);
|
||||
+ return (*plane_coeff_d_);
|
||||
}
|
||||
|
||||
/** \brief Set the tolerance in radians for difference in normal direction between neighboring points, to be considered part of the same plane.
|
||||
--
|
||||
2.7.4
|
||||
|
|
@ -1,4 +1,4 @@
|
|||
From 19361abfa1bf21bc9be911f6ffa97f1c43174d8d Mon Sep 17 00:00:00 2001
|
||||
From 31f72094a309ef6845e5c6b0b989237b4b59973f Mon Sep 17 00:00:00 2001
|
||||
From: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
|
||||
Date: Tue, 27 Sep 2016 14:05:22 +0200
|
||||
Subject: [PATCH] make the pcl library compile with gcc6
|
||||
|
@ -58,23 +58,23 @@ Signed-off-by: Lukas Bulwahn <lukas.bulwahn@gmail.com>
|
|||
6 files changed, 6 insertions(+), 6 deletions(-)
|
||||
|
||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||
index e5fd763..c658df5 100644
|
||||
index 0b4c1a33d..95e1d31e8 100644
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -272,7 +272,7 @@ endif()
|
||||
@@ -277,7 +277,7 @@ endif()
|
||||
|
||||
# Eigen (required)
|
||||
find_package(Eigen REQUIRED)
|
||||
-include_directories(SYSTEM ${EIGEN_INCLUDE_DIRS})
|
||||
+include_directories(${EIGEN_INCLUDE_DIRS})
|
||||
add_definitions(-DEIGEN_USE_NEW_STDVECTOR
|
||||
-DEIGEN_YES_I_KNOW_SPARSE_MODULE_IS_NOT_STABLE_YET)
|
||||
|
||||
# FLANN (required)
|
||||
if(NOT PCL_SHARED_LIBS OR ((WIN32 AND NOT MINGW) AND NOT PCL_BUILD_WITH_FLANN_DYNAMIC_LINKING_WIN32))
|
||||
diff --git a/cmake/Modules/FindOpenNI.cmake b/cmake/Modules/FindOpenNI.cmake
|
||||
index 9f772a4..bd36f3e 100644
|
||||
index 2c7b26eea..1e62c359b 100644
|
||||
--- a/cmake/Modules/FindOpenNI.cmake
|
||||
+++ b/cmake/Modules/FindOpenNI.cmake
|
||||
@@ -30,7 +30,7 @@ if(NOT WIN32)
|
||||
@@ -31,7 +31,7 @@ if(NOT WIN32)
|
||||
message(STATUS "OpenNI disabled because libusb-1.0 not found.")
|
||||
return()
|
||||
else()
|
||||
|
@ -84,10 +84,10 @@ index 9f772a4..bd36f3e 100644
|
|||
endif(NOT WIN32)
|
||||
|
||||
diff --git a/cmake/Modules/FindOpenNI2.cmake b/cmake/Modules/FindOpenNI2.cmake
|
||||
index 713099a..8226895 100644
|
||||
index 037a9a399..cc1855e0f 100644
|
||||
--- a/cmake/Modules/FindOpenNI2.cmake
|
||||
+++ b/cmake/Modules/FindOpenNI2.cmake
|
||||
@@ -30,7 +30,7 @@ if(NOT WIN32)
|
||||
@@ -31,7 +31,7 @@ if(NOT WIN32)
|
||||
message(STATUS "OpenNI 2 disabled because libusb-1.0 not found.")
|
||||
return()
|
||||
else()
|
||||
|
@ -97,10 +97,10 @@ index 713099a..8226895 100644
|
|||
endif(NOT WIN32)
|
||||
|
||||
diff --git a/cmake/pcl_find_boost.cmake b/cmake/pcl_find_boost.cmake
|
||||
index a3abe1c..c57b87d 100644
|
||||
index 6489f3954..0c170116d 100644
|
||||
--- a/cmake/pcl_find_boost.cmake
|
||||
+++ b/cmake/pcl_find_boost.cmake
|
||||
@@ -48,6 +48,6 @@ if(Boost_FOUND)
|
||||
@@ -49,6 +49,6 @@ if(Boost_FOUND)
|
||||
# Obtain diagnostic information about Boost's automatic linking outputted
|
||||
# during compilation time.
|
||||
add_definitions(${Boost_LIB_DIAGNOSTIC_DEFINITIONS})
|
||||
|
@ -109,11 +109,11 @@ index a3abe1c..c57b87d 100644
|
|||
link_directories(${Boost_LIBRARY_DIRS})
|
||||
endif(Boost_FOUND)
|
||||
diff --git a/cmake/pcl_targets.cmake b/cmake/pcl_targets.cmake
|
||||
index 691ead0..f730743 100644
|
||||
index 30696346f..bede67ffa 100644
|
||||
--- a/cmake/pcl_targets.cmake
|
||||
+++ b/cmake/pcl_targets.cmake
|
||||
@@ -858,7 +858,7 @@ macro(PCL_ADD_GRABBER_DEPENDENCY _name _description)
|
||||
message(WARNING "${_description}: not building because ${_name} not found")
|
||||
@@ -864,7 +864,7 @@ macro(PCL_ADD_GRABBER_DEPENDENCY _name _description)
|
||||
message(STATUS "${_description}: not building because ${_name} not found")
|
||||
else()
|
||||
set(HAVE_${_name_capitalized} TRUE)
|
||||
- include_directories(SYSTEM "${${_name_capitalized}_INCLUDE_DIRS}")
|
||||
|
@ -122,10 +122,10 @@ index 691ead0..f730743 100644
|
|||
endif()
|
||||
endmacro(PCL_ADD_GRABBER_DEPENDENCY)
|
||||
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
|
||||
index 3b3e2d7..342cb62 100644
|
||||
index 6a1d55d96..543c279ef 100644
|
||||
--- a/test/CMakeLists.txt
|
||||
+++ b/test/CMakeLists.txt
|
||||
@@ -17,7 +17,7 @@ PCL_SUBSYS_DEPEND(build "${SUBSYS_NAME}" DEPS ${SUBSYS_DEPS} OPT_DEPS ${OPT_DEPS
|
||||
@@ -9,7 +9,7 @@ PCL_SUBSYS_DEPEND(build "${SUBSYS_NAME}" DEPS ${SUBSYS_DEPS} OPT_DEPS ${OPT_DEPS
|
||||
if(build)
|
||||
|
||||
find_package(Gtest REQUIRED)
|
||||
|
@ -134,6 +134,3 @@ index 3b3e2d7..342cb62 100644
|
|||
|
||||
add_library(pcl_gtest STATIC ${GTEST_SRC_DIR}/src/gtest-all.cc)
|
||||
|
||||
--
|
||||
2.5.5
|
||||
|
||||
|
|
|
@ -5,14 +5,13 @@ LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=5b8a2a1aa14e6de44b4273134946a34c"
|
|||
|
||||
DEPENDS = "boost libflann libeigen qhull"
|
||||
|
||||
SRC_URI = "https://github.com/PointCloudLibrary/${PN}/archive/${P}.tar.gz"
|
||||
SRC_URI[md5sum] = "8c1308be2c13106e237e4a4204a32cca"
|
||||
SRC_URI[sha256sum] = "9e54b0c1b59a67a386b9b0f4acb2d764272ff9a0377b825c4ed5eedf46ebfcf4"
|
||||
PV = "1.9.1+git${SRCPV}"
|
||||
SRCREV = "72f41b60a539cd1da67d1329b57222290122a0bb"
|
||||
SRC_URI = "git://github.com/PointCloudLibrary/pcl.git \
|
||||
file://0001-make-the-pcl-library-compile-with-gcc6.patch \
|
||||
"
|
||||
|
||||
SRC_URI += "file://0001-make-the-pcl-library-compile-with-gcc6.patch"
|
||||
SRC_URI += "file://0001-Dereference-shared_ptr-fix-for-GCC8.patch"
|
||||
|
||||
S = "${WORKDIR}/pcl-${P}"
|
||||
S = "${WORKDIR}/git"
|
||||
|
||||
EXTRA_OECMAKE += "\
|
||||
-DCMAKE_SKIP_RPATH=ON \
|
||||
|
@ -39,9 +38,15 @@ CXXFLAGS += "${@bb.utils.contains("TARGET_CC_ARCH", "-mfpmath=sse", "", "-ffloat
|
|||
|
||||
inherit cmake
|
||||
|
||||
FILES_${PN}-dev += "${datadir}/${PN}-1.8/*.cmake"
|
||||
FILES_${PN}-dev += "${datadir}/${PN}-1.9/*.cmake ${datadir}/${PN}-1.9/Modules/*.cmake"
|
||||
|
||||
# The build is really memory hungry (at least with gcc8), even with just -j 8 it triggers OOMK on system with 32GB ram
|
||||
# High memory needs mentioned in: https://github.com/PointCloudLibrary/pcl/issues/2284
|
||||
# Setting just empty doesn't work, ninja will by default use number of cores available
|
||||
PARALLEL_MAKE = "-j1"
|
||||
PARALLEL_MAKE = "-j4"
|
||||
|
||||
# Disable thumb for armv[45] to resolve
|
||||
# pcl/1.9.1+gitAUTOINC+72f41b60a5-r0/git/features/include/pcl/features/impl/pfh.hpp:129: error: relocation overflow in R_ARM_THM_CALL
|
||||
# http://caprica.lgsvl.com:8080/Errors/Details/1510736
|
||||
ARM_INSTRUCTION_SET_armv4 = "arm"
|
||||
ARM_INSTRUCTION_SET_armv5 = "arm"
|
|
@ -13,6 +13,8 @@ SRC_URI[sha256sum] = "18e2d3e847b3b1158c124b6167ea2751236a2749aca03532ca7d9f5b7b
|
|||
|
||||
S = "${WORKDIR}/realsense-${PV}/realsense_camera"
|
||||
|
||||
inherit catkin
|
||||
inherit catkin distro_features_check
|
||||
|
||||
REQUIRED_DISTRO_FEATURES = "ros-realsense"
|
||||
|
||||
EXTRA_OECMAKE = "-DUSE_SYSTEM_LIBREALSENSE:BOOL=ON"
|
||||
|
|
|
@ -14,10 +14,11 @@ inherit autotools-brokensep
|
|||
|
||||
PARALLEL_MAKE = ""
|
||||
|
||||
do_configure_prepend() {
|
||||
#force crosscompilation compiler
|
||||
sed -i 's:CC=gcc:CC=${CC}:g' ${S}/config/compilers/gcc_defaults.mak
|
||||
sed -i 's:CXX=gcc:CXX=${CC}:g' ${S}/config/compilers/gcc_defaults.mak
|
||||
EXTRA_OEMAKE = "CC='${CC}' CXX='${CXX} ${LDFLAGS}'"
|
||||
|
||||
do_configure_prepend() {
|
||||
# respect CC and CXX from EXTRA_OEMAKE
|
||||
sed -i '/^CC=gcc/d; /^CXX=gcc$/d' ${S}/config/compilers/gcc_defaults.mak
|
||||
}
|
||||
|
||||
do_install() {
|
||||
|
@ -34,10 +35,10 @@ SYSROOT_PREPROCESS_FUNCS += "speechtools_sysroot_preprocess"
|
|||
|
||||
#stage speech_tools directories for usage by festival
|
||||
speechtools_sysroot_preprocess() {
|
||||
sysroot_stage_dir ${WORKDIR}/speech_tools/config ${SYSROOT_DESTDIR}${datadir}/${PN}/config
|
||||
sysroot_stage_dir ${WORKDIR}/speech_tools/include ${SYSROOT_DESTDIR}${datadir}/${PN}/include
|
||||
sysroot_stage_dir ${WORKDIR}/speech_tools/base_class ${SYSROOT_DESTDIR}${datadir}/${PN}/base_class
|
||||
sysroot_stage_dir ${WORKDIR}/speech_tools/lib ${SYSROOT_DESTDIR}${datadir}/${PN}/lib
|
||||
sysroot_stage_dir ${S}/config ${SYSROOT_DESTDIR}${datadir}/${PN}/config
|
||||
sysroot_stage_dir ${S}/include ${SYSROOT_DESTDIR}${datadir}/${PN}/include
|
||||
sysroot_stage_dir ${S}/base_class ${SYSROOT_DESTDIR}${datadir}/${PN}/base_class
|
||||
sysroot_stage_dir ${S}/lib ${SYSROOT_DESTDIR}${datadir}/${PN}/lib
|
||||
}
|
||||
|
||||
RDEPENDS_${PN} += "perl"
|
||||
|
|
|
@ -12,7 +12,10 @@ SRC_URI[sha256sum] = "1a5b7e771eff467538d0834136188e8a7506a4fe6e85d0a46c40158cdb
|
|||
|
||||
S = "${WORKDIR}/wxPython-src-${PV}/wxPython"
|
||||
|
||||
inherit pkgconfig pythonnative python-dir distutils
|
||||
inherit pkgconfig pythonnative python-dir distutils distro_features_check
|
||||
|
||||
# Depends on wxwidgets which depends on libxinerama, libglu, gtk need x11 in DISTRO_FEATURES
|
||||
REQUIRED_DISTRO_FEATURES = "x11"
|
||||
|
||||
CFLAGS += "-I${STAGING_INCDIR}/wx-2.9/ -I${STAGING_LIBDIR}/wx/include/${TARGET_PREFIX}gtk2-unicode-2.9/"
|
||||
CFLAGS += "-std=gnu++11"
|
||||
|
@ -31,3 +34,5 @@ do_iinstall_append() {
|
|||
cp -a ${D}${STAGING_DIR_HOST}/* ${D}
|
||||
rm -rf ${D}${STAGING_DIR}
|
||||
}
|
||||
|
||||
PNBLACKLIST[wxpython] ?= "Depends on wxwidgets which depends on old gstreamer 0.10 recipes removed from meta-oe in 2.7 Warrior"
|
||||
|
|
|
@ -4,7 +4,7 @@ HOMEPAGE = "http://www.wxwidgets.org"
|
|||
LICENSE = "WXwindows"
|
||||
LIC_FILES_CHKSUM = "file://docs/licence.txt;md5=18346072db6eb834b6edbd2cdc4f109b"
|
||||
|
||||
DEPENDS = "webkit-gtk gstreamer gtk+ jpeg tiff libpng zlib expat libxinerama libglu"
|
||||
DEPENDS = "webkitgtk gstreamer gtk+ jpeg tiff libpng zlib expat libxinerama libglu"
|
||||
|
||||
SRC_URI = "${SOURCEFORGE_MIRROR}/wxwindows/wxWidgets-${PV}.tar.bz2"
|
||||
SRC_URI[md5sum] = "e98c5f92805493f150656403ffef3bb0"
|
||||
|
@ -12,7 +12,10 @@ SRC_URI[sha256sum] = "b74ba96ca537cc5d049d21ec9ab5eb2670406a4aa9f1ea4845ea84a995
|
|||
|
||||
S = "${WORKDIR}/wxWidgets-${PV}"
|
||||
|
||||
inherit autotools-brokensep pkgconfig binconfig
|
||||
inherit autotools-brokensep pkgconfig binconfig distro_features_check
|
||||
|
||||
# Depends on libxinerama, libglu, gtk need x11 in DISTRO_FEATURES
|
||||
REQUIRED_DISTRO_FEATURES = "x11"
|
||||
|
||||
EXTRA_AUTORECONF = " -I ${S}/build/aclocal"
|
||||
EXTRA_OECONF = " --with-opengl \
|
||||
|
@ -53,3 +56,5 @@ wxwidgets_sysroot_preprocess () {
|
|||
|
||||
FILES_${PN} += "${bindir} ${libdir}/wx/config"
|
||||
FILES_${PN}-dev += "${libdir}/wx/include ${datadir}/bakefile"
|
||||
|
||||
PNBLACKLIST[wxwidgets] ?= "Depends on old gstreamer 0.10 recipes removed from meta-oe in 2.7 Warrior"
|
||||
|
|
|
@ -0,0 +1,31 @@
|
|||
add missing include
|
||||
|
||||
* CV_RGB is defined in opencv2/imgproc.hpp
|
||||
* fixes:
|
||||
ar-track-alvar/0.6.1-r0/ar_track_alvar-0.6.1/src/Marker.cpp: In member function 'virtual void alvar::MarkerData::VisualizeMarkerContent(IplImage*, alvar::Camera*, double*, double*) const':
|
||||
ar-track-alvar/0.6.1-r0/ar_track_alvar-0.6.1/src/Marker.cpp:123:15: error: 'CV_RGB' was not declared in this scope
|
||||
CvScalar rgb=CV_RGB(255,255,0);
|
||||
^~~~~~
|
||||
|
||||
Upstream-Status: Pending
|
||||
|
||||
--- a/include/ar_track_alvar/Draw.h 2019-07-03 16:28:16.540970593 +0000
|
||||
+++ b/include/ar_track_alvar/Draw.h 2019-07-03 16:19:45.113388531 +0000
|
||||
@@ -36,6 +36,7 @@
|
||||
#include "Camera.h"
|
||||
#include "Line.h"
|
||||
#include <sstream>
|
||||
+#include <opencv2/imgproc.hpp>
|
||||
|
||||
namespace alvar {
|
||||
|
||||
--- a/include/ar_track_alvar/Marker.h 2019-07-03 16:24:35.995976014 +0000
|
||||
+++ b/include/ar_track_alvar/Marker.h 2019-07-03 16:24:52.396347425 +0000
|
||||
@@ -41,6 +41,7 @@
|
||||
#include <vector>
|
||||
#include "filter/kinect_filtering.h"
|
||||
#include <Eigen/StdVector>
|
||||
+#include <opencv2/imgproc.hpp>
|
||||
|
||||
namespace alvar {
|
||||
|
|
@ -12,3 +12,5 @@ SRC_URI[sha256sum] = "c34ff4358fb167edccc4357d74425e3370691f04be1f8971f5258aa25d
|
|||
S = "${WORKDIR}/${ROS_SP}"
|
||||
|
||||
inherit catkin
|
||||
|
||||
SRC_URI += "file://fix.missing.include.patch"
|
||||
|
|
|
@ -14,3 +14,5 @@ require audio-common.inc
|
|||
SRC_URI += "file://0002-sound_play-Fix-build-with-DCATKIN_ENABLE_TESTING-OFF.patch;striplevel=2"
|
||||
|
||||
RRECOMMENDS_${PN} += "roscpp roslib audio-common-msgs diagnostic-msgs gst-plugins-base gst-plugins-ugly gst-plugins-good rospy festival python-gst gst-meta-audio"
|
||||
|
||||
PNBLACKLIST[sound-play] ?= "Depends on old gstreamer 0.10 recipes removed from meta-oe in 2.7 Warrior"
|
||||
|
|
|
@ -1,6 +1,8 @@
|
|||
require catkin.inc
|
||||
|
||||
SRC_URI += "file://environment.d-catkin.sh"
|
||||
SRC_URI += "file://environment.d-catkin.sh \
|
||||
file://0001-strip-l-from-lpthread-library-to-fix-a-build-failure.patch \
|
||||
"
|
||||
|
||||
DEPENDS_class-native += "catkin-runtime"
|
||||
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
From e6179255b99264a51f8733f52d92ca579fbacb61 Mon Sep 17 00:00:00 2001
|
||||
From 5de0fe25ec27bca4c593e06cdc0c3dff3d553e06 Mon Sep 17 00:00:00 2001
|
||||
From: Lukas Bulwahn <lukas.bulwahn@gmail.com>
|
||||
Date: Sun, 15 Apr 2018 02:11:42 +0200
|
||||
Subject: [PATCH] allow proper cross-compilation with catkin
|
||||
|
@ -17,11 +17,12 @@ Some of the context lines in patches were ignored. This can lead to incorrectly
|
|||
Upstream-Status: Pending
|
||||
|
||||
Signed-off-by: Lukas Bulwahn <lukas.bulwahn@gmail.com>
|
||||
|
||||
---
|
||||
cmake/all.cmake | 1 +
|
||||
cmake/catkin_package.cmake | 8 ++++++++
|
||||
cmake/catkin_strip_root_path.cmake | 32 +++++++++++++++++++++++++++++
|
||||
cmake/templates/pkgConfig.cmake.in | 42 ++++++++++++++++++++++++++++++++++----
|
||||
cmake/catkin_package.cmake | 8 ++++++
|
||||
cmake/catkin_strip_root_path.cmake | 32 +++++++++++++++++++++++
|
||||
cmake/templates/pkgConfig.cmake.in | 42 +++++++++++++++++++++++++++---
|
||||
4 files changed, 79 insertions(+), 4 deletions(-)
|
||||
create mode 100644 cmake/catkin_strip_root_path.cmake
|
||||
|
||||
|
@ -170,6 +171,3 @@ index d99b811..3af5c71 100644
|
|||
break()
|
||||
endif()
|
||||
endforeach()
|
||||
--
|
||||
2.7.4
|
||||
|
||||
|
|
|
@ -0,0 +1,26 @@
|
|||
From e19e2085e1aa58456ed94c529536df387e0ab340 Mon Sep 17 00:00:00 2001
|
||||
From: Jochen Sprickerhof <github@jochen.sprickerhof.de>
|
||||
Date: Sat, 26 Jan 2019 07:36:24 +0100
|
||||
Subject: [PATCH] strip "-l" from "-lpthread" library, to fix a build failure
|
||||
|
||||
on ros-ros-comm (#975)
|
||||
|
||||
Upstream-Status: Backport from 0.17.15 [https://github.com/ros/catkin/commit/98f97ffcffbb7127d4a8aff0fcb26d1578557906]
|
||||
|
||||
---
|
||||
cmake/templates/pkgConfig.cmake.in | 2 ++
|
||||
1 file changed, 2 insertions(+)
|
||||
|
||||
diff --git a/cmake/templates/pkgConfig.cmake.in b/cmake/templates/pkgConfig.cmake.in
|
||||
index 3af5c71..8bc8979 100644
|
||||
--- a/cmake/templates/pkgConfig.cmake.in
|
||||
+++ b/cmake/templates/pkgConfig.cmake.in
|
||||
@@ -135,6 +135,8 @@ foreach(library ${libraries})
|
||||
# keep build configuration keywords, target names and absolute libraries as-is
|
||||
if("${library}" MATCHES "^(debug|optimized|general)$")
|
||||
list(APPEND @PROJECT_NAME@_LIBRARIES ${library})
|
||||
+ elseif(${library} MATCHES "^-l")
|
||||
+ list(APPEND @PROJECT_NAME@_LIBRARIES ${library})
|
||||
elseif(TARGET ${library})
|
||||
list(APPEND @PROJECT_NAME@_LIBRARIES ${library})
|
||||
elseif(IS_ABSOLUTE ${library} AND CMAKE_CROSSCOMPILING)
|
|
@ -1,4 +1,4 @@
|
|||
From 7894487c0d749124c3b0d82fcebff2309a84024a Mon Sep 17 00:00:00 2001
|
||||
From 23972aa72e7364f6fd69cdd102274fc2a29fb395 Mon Sep 17 00:00:00 2001
|
||||
From: Lukas Bulwahn <lukas.bulwahn@bmw-carit.de>
|
||||
Date: Tue, 31 May 2016 15:38:05 +0200
|
||||
Subject: [PATCH] use python provided by environment instead of the generated
|
||||
|
|
|
@ -8,3 +8,8 @@ DEPENDS = "camera-info-manager diagnostic-updater dynamic-reconfigure \
|
|||
image-transport libfreenect nodelet roscpp sensor-msgs pluginlib"
|
||||
|
||||
require freenect-stack.inc
|
||||
|
||||
inherit distro_features_check
|
||||
|
||||
# Depends on libfreenect which depends on freeglut libxi libxmu which need x11 in DISTRO_FEATURES
|
||||
REQUIRED_DISTRO_FEATURES = "x11"
|
||||
|
|
|
@ -8,3 +8,8 @@ LIC_FILES_CHKSUM = "file://package.xml;beginline=14;endline=14;md5=d566ef916e9de
|
|||
require freenect-stack.inc
|
||||
|
||||
RRECOMMENDS_${PN} = "freenect-camera image-proc nodelet rgbd-launch tf"
|
||||
|
||||
inherit distro_features_check
|
||||
|
||||
# Depends on freenect-camera which depends on libfreenect which depends on freeglut libxi libxmu which need x11 in DISTRO_FEATURES
|
||||
REQUIRED_DISTRO_FEATURES = "x11"
|
||||
|
|
|
@ -11,3 +11,5 @@ SRC_URI[md5sum] = "b0512882e06f5cdd4c6015f16dceb346"
|
|||
SRC_URI[sha256sum] = "84d02ed9a0bed769bebddfb67d27085ae779aaf9ab1311aaad94e9d17aa0fbc6"
|
||||
|
||||
inherit catkin
|
||||
|
||||
PNBLACKLIST[gscam] ?= "Depends on old gstreamer 0.10 recipes removed from meta-oe in 2.7 Warrior"
|
||||
|
|
|
@ -0,0 +1,14 @@
|
|||
Upstream-Status: Pending
|
||||
|
||||
diff -uNr image_pipeline-1.12.23.orig/image_view/CMakeLists.txt image_pipeline-1.12.23/image_view/CMakeLists.txt
|
||||
--- image_pipeline-1.12.23.orig/image_view/CMakeLists.txt 2018-05-10 12:52:54.000000000 +0000
|
||||
+++ image_pipeline-1.12.23/image_view/CMakeLists.txt 2019-07-03 17:02:21.775288064 +0000
|
||||
@@ -5,7 +5,7 @@
|
||||
generate_dynamic_reconfigure_options(cfg/ImageView.cfg)
|
||||
|
||||
catkin_package(CATKIN_DEPENDS dynamic_reconfigure)
|
||||
-find_package(Boost REQUIRED COMPONENTS signals thread)
|
||||
+find_package(Boost REQUIRED COMPONENTS thread)
|
||||
find_package(OpenCV REQUIRED)
|
||||
|
||||
include_directories(${Boost_INCLUDE_DIRS}
|
|
@ -3,6 +3,11 @@ SECTION = "devel"
|
|||
LICENSE = "BSD"
|
||||
LIC_FILES_CHKSUM = "file://package.xml;beginline=10;endline=10;md5=d566ef916e9dedc494f5f793a6690ba5"
|
||||
|
||||
DEPENDS = "camera-calibration-parsers cv-bridge dynamic-reconfigure image-transport message-filters nodelet opencv rosconsole roscpp sensor-msgs std-srvs stereo-msgs"
|
||||
DEPENDS = "camera-calibration-parsers cv-bridge dynamic-reconfigure image-transport message-filters nodelet opencv rosconsole roscpp sensor-msgs std-srvs stereo-msgs gtk+"
|
||||
|
||||
require image-pipeline.inc
|
||||
|
||||
inherit distro_features_check
|
||||
ANY_OF_DISTRO_FEATURES = "${GTK2DISTROFEATURES}"
|
||||
|
||||
SRC_URI += "file://image-view-remove-unused-signals-boost-component.patch;patchdir=.."
|
||||
|
|
|
@ -145,7 +145,6 @@ RDEPENDS_${PN} = "\
|
|||
depthimage-to-laserscan \
|
||||
diff-drive-controller \
|
||||
gripper-action-controller \
|
||||
gscam \
|
||||
imu-processors \
|
||||
imu-transformer \
|
||||
joint-trajectory-controller \
|
||||
|
@ -154,7 +153,6 @@ RDEPENDS_${PN} = "\
|
|||
move-base \
|
||||
robot-pose-ekf \
|
||||
roslint \
|
||||
ros-pocketsphinx \
|
||||
rt-tests-support \
|
||||
communication-tests \
|
||||
cyclic-timer-tests \
|
||||
|
|
|
@ -9,3 +9,10 @@ DEPENDS = "rospy wxpython sensor-msgs"
|
|||
require robot-model.inc
|
||||
|
||||
RDEPENDS_${PN} = "wxpython"
|
||||
|
||||
inherit distro_features_check
|
||||
|
||||
# Depends on wxpython which depends on wxwidgets which depends on libxinerama, libglu, gtk need x11 in DISTRO_FEATURES
|
||||
REQUIRED_DISTRO_FEATURES = "x11"
|
||||
|
||||
PNBLACKLIST[joint-state-publisher] ?= "Depends on wxpython which depends on wxwidgets which depends on old gstreamer 0.10 recipes removed from meta-oe in 2.7 Warrior"
|
||||
|
|
|
@ -27,3 +27,5 @@ RDEPENDS_${PN} = "std-srvs rospy gstreamer0.10-pocketsphinx"
|
|||
RRECOMMENDS_${PN} += "gst-plugins-good-gconfelements"
|
||||
|
||||
ROS_SPN = "ros_pocketsphinx"
|
||||
|
||||
PNBLACKLIST[ros-pocketsphinx] ?= "Depends on old gstreamer 0.10 recipes removed from meta-oe in 2.7 Warrior"
|
||||
|
|
|
@ -10,3 +10,9 @@ DEPENDS = " \
|
|||
ROS_BPN = "demo_nodes_cpp"
|
||||
|
||||
include ros2-demos.inc
|
||||
|
||||
# FAILED: allocator_tutorial
|
||||
# /usr/include/c++/8.2.0/bits/atomic_base.h:514: error: undefined reference to '__atomic_fetch_add_8'
|
||||
# http://caprica.lgsvl.com:8080/Errors/Details/1510771
|
||||
LDFLAGS_append_armv4 = " -latomic"
|
||||
LDFLAGS_append_armv5 = " -latomic"
|
||||
|
|
Loading…
Reference in New Issue