Merge pull request #563 from bulwahn/indigo-updates
recipe updates for indigo distribution on 2017-11-21
This commit is contained in:
commit
f500ab2f21
|
@ -1,20 +1,24 @@
|
|||
From ddf9ddefb51502fb21ba01e31187e4ffebc70cce Mon Sep 17 00:00:00 2001
|
||||
From: Dmitry Rozhkov <dmitry.rozhkov@linux.intel.com>
|
||||
Date: Mon, 10 Apr 2017 10:35:26 +0300
|
||||
From 4227ce0c22e6757db1c66e46b163df7d0ecf1282 Mon Sep 17 00:00:00 2001
|
||||
From: Lukas Bulwahn <lukas.bulwahn@gmail.com>
|
||||
Date: Wed, 22 Nov 2017 13:56:25 +0100
|
||||
Subject: [PATCH] Drop support for python
|
||||
|
||||
Upstream-Status: Inappropriate [ROS still supports python2 officially]
|
||||
|
||||
Signed-off-by: Dmitry Rozhkov <dmitry.rozhkov@linux.intel.com>
|
||||
---
|
||||
CMakeLists.txt | 23 ++---------------------
|
||||
1 file changed, 2 insertions(+), 21 deletions(-)
|
||||
|
||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||
index c21e54a..3a89d94 100644
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -3,13 +3,8 @@ project(camera_calibration_parsers)
|
||||
[I rewrote the patch for the update from 1.11.12 to 1.11.13.]
|
||||
|
||||
Signed-off-by: Lukas Bulwahn <lukas.bulwahn@gmail.com>
|
||||
---
|
||||
camera_calibration_parsers/CMakeLists.txt | 22 +---------------------
|
||||
1 file changed, 1 insertion(+), 21 deletions(-)
|
||||
|
||||
diff --git a/camera_calibration_parsers/CMakeLists.txt b/camera_calibration_parsers/CMakeLists.txt
|
||||
index b70b853..b0bdf9a 100644
|
||||
--- a/camera_calibration_parsers/CMakeLists.txt
|
||||
+++ b/camera_calibration_parsers/CMakeLists.txt
|
||||
@@ -3,13 +3,7 @@ project(camera_calibration_parsers)
|
||||
|
||||
find_package(catkin REQUIRED sensor_msgs rosconsole roscpp roscpp_serialization)
|
||||
|
||||
|
@ -25,12 +29,11 @@ index c21e54a..3a89d94 100644
|
|||
- find_package(Boost REQUIRED COMPONENTS filesystem python3)
|
||||
-endif()
|
||||
-include_directories(include ${catkin_INCLUDE_DIRS} ${Boost_INCLUDE_DIRS} ${PYTHON_INCLUDE_DIRS})
|
||||
+
|
||||
+include_directories(include ${catkin_INCLUDE_DIRS} ${Boost_INCLUDE_DIRS})
|
||||
|
||||
catkin_python_setup()
|
||||
|
||||
@@ -41,17 +36,7 @@ add_library(${PROJECT_NAME}
|
||||
@@ -41,17 +35,7 @@ add_library(${PROJECT_NAME}
|
||||
src/parse_yml.cpp
|
||||
)
|
||||
|
||||
|
@ -38,7 +41,7 @@ index c21e54a..3a89d94 100644
|
|||
- src/parse_wrapper.cpp)
|
||||
-
|
||||
target_link_libraries(${PROJECT_NAME} ${catkin_LIBRARIES} ${YAML_CPP_LIBRARIES} ${Boost_FILESYSTEM_LIBRARY})
|
||||
-target_link_libraries(${PROJECT_NAME}_wrapper ${PROJECT_NAME} ${catkin_LIBRARIES} ${Boost_PYTHON_LIBRARY} ${PYTHON_LIBRARIES})
|
||||
-target_link_libraries(${PROJECT_NAME}_wrapper ${PROJECT_NAME} ${catkin_LIBRARIES} ${Boost_LIBRARIES} ${PYTHON_LIBRARIES})
|
||||
-
|
||||
-# Don't prepend wrapper library name with lib and add to Python libs.
|
||||
-set_target_properties(${PROJECT_NAME}_wrapper PROPERTIES
|
||||
|
@ -48,7 +51,7 @@ index c21e54a..3a89d94 100644
|
|||
|
||||
add_dependencies(${PROJECT_NAME} ${catkin_EXPORTED_TARGETS})
|
||||
|
||||
@@ -74,10 +59,6 @@ install(
|
||||
@@ -74,10 +58,6 @@ install(
|
||||
DESTINATION ${CATKIN_PACKAGE_BIN_DESTINATION}
|
||||
)
|
||||
|
||||
|
@ -60,5 +63,5 @@ index c21e54a..3a89d94 100644
|
|||
add_subdirectory(test)
|
||||
endif()
|
||||
--
|
||||
2.9.3
|
||||
2.7.4
|
||||
|
||||
|
|
|
@ -10,4 +10,4 @@ require image-common.inc
|
|||
# OE upstream doesn't support python2 in Boost, but python3 only.
|
||||
# So, drop python support from camera-calibration-parsers in case
|
||||
# we're building a python2 flavour of ROS.
|
||||
SRC_URI += "${@'file://0001-Drop-support-for-python.patch' if d.getVar('PYTHON_PN', True) != 'python3' else ''}"
|
||||
SRC_URI += "${@'file://0001-Drop-support-for-python.patch;striplevel=2' if d.getVar('PYTHON_PN', True) != 'python3' else ''}"
|
|
@ -1,6 +1,6 @@
|
|||
SRC_URI = "https://github.com/ros-perception/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
|
||||
SRC_URI[md5sum] = "93262ecca39761feb87ec0538217bbb5"
|
||||
SRC_URI[sha256sum] = "13d434e2d46e13af05398f3cbacffb2c69e2d015f6827d848f799a28d23e816d"
|
||||
SRC_URI[md5sum] = "a9cf52febf87dfc4d2bf3eba1a499a6b"
|
||||
SRC_URI[sha256sum] = "32a2e07724dec6eaaace21eae006274436d70d40bfe205249438570275c43cac"
|
||||
|
||||
S = "${WORKDIR}/${ROS_SP}/${ROS_BPN}"
|
||||
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
SRC_URI = "https://github.com/ros-perception/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
|
||||
SRC_URI[md5sum] = "af3628ca8adaa73be854775c10ebe8a1"
|
||||
SRC_URI[sha256sum] = "b69307689c7fb4e62464254fc24ede26c85087b51519f0b43a33e995dabe1a53"
|
||||
SRC_URI[md5sum] = "f4621ba05959f67826878f6540182e3e"
|
||||
SRC_URI[sha256sum] = "5e358bbbd3283e7f6175fbe55b965b8028e81b95ca54c5ae7a551833b7c61d3e"
|
||||
|
||||
S = "${WORKDIR}/${ROS_SP}/${ROS_BPN}"
|
||||
|
||||
|
|
|
@ -1,9 +1,9 @@
|
|||
DESCRIPTION = "ROS device driver for Velodyne HDL-64E, and HDL-32 LIDARs."
|
||||
SECTION = "devel"
|
||||
LICENSE = "BSD"
|
||||
LIC_FILES_CHKSUM = "file://package.xml;beginline=13;endline=13;md5=d566ef916e9dedc494f5f793a6690ba5"
|
||||
LIC_FILES_CHKSUM = "file://package.xml;beginline=14;endline=14;md5=d566ef916e9dedc494f5f793a6690ba5"
|
||||
|
||||
DEPENDS = "diagnostic-updater libpcap nodelet pluginlib roscpp tf velodyne-msgs"
|
||||
DEPENDS = "diagnostic-updater dynamic-reconfigure ${PYTHON_PN}-rospkg libpcap nodelet pluginlib roscpp tf velodyne-msgs"
|
||||
|
||||
require velodyne.inc
|
||||
|
|
@ -1,6 +1,6 @@
|
|||
SRC_URI = "https://github.com/ros-drivers/${ROS_SPN}/archive/${ROS_SP}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
|
||||
SRC_URI[md5sum] = "72417eb244903e824bd775ab74879982"
|
||||
SRC_URI[sha256sum] = "b767ccd50aa8981884398c88a1b292e43e27410fdb5801684cef7bfa8e8cd667"
|
||||
SRC_URI[md5sum] = "f832dfb305fc68cc4214c706cc53428d"
|
||||
SRC_URI[sha256sum] = "7adfb3efaf89a6576f796e40ef32041175e911589cfc75cbf6d10e62fd66c3c2"
|
||||
|
||||
S = "${WORKDIR}/${ROS_SPN}-${ROS_SP}/${ROS_BPN}"
|
||||
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
SRC_URI = "https://github.com/ros-perception/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
|
||||
SRC_URI[md5sum] = "f0a79aead8acadaf12f9fee676615860"
|
||||
SRC_URI[sha256sum] = "c8da1314d18e3da895a89966709c3539ed9fe0fb2d8cfd29ee4d3b138d7b48f4"
|
||||
SRC_URI[md5sum] = "d572249f578dd2a1753be77fd8d94107"
|
||||
SRC_URI[sha256sum] = "9b9b98d27f6dda114b2ba59cb5963b7bf336154589d68c4a6c96cc090d1fc880"
|
||||
|
||||
S = "${WORKDIR}/${ROS_SP}/${ROS_BPN}"
|
||||
|
||||
|
|
Loading…
Reference in New Issue