urdf-tutorial: updating to 0.2.5
This commit also updates the license file checksum, and patches CMakeLists.txt to build properly when testing with catkin is switched off. Signed-off-by: Lukas Bulwahn <lukas.bulwahn@gmail.com>
This commit is contained in:
parent
960c89659e
commit
f645ea526d
|
@ -0,0 +1,35 @@
|
|||
From e125886b0c497f01541868dc184130e33089f116 Mon Sep 17 00:00:00 2001
|
||||
From: Lukas Bulwahn <lukas.bulwahn@gmail.com>
|
||||
Date: Tue, 2 May 2017 08:42:14 +0200
|
||||
Subject: [PATCH] also build with CATKIN_ENABLE_TESTING=OFF
|
||||
|
||||
Upstream-Status: Pending
|
||||
|
||||
Signed-off-by: Lukas Bulwahn <lukas.bulwahn@gmail.com>
|
||||
---
|
||||
CMakeLists.txt | 7 +++++--
|
||||
1 file changed, 5 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||
index 474363f..20367d9 100644
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -1,10 +1,13 @@
|
||||
cmake_minimum_required(VERSION 2.8.3)
|
||||
project(urdf_tutorial)
|
||||
|
||||
-find_package(catkin REQUIRED roslaunch)
|
||||
+find_package(catkin REQUIRED)
|
||||
catkin_package()
|
||||
|
||||
-roslaunch_add_file_check(launch)
|
||||
+if (CATKIN_ENABLE_TESTING)
|
||||
+ find_package(roslaunch REQUIRED)
|
||||
+ roslaunch_add_file_check(launch)
|
||||
+endif()
|
||||
|
||||
install(DIRECTORY config images meshes launch rviz urdf
|
||||
DESTINATION ${CATKIN_PACKAGE_SHARE_DESTINATION})
|
||||
--
|
||||
1.9.1
|
||||
|
|
@ -1,13 +1,15 @@
|
|||
DESCRIPTION = "This package contains a number of URDF tutorials."
|
||||
SECTION = "devel"
|
||||
LICENSE = "BSD"
|
||||
LIC_FILES_CHKSUM = "file://package.xml;beginline=10;endline=10;md5=5ee5b8b046ae48ad94a2037ca953a67b"
|
||||
LIC_FILES_CHKSUM = "file://package.xml;beginline=10;endline=10;md5=d566ef916e9dedc494f5f793a6690ba5"
|
||||
|
||||
DEPENDS = "urdf"
|
||||
|
||||
SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
|
||||
SRC_URI[md5sum] = "00ca53e1f00b58f39d3ca89cca1819a7"
|
||||
SRC_URI[sha256sum] = "ac6c1d666eae7987ace46bab78dc9cc837a17462e59a80574d5441d0653cf333"
|
||||
SRC_URI[md5sum] = "2ea186e30b865fb6c6e535add7bd445e"
|
||||
SRC_URI[sha256sum] = "c90e7ca21bb51e851f1609c853103f39711da18f79c9915cd4d5fc3f100031c2"
|
||||
|
||||
SRC_URI += "file://0001-also-build-with-CATKIN_ENABLE_TESTING-OFF.patch"
|
||||
|
||||
S = "${WORKDIR}/${ROS_SP}"
|
||||
|
Loading…
Reference in New Issue