Merge pull request #287 from bulwahn/master-next

updates and minor tuning at the end of July 2014
This commit is contained in:
KristofRobot 2014-08-05 11:45:27 +02:00
commit f6ba831226
38 changed files with 152 additions and 74 deletions

View File

@ -4,7 +4,7 @@ COLLADA XML instance document."
LICENSE = "MIT" LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://License_Folder/license_e.txt;md5=33ea5b7341abf67bd9055a229646feae" LIC_FILES_CHKSUM = "file://License_Folder/license_e.txt;md5=33ea5b7341abf67bd9055a229646feae"
DEPENDS = "boost libxml2" DEPENDS = "boost libxml2 libpcre"
SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${BP}.tgz" SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${BP}.tgz"
SRC_URI[md5sum] = "20399de4206eab850c32e65c04e907cb" SRC_URI[md5sum] = "20399de4206eab850c32e65c04e907cb"

View File

@ -22,7 +22,7 @@ SRC_URI[kallpc16k.sha256sum] = "7a357c34086fbba8b813f9750f6b5ba13e2a00478a0a2e78
S = "${WORKDIR}/${PN}" S = "${WORKDIR}/${PN}"
inherit autotools inherit autotools-brokensep
#disable parallel make (make -j), as festival cannot handle that #disable parallel make (make -j), as festival cannot handle that
PARALLEL_MAKE = "" PARALLEL_MAKE = ""
@ -55,7 +55,7 @@ do_install() {
install -m 0755 ${S}/bin/text2wave ${D}${bindir} install -m 0755 ${S}/bin/text2wave ${D}${bindir}
install -m 0755 -d ${D}${libdir} install -m 0755 -d ${D}${libdir}
install -m 0644 ${S}/lib/etc/unknown_DebianGNULinux/audsp ${D}${libdir} install -m 0644 ${S}/lib/etc/unknown_*/audsp ${D}${libdir}
install -m 0755 -d ${D}${datadir}/festival install -m 0755 -d ${D}${datadir}/festival
install -m 0644 ${S}/lib/*scm ${D}${datadir}/festival install -m 0644 ${S}/lib/*scm ${D}${datadir}/festival

View File

@ -1,6 +1,6 @@
SRC_URI = "https://github.com/orocos/${SPN}/archive/v${PV}.tar.gz;downloadfilename=${SPN}-${PV}.tar.gz" SRC_URI = "https://github.com/orocos/${SPN}/archive/v${PV}.tar.gz;downloadfilename=${SPN}-${PV}.tar.gz"
SRC_URI[md5sum] = "710b6ab202cc062d1ad08afde9c9b21a" SRC_URI[md5sum] = "dc927de422cf6afe716ec7b12c0eed11"
SRC_URI[sha256sum] = "b35c3264ccbbde5b5dbb562cbca6cab5b69f30ebfb8d347314d844e084d037ef" SRC_URI[sha256sum] = "7be2dd5e4f4c1ceac2cdf1f4fae3d94d4ffd9fc1af8d483c05f04e80ef84b3f9"
S = "${WORKDIR}/${SPN}-${PV}/${@d.getVar('BPN', True).replace('-', '_')}" S = "${WORKDIR}/${SPN}-${PV}/${@d.getVar('BPN', True).replace('-', '_')}"

View File

@ -1,42 +0,0 @@
From ee7e02737b599d90f628252202e5a9969d050f5e Mon Sep 17 00:00:00 2001
From: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
Date: Sat, 1 Mar 2014 16:32:32 +0100
Subject: [PATCH] correct path for CONFIGURE_FILE in CMakeLists.txt
If CMAKE_MODULE_PATH is empty before appending
'${CMAKE_CURRENT_SOURCE_DIR}/cmake' to it (CMakeLists.txt:27),
CONFIGURE_FILE (CMakeLists.txt:182) works as intended.
However, when CMAKE_MODULE_PATH is not empty, e.g., because of
further tool-chain settings, CONFIGURE_FILE fails with:
CMake Error: File <SOME-OTHER-PATH>;<POCO-SRC-PATH>/cmake/cmake_uninstall.cmake.in does not exist.
| CMake Error at CMakeLists.txt:182 (CONFIGURE_FILE):
| configure_file Problem configuring file
This commit addresses this problem by only using
'${CMAKE_CURRENT_SOURCE_DIR}/cmake' in CONFIGURE_FILE.
The problem was discovered in the meta-ros layer project
(http://github.com/bmwcarit/meta-ros) when creating a libpoco
bitbake recipe, which uses poco's cmake installation scripts.
Signed-off-by: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
---
CMakeLists.txt | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8d02f13..1c9f523 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -180,7 +180,7 @@ endif(APRUTIL_FOUND AND APACHE_FOUND)
#############################################################
# Uninstall stuff see: http://www.vtk.org/Wiki/CMake_FAQ
CONFIGURE_FILE(
- "${CMAKE_MODULE_PATH}/cmake_uninstall.cmake.in"
+ "${CMAKE_CURRENT_SOURCE_DIR}/cmake/cmake_uninstall.cmake.in"
"${CMAKE_CURRENT_BINARY_DIR}/cmake_uninstall.cmake"
IMMEDIATE @ONLY)
--
1.8.3.1

View File

@ -1,15 +1,13 @@
DESCRIPTION = "POCO C++ Libraries" DESCRIPTION = "POCO C++ Libraries"
HOMEPAGE = "http://pocoproject.org" HOMEPAGE = "http://pocoproject.org"
LICENSE = "BSL-1.0" LICENSE = "BSL-1.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=e4224ccaecb14d942c71d31bef20d78c" LIC_FILES_CHKSUM = "file://LICENSE;md5=4267f48fc738f50380cbeeb76f95cebc"
DEPENDS = "expat zlib libpcre openssl" DEPENDS = "expat zlib libpcre openssl"
SRC_URI = "https://github.com/pocoproject/poco/archive/poco-${PV}-release.tar.gz" SRC_URI = "https://github.com/pocoproject/poco/archive/poco-${PV}-release.tar.gz"
SRC_URI[md5sum] = "4ed751311fe4eb437a485139fcfdf558" SRC_URI[md5sum] = "4636d84055a434fde3a67396bf15924a"
SRC_URI[sha256sum] = "315f0947b3494172cb2833d7c978fc24f16f6f10dd1a5299e83b81fee7b62f27" SRC_URI[sha256sum] = "f26bbd7879ad79b45630f8efa20b1c65f0ddf81dc44f169245d512d208c71e53"
SRC_URI += "file://0001-correct-path-for-CONFIGURE_FILE-in-CMakeLists.txt.patch"
S = "${WORKDIR}/poco-poco-${PV}-release" S = "${WORKDIR}/poco-poco-${PV}-release"

View File

@ -1,6 +1,6 @@
SRC_URI = "https://github.com/ros-drivers/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz" SRC_URI = "https://github.com/ros-drivers/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
SRC_URI[md5sum] = "26b6b9f852b0e20017c51fc98e229282" SRC_URI[md5sum] = "7610358ec0e87b37321e0391e351f487"
SRC_URI[sha256sum] = "a41c52b337d1117bdcaa60a8a092629f07da9135c8df42954eb2e225a4ad307a" SRC_URI[sha256sum] = "bdffab26cd837b6db65d275dd14de143d1cf056167fc121b213b7403142195c4"
S = "${WORKDIR}/${ROS_SP}/${ROS_BPN}" S = "${WORKDIR}/${ROS_SP}/${ROS_BPN}"

View File

@ -6,8 +6,8 @@ LIC_FILES_CHKSUM = "file://package.xml;beginline=13;endline=13;md5=d566ef916e9de
DEPENDS = "rospy sensor-msgs" DEPENDS = "rospy sensor-msgs"
SRC_URI = "https://github.com/ros-perception/${ROS_SPN}/archive/${ROS_SP}.tar.gz;downloadfilename=${ROS_SP}.tar.gz" SRC_URI = "https://github.com/ros-perception/${ROS_SPN}/archive/${ROS_SP}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
SRC_URI[md5sum] = "9d1ead73e678fa2f51a70a933b0bf017" SRC_URI[md5sum] = "eb12065f8e6b9d06a489f89f19dcc41e"
SRC_URI[sha256sum] = "0019dfc4b32d63c1392aa264aed2253c1e0c2fb09216f8e2cc269bbfb8bb49b5" SRC_URI[sha256sum] = "d1ae6229c9a55e8d6fa89b5d051b86605fca0b02ff2e344c76c44d7642eb88c6"
S = "${WORKDIR}/${ROS_SPN}-${ROS_SP}" S = "${WORKDIR}/${ROS_SPN}-${ROS_SP}"

View File

@ -4,6 +4,6 @@ SECTION = "devel"
LICENSE = "BSD" LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://package.xml;beginline=26;endline=26;md5=d566ef916e9dedc494f5f793a6690ba5" LIC_FILES_CHKSUM = "file://package.xml;beginline=26;endline=26;md5=d566ef916e9dedc494f5f793a6690ba5"
DEPENDS = "cv-bridge dynamic-reconfigure image-transport opencv roscpp tf tf-conversions eigen-conversions" DEPENDS = "cv-bridge dynamic-reconfigure image-transport opencv roscpp tf tf-conversions eigen-conversions nodelet"
require image-pipeline.inc require image-pipeline.inc

View File

@ -0,0 +1,36 @@
From a4404ea5ee0f4fb192c5765ee4dce6a265a70ec9 Mon Sep 17 00:00:00 2001
From: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
Date: Sun, 27 Jul 2014 09:58:36 +0200
Subject: [PATCH] make rostest in CMakeLists optional (ros/rosdistro#3010)
Upstream-Status: Submitted
---
CMakeLists.txt | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1ad9dbc..7309f3d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -10,8 +10,7 @@ tf sensor_msgs message_filters roscpp laser_geometry filters)
find_package(catkin REQUIRED COMPONENTS
${THIS_PACKAGE_ROS_DEPS}
- message_generation
- rostest)
+ message_generation)
find_package(Boost REQUIRED COMPONENTS system signals)
include_directories(include ${catkin_INCLUDE_DIRS} ${Boost_INCLUDE_DIRS})
@@ -68,6 +67,8 @@ add_dependencies(point_cloud2_assembler ${PROJECT_NAME}_gencpp)
## unit testing
if(CATKIN_ENABLE_TESTING)
+ find_package(rostest)
+
add_executable(periodic_snapshotter examples/periodic_snapshotter.cpp)
target_link_libraries(periodic_snapshotter ${catkin_LIBRARIES} ${Boost_LIBRARIES})
add_dependencies(periodic_snapshotter ${PROJECT_NAME}_gencpp)
--
1.9.1

View File

@ -3,12 +3,14 @@ SECTION = "devel"
LICENSE = "BSD" LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://package.xml;beginline=13;endline=13;md5=d566ef916e9dedc494f5f793a6690ba5" LIC_FILES_CHKSUM = "file://package.xml;beginline=13;endline=13;md5=d566ef916e9dedc494f5f793a6690ba5"
DEPENDS = "message-generation sensor-msgs message-filters tf roscpp rostest filters laser-geometry pluginlib" DEPENDS = "message-generation sensor-msgs message-filters tf roscpp filters laser-geometry pluginlib"
SRC_URI = "https://github.com/ros-perception/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz" SRC_URI = "https://github.com/ros-perception/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
SRC_URI[md5sum] = "1e0fe2d0b5fb26eca1e9137d64767419" SRC_URI[md5sum] = "1e0fe2d0b5fb26eca1e9137d64767419"
SRC_URI[sha256sum] = "de6637a229d84d6215dc0176ea05bc40c2eb2d8dec8ca520c4a29822f089e74a" SRC_URI[sha256sum] = "de6637a229d84d6215dc0176ea05bc40c2eb2d8dec8ca520c4a29822f089e74a"
SRC_URI += "file://0001-make-rostest-in-CMakeLists-optional-ros-rosdistro-30.patch"
S = "${WORKDIR}/${ROS_SP}" S = "${WORKDIR}/${ROS_SP}"
inherit catkin inherit catkin

View File

@ -1,6 +1,6 @@
SRC_URI = "https://github.com/ros-planning/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz" SRC_URI = "https://github.com/ros-planning/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
SRC_URI[md5sum] = "3ef134620bd407d547da7a8798dba598" SRC_URI[md5sum] = "dce7f2003e60fc8d29f8a012a5d6ed1b"
SRC_URI[sha256sum] = "349f0cfec19a545b7448e8dba1796a984210cebcd1c7d13827b74cdb436ddf7a" SRC_URI[sha256sum] = "7c4ade380aa33d8c39d446185a715e08494115097cd34fb8e28dba53b29b7966"
S = "${WORKDIR}/${ROS_SP}/${ROS_BPN}" S = "${WORKDIR}/${ROS_SP}/${ROS_BPN}"

View File

@ -1,13 +1,13 @@
DESCRIPTION = "This package allows you to publish the state of a robot to tf." DESCRIPTION = "This package allows you to publish the state of a robot to tf."
SECTION = "devel" SECTION = "devel"
LICENSE = "BSD" LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://package.xml;beginline=17;endline=17;md5=5ee5b8b046ae48ad94a2037ca953a67b" LIC_FILES_CHKSUM = "file://package.xml;beginline=17;endline=17;md5=d566ef916e9dedc494f5f793a6690ba5"
DEPENDS = "libeigen kdl-parser rosconsole roscpp rostime sensor-msgs tf tf-conversions" DEPENDS = "libeigen kdl-parser rosconsole roscpp rostime sensor-msgs tf tf-conversions"
SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz" SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
SRC_URI[md5sum] = "69fd00d92a1fe6928d30cd49f3e41fbd" SRC_URI[md5sum] = "79157d107c6062bb98ee8197d7db607c"
SRC_URI[sha256sum] = "b2ee50c242508d78685e17819c3bafe22cdd667e9519c5f107169a9e1507a501" SRC_URI[sha256sum] = "d4cddab199fa32c423cc9ea0c532b564e1df751d5d3382a82e6054c9656cfae6"
S = "${WORKDIR}/${ROS_SP}" S = "${WORKDIR}/${ROS_SP}"

View File

@ -1,16 +1,16 @@
From 8c6aa59b2380a5aa39d7e815c521407f40640545 Mon Sep 17 00:00:00 2001 From 00fbc3fa30d78c10e13ecd04d85ecf98a39a4bb2 Mon Sep 17 00:00:00 2001
From: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de> From: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
Date: Tue, 4 Feb 2014 16:06:33 +0100 Date: Sun, 27 Jul 2014 09:07:29 +0200
Subject: [PATCH] make rostest in CMakeLists optional (ros/rosdistro#3010) Subject: [PATCH] make rostest in CMakeLists optional (ros/rosdistro#3010)
Upstream-Status: Submitted Upstream-Status: Accepted
--- ---
controller_manager_tests/CMakeLists.txt | 3 ++- controller_manager_tests/CMakeLists.txt | 3 ++-
joint_limits_interface/CMakeLists.txt | 3 ++- joint_limits_interface/CMakeLists.txt | 3 ++-
2 files changed, 4 insertions(+), 2 deletions(-) 2 files changed, 4 insertions(+), 2 deletions(-)
diff --git a/controller_manager_tests/CMakeLists.txt b/controller_manager_tests/CMakeLists.txt diff --git a/controller_manager_tests/CMakeLists.txt b/controller_manager_tests/CMakeLists.txt
index 95c73cc..9e018b1 100644 index 64731bd..badc147 100644
--- a/controller_manager_tests/CMakeLists.txt --- a/controller_manager_tests/CMakeLists.txt
+++ b/controller_manager_tests/CMakeLists.txt +++ b/controller_manager_tests/CMakeLists.txt
@@ -29,7 +29,7 @@ if(USE_ROSBUILD) @@ -29,7 +29,7 @@ if(USE_ROSBUILD)
@ -22,7 +22,7 @@ index 95c73cc..9e018b1 100644
include_directories(include ${Boost_INCLUDE_DIR} ${catkin_INCLUDE_DIRS}) include_directories(include ${Boost_INCLUDE_DIR} ${catkin_INCLUDE_DIRS})
@@ -53,6 +53,7 @@ else() @@ -54,6 +54,7 @@ else()
target_link_libraries(dummy_app ${PROJECT_NAME} ${catkin_LIBRARIES}) target_link_libraries(dummy_app ${PROJECT_NAME} ${catkin_LIBRARIES})
if(CATKIN_ENABLE_TESTING) if(CATKIN_ENABLE_TESTING)
@ -31,7 +31,7 @@ index 95c73cc..9e018b1 100644
add_dependencies(tests cm_test) add_dependencies(tests cm_test)
target_link_libraries(cm_test ${GTEST_LIBRARIES} ${catkin_LIBRARIES}) target_link_libraries(cm_test ${GTEST_LIBRARIES} ${catkin_LIBRARIES})
diff --git a/joint_limits_interface/CMakeLists.txt b/joint_limits_interface/CMakeLists.txt diff --git a/joint_limits_interface/CMakeLists.txt b/joint_limits_interface/CMakeLists.txt
index 2ac2b3f..1a72061 100644 index fedaadd..f8305f1 100644
--- a/joint_limits_interface/CMakeLists.txt --- a/joint_limits_interface/CMakeLists.txt
+++ b/joint_limits_interface/CMakeLists.txt +++ b/joint_limits_interface/CMakeLists.txt
@@ -25,7 +25,6 @@ else() # catkin @@ -25,7 +25,6 @@ else() # catkin
@ -42,7 +42,7 @@ index 2ac2b3f..1a72061 100644
hardware_interface hardware_interface
urdfdom urdfdom
) )
@@ -48,6 +47,8 @@ else() # catkin @@ -49,6 +48,8 @@ else() # catkin
) )
if(CATKIN_ENABLE_TESTING) if(CATKIN_ENABLE_TESTING)
@ -52,5 +52,5 @@ index 2ac2b3f..1a72061 100644
target_link_libraries(joint_limits_interface_test ${catkin_LIBRARIES}) target_link_libraries(joint_limits_interface_test ${catkin_LIBRARIES})
-- --
1.8.3.2 1.9.3

View File

@ -0,0 +1,38 @@
From 79856f596b827981fb5dad854c56347b912836fd Mon Sep 17 00:00:00 2001
From: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
Date: Thu, 31 Jul 2014 21:06:41 +0200
Subject: [PATCH] gripper_action_controller: drop unneeded rostest dependency
Upstream-Status: Accepted
---
gripper_action_controller/CMakeLists.txt | 1 -
gripper_action_controller/package.xml | 1 -
2 files changed, 2 deletions(-)
diff --git a/gripper_action_controller/CMakeLists.txt b/gripper_action_controller/CMakeLists.txt
index 555ec69..2b925a9 100644
--- a/gripper_action_controller/CMakeLists.txt
+++ b/gripper_action_controller/CMakeLists.txt
@@ -17,7 +17,6 @@ find_package(catkin
realtime_tools
control_msgs
trajectory_msgs
- rostest
controller_manager
xacro
)
diff --git a/gripper_action_controller/package.xml b/gripper_action_controller/package.xml
index 513321b..2607005 100644
--- a/gripper_action_controller/package.xml
+++ b/gripper_action_controller/package.xml
@@ -49,7 +49,6 @@
<build_depend>controller_manager</build_depend>
<build_depend>hardware_interface</build_depend>
<build_depend>realtime_tools</build_depend>
- <build_depend>rostest</build_depend>
<build_depend>trajectory_msgs</build_depend>
<build_depend>urdf</build_depend>
<build_depend>xacro</build_depend>
--
1.7.9.5

View File

@ -4,6 +4,8 @@ LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://package.xml;beginline=16;endline=16;md5=d566ef916e9dedc494f5f793a6690ba5" LIC_FILES_CHKSUM = "file://package.xml;beginline=16;endline=16;md5=d566ef916e9dedc494f5f793a6690ba5"
DEPENDS = "actionlib angles cmake-modules roscpp urdf control-toolbox controller-interface \ DEPENDS = "actionlib angles cmake-modules roscpp urdf control-toolbox controller-interface \
hardware-interface realtime-tools control-msgs trajectory-msgs rostest controller-manager xacro" hardware-interface realtime-tools control-msgs trajectory-msgs controller-manager xacro"
require ros-controllers.inc require ros-controllers.inc
SRC_URI += "file://0001-gripper_action_controller-drop-unneeded-rostest-depe.patch;striplevel=2"

View File

@ -0,0 +1,43 @@
From f87e0c5c30bf99e0a45cfef7a8dc17a60ac41cba Mon Sep 17 00:00:00 2001
From: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
Date: Thu, 31 Jul 2014 21:18:31 +0200
Subject: [PATCH] joint_trajectory_controller: make rostest in CMakeLists
optional (ros/rosdistro#3010)
Upstream-Status: Accepted
---
joint_trajectory_controller/CMakeLists.txt | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/joint_trajectory_controller/CMakeLists.txt b/joint_trajectory_controller/CMakeLists.txt
index 06e9d93..9687ec3 100644
--- a/joint_trajectory_controller/CMakeLists.txt
+++ b/joint_trajectory_controller/CMakeLists.txt
@@ -61,7 +61,6 @@ else()
realtime_tools
control_msgs
trajectory_msgs
- rostest
controller_manager
xacro
)
@@ -79,7 +78,6 @@ else()
realtime_tools
control_msgs
trajectory_msgs
- rostest
controller_manager
xacro
INCLUDE_DIRS include
@@ -103,6 +101,8 @@ else()
target_link_libraries(${PROJECT_NAME} ${catkin_LIBRARIES})
if(CATKIN_ENABLE_TESTING)
+ find_package(rostest)
+
catkin_add_gtest(quintic_spline_segment_test test/quintic_spline_segment_test.cpp)
target_link_libraries(quintic_spline_segment_test ${catkin_LIBRARIES})
--
1.7.9.5

View File

@ -3,8 +3,9 @@ SECTION = "devel"
LICENSE = "BSD" LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://package.xml;beginline=8;endline=8;md5=d566ef916e9dedc494f5f793a6690ba5" LIC_FILES_CHKSUM = "file://package.xml;beginline=8;endline=8;md5=d566ef916e9dedc494f5f793a6690ba5"
DEPENDS = "actionlib angles cmake-modules control-toolbox controller-interface controller-manager control-msgs rostest urdf xacro" DEPENDS = "actionlib angles cmake-modules control-toolbox controller-interface controller-manager control-msgs urdf xacro"
require ros-controllers.inc require ros-controllers.inc
SRC_URI += "file://0001-check-for-CATKIN_ENABLE_TESTING.patch;striplevel=2" SRC_URI += "file://0001-check-for-CATKIN_ENABLE_TESTING.patch;striplevel=2 \
file://0001-joint_trajectory_controller-make-rostest-in-CMakeLis.patch;striplevel=2"