geometry: updating to 1.11.9
In the tf recipe, this commit adjusts the license-file line and drops the upstream-accepted patch due to update. With the update of eigen-conversions and tf-conversions, the compilation of both packages fails with: ``` | [...]: fatal error: Eigen/Core: No such file or directory | #include <Eigen/Core> | ^~~~~~~~~~~~ | compilation terminated. ``` It fails as the upstream development uses the Eigen3 CMake find script instead of the ROS cmake_modules find script, and the Eigen3 CMake find script does not work in the current openembedded-core and meta-openembedded setup (cf. #501). Hence, this commit applies a patch to revert the CMakeLists.txt to use ROS cmake_modules to find Eigen. This patch must be applied until issue #501 is resolved in the upstream development. Signed-off-by: Lukas Bulwahn <lukas.bulwahn@gmail.com>
This commit is contained in:
parent
14d4596eb1
commit
f734e4466a
|
@ -0,0 +1,64 @@
|
||||||
|
From fc3670a9a37c806458fba9ef6332a63ea8f31951 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Lukas Bulwahn <lukas.bulwahn@gmail.com>
|
||||||
|
Date: Mon, 14 Aug 2017 18:00:37 +0200
|
||||||
|
Subject: [PATCH] find Eigen with cmake_modules' Find script (partly reverts
|
||||||
|
707eb4119d)
|
||||||
|
|
||||||
|
Upstream-Status: Inappropriate [openembedded-specific adjustment]
|
||||||
|
---
|
||||||
|
eigen_conversions/CMakeLists.txt | 6 +++---
|
||||||
|
tf_conversions/CMakeLists.txt | 6 +++---
|
||||||
|
2 files changed, 6 insertions(+), 6 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/eigen_conversions/CMakeLists.txt b/eigen_conversions/CMakeLists.txt
|
||||||
|
index 5277aea..f056048 100644
|
||||||
|
--- a/eigen_conversions/CMakeLists.txt
|
||||||
|
+++ b/eigen_conversions/CMakeLists.txt
|
||||||
|
@@ -3,15 +3,15 @@ project(eigen_conversions)
|
||||||
|
|
||||||
|
find_package(orocos_kdl REQUIRED)
|
||||||
|
find_package(catkin REQUIRED cmake_modules geometry_msgs std_msgs)
|
||||||
|
-find_package(Eigen3 REQUIRED)
|
||||||
|
+find_package(Eigen REQUIRED)
|
||||||
|
|
||||||
|
-include_directories(SYSTEM ${EIGEN3_INCLUDE_DIRS})
|
||||||
|
+include_directories(SYSTEM ${EIGEN_INCLUDE_DIRS})
|
||||||
|
include_directories(include ${catkin_INCLUDE_DIRS} ${orocos_kdl_INCLUDE_DIRS})
|
||||||
|
link_directories(${catkin_LIBRARY_DIRS})
|
||||||
|
link_directories(${orocos_kdl_LIBRARY_DIRS})
|
||||||
|
|
||||||
|
catkin_package(
|
||||||
|
- INCLUDE_DIRS include ${EIGEN3_INCLUDE_DIRS}
|
||||||
|
+ INCLUDE_DIRS include ${EIGEN_INCLUDE_DIRS}
|
||||||
|
LIBRARIES ${PROJECT_NAME}
|
||||||
|
CATKIN_DEPENDS geometry_msgs std_msgs
|
||||||
|
DEPENDS orocos_kdl
|
||||||
|
diff --git a/tf_conversions/CMakeLists.txt b/tf_conversions/CMakeLists.txt
|
||||||
|
index 543bbdb..5797b2f 100644
|
||||||
|
--- a/tf_conversions/CMakeLists.txt
|
||||||
|
+++ b/tf_conversions/CMakeLists.txt
|
||||||
|
@@ -3,18 +3,18 @@ project(tf_conversions)
|
||||||
|
|
||||||
|
find_package(orocos_kdl REQUIRED)
|
||||||
|
find_package(catkin REQUIRED cmake_modules geometry_msgs kdl_conversions tf)
|
||||||
|
-find_package(Eigen3 REQUIRED)
|
||||||
|
+find_package(Eigen REQUIRED)
|
||||||
|
|
||||||
|
catkin_python_setup()
|
||||||
|
|
||||||
|
catkin_package(
|
||||||
|
INCLUDE_DIRS include
|
||||||
|
LIBRARIES ${PROJECT_NAME}
|
||||||
|
- DEPENDS EIGEN3 orocos_kdl
|
||||||
|
+ DEPENDS EIGEN orocos_kdl
|
||||||
|
CATKIN_DEPENDS geometry_msgs kdl_conversions tf
|
||||||
|
)
|
||||||
|
|
||||||
|
-include_directories(include ${catkin_INCLUDE_DIRS} ${EIGEN3_INCLUDE_DIRS} ${orocos_kdl_INCLUDE_DIRS})
|
||||||
|
+include_directories(include ${catkin_INCLUDE_DIRS} ${EIGEN_INCLUDE_DIRS} ${orocos_kdl_INCLUDE_DIRS})
|
||||||
|
|
||||||
|
# Needed due to no full filename in orocos_kdl pkg-config export
|
||||||
|
link_directories(${orocos_kdl_LIBRARY_DIRS})
|
||||||
|
--
|
||||||
|
1.9.1
|
||||||
|
|
|
@ -1,6 +1,8 @@
|
||||||
SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
|
SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
|
||||||
SRC_URI[md5sum] = "a5e9e0a164c569bea3b4a1a07d3b104f"
|
SRC_URI[md5sum] = "5d55aa4d8b5fea53e0fc72605843b4d0"
|
||||||
SRC_URI[sha256sum] = "a372f2225d6d9625dadc9dee817281a22dfb4b4dc8fd129ee1fb9375993bfd88"
|
SRC_URI[sha256sum] = "8c8e20d28d352b3ccb227ca7da39a1dddc051cf8309f90a46d6b0c7b2e398d33"
|
||||||
|
|
||||||
|
SRC_URI += "file://0001-find-Eigen-with-cmake_modules-Find-script-partly-rev.patch;patchdir=.."
|
||||||
|
|
||||||
S = "${WORKDIR}/${ROS_SP}/${ROS_BPN}"
|
S = "${WORKDIR}/${ROS_SP}/${ROS_BPN}"
|
||||||
|
|
||||||
|
|
|
@ -1,35 +0,0 @@
|
||||||
From b0d31cc1e9a43b45d216ee7f804e901a5c0f8936 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Hodorgasm <nsane457@gmail.com>
|
|
||||||
Date: Mon, 19 Sep 2016 17:58:22 -0400
|
|
||||||
Subject: [PATCH] Fix "stdlib.h: No such file or directory" errors in GCC-6
|
|
||||||
|
|
||||||
Including '-isystem /usr/include' breaks building with GCC-6.
|
|
||||||
See https://gcc.gnu.org/bugzilla/show_bug.cgi?id=70129
|
|
||||||
|
|
||||||
Upstream-Status: Accepted [https://github.com/ros/geometry/commit/b0d31cc1e9a43b45d216ee7f804e901a5c0f8936]
|
|
||||||
|
|
||||||
This patch has been generated with:
|
|
||||||
`git format-patch -1 b0d31cc1e9a43b45d216ee7f804e901a5c0f8936`
|
|
||||||
in the geometry repository.
|
|
||||||
|
|
||||||
Signed-off-by: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
|
|
||||||
---
|
|
||||||
tf/CMakeLists.txt | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/tf/CMakeLists.txt b/tf/CMakeLists.txt
|
|
||||||
index 8077561..cf72127 100644
|
|
||||||
--- a/tf/CMakeLists.txt
|
|
||||||
+++ b/tf/CMakeLists.txt
|
|
||||||
@@ -8,7 +8,7 @@ find_package(catkin COMPONENTS angles geometry_msgs message_filters message_gene
|
|
||||||
|
|
||||||
catkin_python_setup()
|
|
||||||
|
|
||||||
-include_directories(SYSTEM ${Boost_INCLUDE_DIR}
|
|
||||||
+include_directories(${Boost_INCLUDE_DIR}
|
|
||||||
${catkin_INCLUDE_DIRS}
|
|
||||||
)
|
|
||||||
include_directories(include)
|
|
||||||
--
|
|
||||||
2.5.5
|
|
||||||
|
|
|
@ -1,14 +1,12 @@
|
||||||
DESCRIPTION = "tf is a package that lets the user keep track of multiple coordinate frames over time."
|
DESCRIPTION = "tf is a package that lets the user keep track of multiple coordinate frames over time."
|
||||||
SECTION = "devel"
|
SECTION = "devel"
|
||||||
LICENSE = "BSD"
|
LICENSE = "BSD"
|
||||||
LIC_FILES_CHKSUM = "file://package.xml;beginline=18;endline=18;md5=d566ef916e9dedc494f5f793a6690ba5"
|
LIC_FILES_CHKSUM = "file://package.xml;beginline=21;endline=21;md5=d566ef916e9dedc494f5f793a6690ba5"
|
||||||
|
|
||||||
DEPENDS = "angles geometry-msgs message-filters sensor-msgs tf2-ros"
|
DEPENDS = "angles geometry-msgs message-filters sensor-msgs tf2-ros"
|
||||||
|
|
||||||
require geometry.inc
|
require geometry.inc
|
||||||
|
|
||||||
SRC_URI += "file://0001-Fix-stdlib.h-No-such-file-or-directory-errors-in-GCC.patch;striplevel=2"
|
|
||||||
|
|
||||||
RDEPENDS_${PN} = "${PYTHON_PN}-numpy"
|
RDEPENDS_${PN} = "${PYTHON_PN}-numpy"
|
||||||
|
|
||||||
# This option disables python support in case of python3 flavour of ROS because
|
# This option disables python support in case of python3 flavour of ROS because
|
Loading…
Reference in New Issue