ros-control: updating to 0.7.2
This commit is contained in:
parent
455385f0f6
commit
fb365e9f35
|
@ -1,12 +1,12 @@
|
|||
From b746072f9729b9d39a5e1901c0ffa7dcb5f19956 Mon Sep 17 00:00:00 2001
|
||||
From 8c6aa59b2380a5aa39d7e815c521407f40640545 Mon Sep 17 00:00:00 2001
|
||||
From: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
|
||||
Date: Tue, 4 Feb 2014 16:06:33 +0100
|
||||
Subject: [PATCH] make rostest in CMakeLists optional (ros/rosdistro#3010)
|
||||
|
||||
---
|
||||
controller_manager_tests/CMakeLists.txt | 3 ++-
|
||||
joint_limits_interface/CMakeLists.txt | 4 +++-
|
||||
2 files changed, 5 insertions(+), 2 deletions(-)
|
||||
joint_limits_interface/CMakeLists.txt | 3 ++-
|
||||
2 files changed, 4 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/controller_manager_tests/CMakeLists.txt b/controller_manager_tests/CMakeLists.txt
|
||||
index 95c73cc..9e018b1 100644
|
||||
|
@ -30,19 +30,18 @@ index 95c73cc..9e018b1 100644
|
|||
add_dependencies(tests cm_test)
|
||||
target_link_libraries(cm_test ${GTEST_LIBRARIES} ${catkin_LIBRARIES})
|
||||
diff --git a/joint_limits_interface/CMakeLists.txt b/joint_limits_interface/CMakeLists.txt
|
||||
index 16644a2..7053abc 100644
|
||||
index 2ac2b3f..1a72061 100644
|
||||
--- a/joint_limits_interface/CMakeLists.txt
|
||||
+++ b/joint_limits_interface/CMakeLists.txt
|
||||
@@ -23,7 +23,7 @@ if(USE_ROSBUILD)
|
||||
@@ -25,7 +25,6 @@ else() # catkin
|
||||
|
||||
else() # catkin
|
||||
|
||||
- find_package(catkin REQUIRED COMPONENTS roscpp rostest)
|
||||
+ find_package(catkin REQUIRED COMPONENTS roscpp)
|
||||
|
||||
include_directories(
|
||||
SYSTEM
|
||||
@@ -44,6 +44,8 @@ else() # catkin
|
||||
find_package(catkin REQUIRED
|
||||
roscpp
|
||||
- rostest
|
||||
hardware_interface
|
||||
urdfdom
|
||||
)
|
||||
@@ -48,6 +47,8 @@ else() # catkin
|
||||
)
|
||||
|
||||
if(CATKIN_ENABLE_TESTING)
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
SRC_URI = "https://github.com/ros-controls/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
|
||||
SRC_URI[md5sum] = "f3fa5aabaa68f4f23bb277f47746cfc4"
|
||||
SRC_URI[sha256sum] = "598d6c28148764f328b87ef0c2533e49f9b4925a1457688f2715ce332fc82dfd"
|
||||
SRC_URI[md5sum] = "4eadd134fcb828a341fc65ff521f7e5c"
|
||||
SRC_URI[sha256sum] = "7bc3bfde309e0938cf2cd639d97e95c06e837c140831357378df861e3b657577"
|
||||
|
||||
SRC_URI += "file://0001-make-rostest-in-CMakeLists-optional-ros-rosdistro-30.patch;patchdir=.."
|
||||
|
||||
|
|
Loading…
Reference in New Issue