Merge pull request #294 from bulwahn/updates

updates and minor tuning at the beginning of September 2014
This commit is contained in:
herbrechtsmeier 2014-09-10 07:13:33 +02:00
commit ff23467c9e
38 changed files with 91 additions and 13 deletions

View File

@ -0,0 +1,77 @@
From c2ad66f36569d64a445dbadeae197264d216d48c Mon Sep 17 00:00:00 2001
From: Sergey Alexandrov <alexandrov88@gmail.com>
Date: Sat, 23 Aug 2014 13:03:37 +0200
Subject: [PATCH] Fix incompatibility with Boost 1.56
The fix is based on the proposal of Andrew McMahon (@McDamon, #864).
Upstream-Status: Backport [retrieved from upstream repository]
This patch is copy of:
https://github.com/PointCloudLibrary/pcl/commit/c2ad66f36569d64a445dbadeae197264d216d48c.patch
---
io/src/lzf_image_io.cpp | 20 ++++++++++++++------
1 file changed, 14 insertions(+), 6 deletions(-)
diff --git a/io/src/lzf_image_io.cpp b/io/src/lzf_image_io.cpp
index 55eca90..7742f16 100644
--- a/io/src/lzf_image_io.cpp
+++ b/io/src/lzf_image_io.cpp
@@ -59,6 +59,17 @@
#define LZF_HEADER_SIZE 37
+
+// The signature of boost::property_tree::xml_parser::write_xml() changed in Boost 1.56
+// See https://github.com/PointCloudLibrary/pcl/issues/864
+#include <boost/version.hpp>
+#if (BOOST_VERSION >= 105600)
+ typedef boost::property_tree::xml_writer_settings<std::string> xml_writer_settings;
+#else
+ typedef boost::property_tree::xml_writer_settings<char> xml_writer_settings;
+#endif
+
+
//////////////////////////////////////////////////////////////////////////////
bool
pcl::io::LZFImageWriter::saveImageBlob (const char* data,
@@ -198,9 +209,8 @@ pcl::io::LZFImageWriter::writeParameter (const double &parameter,
catch (std::exception& e)
{}
- boost::property_tree::xml_writer_settings<char> settings ('\t', 1);
pt.put (tag, parameter);
- write_xml (filename, pt, std::locale (), settings);
+ write_xml (filename, pt, std::locale (), xml_writer_settings ('\t', 1));
return (true);
}
@@ -218,13 +228,12 @@ pcl::io::LZFDepth16ImageWriter::writeParameters (const pcl::io::CameraParameters
catch (std::exception& e)
{}
- boost::property_tree::xml_writer_settings<char> settings ('\t', 1);
pt.put ("depth.focal_length_x", parameters.focal_length_x);
pt.put ("depth.focal_length_y", parameters.focal_length_y);
pt.put ("depth.principal_point_x", parameters.principal_point_x);
pt.put ("depth.principal_point_y", parameters.principal_point_y);
pt.put ("depth.z_multiplication_factor", z_multiplication_factor_);
- write_xml (filename, pt, std::locale (), settings);
+ write_xml (filename, pt, std::locale (), xml_writer_settings ('\t', 1));
return (true);
}
@@ -279,12 +288,11 @@ pcl::io::LZFRGB24ImageWriter::writeParameters (const pcl::io::CameraParameters &
catch (std::exception& e)
{}
- boost::property_tree::xml_writer_settings<char> settings ('\t', 1);
pt.put ("rgb.focal_length_x", parameters.focal_length_x);
pt.put ("rgb.focal_length_y", parameters.focal_length_y);
pt.put ("rgb.principal_point_x", parameters.principal_point_x);
pt.put ("rgb.principal_point_y", parameters.principal_point_y);
- write_xml (filename, pt, std::locale (), settings);
+ write_xml (filename, pt, std::locale (), xml_writer_settings ('\t', 1));
return (true);
}

View File

@ -9,6 +9,8 @@ SRC_URI = "https://github.com/PointCloudLibrary/${PN}/archive/${P}.tar.gz"
SRC_URI[md5sum] = "e2ac2d2e72825d991c6d194f9586b5d8"
SRC_URI[sha256sum] = "a5446b4d892d0e6b080ab6b6b745faad2f2f415c6c1353b1424f6b38175c777e"
SRC_URI += "file://0001-Fix-incompatibility-with-Boost-1.56.patch"
S = "${WORKDIR}/pcl-${P}"
EXTRA_OECMAKE += "\

View File

@ -6,8 +6,8 @@ LIC_FILES_CHKSUM = "file://package.xml;beginline=7;endline=7;md5=d566ef916e9dedc
DEPENDS = "cmake python-empy python-catkin-pkg python-empy-native python-catkin-pkg-native"
SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
SRC_URI[md5sum] = "472ff1f0e04f456af65fa16060fc75c6"
SRC_URI[sha256sum] = "e393e114f491d54982d854ba6e878fd85ed9606d6a5cc122d30fd950daed269f"
SRC_URI[md5sum] = "994b57a85d788cc10b13f39c3bc59cfc"
SRC_URI[sha256sum] = "3cbac7fc3704ccef78984740001b7d5779dd93470522b407ef5b6d9972f9f47a"
SRC_URI += "file://0001-CATKIN_WORKSPACES-Don-t-require-.catkin-file.patch"

View File

@ -1,6 +1,6 @@
SRC_URI = "https://github.com/OctoMap/${ROS_SPN}/archive/v${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
SRC_URI[md5sum] = "6781c4a12958cca69570c334cf836f21"
SRC_URI[sha256sum] = "cad32744152970d0ab141d12c122d0482510644f29c61b8464bbfc65ebff1cf0"
SRC_URI[md5sum] = "e4f9ab54fecfc031ec160b8989340804"
SRC_URI[sha256sum] = "833adba0d3b203cab0e28a0180490e74bc852a7fea9adf6ee53bbfb8f10bc79a"
S = "${WORKDIR}/${ROS_SP}/${ROS_BPN}"

View File

@ -155,7 +155,6 @@ RDEPENDS_${PN} = "\
communication-tests \
cyclic-timer-tests \
oneshot-timer-tests \
urdfdom-headers \
urdfdom-py \
urdf-tutorial \
velodyne-driver \

View File

@ -1,6 +1,6 @@
SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
SRC_URI[md5sum] = "a2852ce1e1b3a7805f0a0836b8942811"
SRC_URI[sha256sum] = "908dee4ff9031a0f954f98f8c5b646c24efd86ec352887df4882b1b6e067c5b6"
SRC_URI[md5sum] = "eda49f4a025e229be069622132f56eef"
SRC_URI[sha256sum] = "d9fa88f5cd904359041cd072fed59cb06f87537ab14c51c89605d1f04be58e9e"
S = "${WORKDIR}/${ROS_SP}/${ROS_BPN}"

View File

@ -1,6 +1,6 @@
SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
SRC_URI[md5sum] = "76d68100d0b261b437953a0c1e36999d"
SRC_URI[sha256sum] = "57cab5aec103eb4a2a6711c3ce364a03e58ed79d39b600efa2c231527a470a33"
SRC_URI[md5sum] = "d76ea0a49d8cf5ac21345119a617c60b"
SRC_URI[sha256sum] = "7680d3e14c3dba8d393f7fde21eb2b5ac78d7024ac6fc5b13a653172bf8a2f30"
SRC_URI += "file://0001-make-rostest-in-CMakeLists-optional-ros-rosdistro-30.patch;patchdir=../.."

View File

@ -6,8 +6,8 @@ LIC_FILES_CHKSUM = "file://package.xml;beginline=6;endline=6;md5=d566ef916e9dedc
DEPENDS = "boost python-rospkg-native libtinyxml"
SRC_URI = "https://github.com/ros/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
SRC_URI[md5sum] = "fd27ee7b35fb5d34be609bac35477306"
SRC_URI[sha256sum] = "b41cf1775a9216aa2c7604d8e293b7eb11f50d18b1722a491a4b800362c5d7ca"
SRC_URI[md5sum] = "d625279380f40e8033eeeb451f0e4b5b"
SRC_URI[sha256sum] = "95e05ef70eb46e483c241278e9c0d7fb10390a61927c2593ce6f408682e1637d"
inherit catkin

View File

@ -6,8 +6,8 @@ LIC_FILES_CHKSUM = "file://package.xml;beginline=11;endline=11;md5=11e24f757f025
DEPENDS = "nav-msgs openslam-gmapping roscpp rostest tf"
SRC_URI = "https://github.com/ros-perception/${ROS_SPN}/archive/${PV}.tar.gz;downloadfilename=${ROS_SP}.tar.gz"
SRC_URI[md5sum] = "f5ce250bea6e5798735ddba602e69815"
SRC_URI[sha256sum] = "35fb00bed65a11de5c901fd9b32608bf2fb172d2428779f06489837910b09684"
SRC_URI[md5sum] = "da3c1ec894314a469e93c344f01a9cd5"
SRC_URI[sha256sum] = "9ffc587372fa9bb0b966322977cfdfdb52f2233c0ce15c07fb1447148faec08d"
S = "${WORKDIR}/${ROS_SP}/${ROS_BPN}"