26 lines
1.0 KiB
Diff
26 lines
1.0 KiB
Diff
From cf6a9100902484e4d028ee88742dd2487b014a98 Mon Sep 17 00:00:00 2001
|
|
From: Alexander Kanavin <alex.kanavin@gmail.com>
|
|
Date: Wed, 30 Jan 2019 12:41:04 +0100
|
|
Subject: [PATCH] Makefile.pre: use qemu wrapper when gathering profile data
|
|
|
|
Upstream-Status: Inappropriate [oe-core specific]
|
|
Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
|
|
---
|
|
Makefile.pre.in | 3 +--
|
|
1 file changed, 1 insertion(+), 2 deletions(-)
|
|
|
|
diff --git a/Makefile.pre.in b/Makefile.pre.in
|
|
index a3a02a7..d5503dd 100644
|
|
--- a/Makefile.pre.in
|
|
+++ b/Makefile.pre.in
|
|
@@ -507,8 +507,7 @@ build_all_generate_profile:
|
|
$(MAKE) @DEF_MAKE_RULE@ CFLAGS_NODIST="$(CFLAGS_NODIST) $(PGO_PROF_GEN_FLAG)" LDFLAGS_NODIST="$(LDFLAGS_NODIST) $(PGO_PROF_GEN_FLAG)" LIBS="$(LIBS)"
|
|
|
|
run_profile_task:
|
|
- @ # FIXME: can't run for a cross build
|
|
- $(LLVM_PROF_FILE) $(RUNSHARED) ./$(BUILDPYTHON) $(PROFILE_TASK) || true
|
|
+ ./pgo-wrapper ./python -m test.regrtest --pgo test_grammar test_opcodes test_dict test_builtin test_exceptions test_types test_support || true
|
|
|
|
build_all_merge_profile:
|
|
$(LLVM_PROF_MERGER)
|