meta-ros/recipes-ros/ros-controllers/joint-trajectory-controller/0001-check-for-CATKIN_ENABL...

91 lines
4.1 KiB
Diff

From 9729165a4725b2a70d6c8d3690da76213bc8b5ec Mon Sep 17 00:00:00 2001
From: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
Date: Thu, 10 Apr 2014 07:31:32 +0200
Subject: [PATCH] check for CATKIN_ENABLE_TESTING
Upstream-Status: Accepted
---
joint_trajectory_controller/CMakeLists.txt | 44 ++++++++++++++++--------------
joint_trajectory_controller/package.xml | 2 +-
2 files changed, 24 insertions(+), 22 deletions(-)
diff --git a/joint_trajectory_controller/CMakeLists.txt b/joint_trajectory_controller/CMakeLists.txt
index a1a3c4d..afc792d 100644
--- a/joint_trajectory_controller/CMakeLists.txt
+++ b/joint_trajectory_controller/CMakeLists.txt
@@ -102,35 +102,37 @@ else()
LIBRARIES ${PROJECT_NAME}
)
- catkin_add_gtest(quintic_spline_segment_test test/quintic_spline_segment_test.cpp)
- target_link_libraries(quintic_spline_segment_test ${catkin_LIBRARIES})
+ if(CATKIN_ENABLE_TESTING)
+ catkin_add_gtest(quintic_spline_segment_test test/quintic_spline_segment_test.cpp)
+ target_link_libraries(quintic_spline_segment_test ${catkin_LIBRARIES})
- catkin_add_gtest(trajectory_interface_test test/trajectory_interface_test.cpp)
- target_link_libraries(trajectory_interface_test ${catkin_LIBRARIES})
+ catkin_add_gtest(trajectory_interface_test test/trajectory_interface_test.cpp)
+ target_link_libraries(trajectory_interface_test ${catkin_LIBRARIES})
- catkin_add_gtest(joint_trajectory_segment_test test/joint_trajectory_segment_test.cpp)
- target_link_libraries(joint_trajectory_segment_test ${catkin_LIBRARIES})
+ catkin_add_gtest(joint_trajectory_segment_test test/joint_trajectory_segment_test.cpp)
+ target_link_libraries(joint_trajectory_segment_test ${catkin_LIBRARIES})
- catkin_add_gtest(joint_trajectory_msg_utils_test test/joint_trajectory_msg_utils_test.cpp)
- target_link_libraries(joint_trajectory_msg_utils_test ${catkin_LIBRARIES})
+ catkin_add_gtest(joint_trajectory_msg_utils_test test/joint_trajectory_msg_utils_test.cpp)
+ target_link_libraries(joint_trajectory_msg_utils_test ${catkin_LIBRARIES})
- catkin_add_gtest(init_joint_trajectory_test test/init_joint_trajectory_test.cpp)
- target_link_libraries(init_joint_trajectory_test ${catkin_LIBRARIES})
+ catkin_add_gtest(init_joint_trajectory_test test/init_joint_trajectory_test.cpp)
+ target_link_libraries(init_joint_trajectory_test ${catkin_LIBRARIES})
- add_rostest_gtest(tolerances_test
- test/tolerances.test
- test/tolerances_test.cpp)
- target_link_libraries(tolerances_test ${catkin_LIBRARIES})
+ add_rostest_gtest(tolerances_test
+ test/tolerances.test
+ test/tolerances_test.cpp)
+ target_link_libraries(tolerances_test ${catkin_LIBRARIES})
- add_executable(rrbot test/rrbot.cpp)
- target_link_libraries(rrbot ${catkin_LIBRARIES})
+ add_executable(rrbot test/rrbot.cpp)
+ target_link_libraries(rrbot ${catkin_LIBRARIES})
- add_dependencies(tests rrbot)
+ add_dependencies(tests rrbot)
- add_rostest_gtest(joint_trajectory_controller_test
- test/joint_trajectory_controller.test
- test/joint_trajectory_controller_test.cpp)
- target_link_libraries(joint_trajectory_controller_test ${catkin_LIBRARIES})
+ add_rostest_gtest(joint_trajectory_controller_test
+ test/joint_trajectory_controller.test
+ test/joint_trajectory_controller_test.cpp)
+ target_link_libraries(joint_trajectory_controller_test ${catkin_LIBRARIES})
+ endif()
# Install
install(DIRECTORY include/${PROJECT_NAME}/
diff --git a/joint_trajectory_controller/package.xml b/joint_trajectory_controller/package.xml
index bc2ab39..54ba444 100644
--- a/joint_trajectory_controller/package.xml
+++ b/joint_trajectory_controller/package.xml
@@ -13,7 +13,7 @@
<author>Adolfo Rodriguez Tsouroukdissian</author>
- <buildtool_depend>catkin</buildtool_depend>
+ <buildtool_depend version_gte="0.5.68">catkin</buildtool_depend>
<build_depend>cmake_modules</build_depend>
<build_depend>actionlib</build_depend>
--
1.8.3.2